Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win ERROR meaasge for AOMEI Backupper Professional Edition 2.5

29 Apr 2015   #1

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit
Win ERROR meaasge for AOMEI Backupper Professional Edition 2.5

Just yesterday installed AOMEI Backupper Professional Edition 2.5 in Win 7 Pro SP1 64-bit, but the Event Viewer in Win 7 shows an error at about the time of the install and the first time I turned it on and looked at it:
"Activation context generation failed for "C:\Program Files (x86)\AOMEI Backupper\MFC80U.DLL". Dependent Assembly Microsoft.VC80.MFCLOC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",ver sion="8.0.50608.0" could not be found. Please use sxstrace.exe for detailed diagnosis."
► So, what's the problem, and what should I do? ◄

Please don't suggest I use "sxstrace.exe" - I have no idea what that is. I'm only a lawyer, not a tech person. Or I suppose I could but would have no idea what to do with it.

Now, there are a few details to consider.

First, I downloaded this AOMEI Backupper Professional Edition 2.5 yesterday from Giveaway of the Day and registered with the serial number given in its readme.txt file. It seemed to install and register OK.

Second, on my Win 7 PC, the following are always running: Avast Home Free AV, Malwarebytes Anti-Exploit Free, and CryptoPrevent (from Foolish IT). CryptoPrevent is passive - it imposes many particular user settings that try to prevent any ransomware from running. I suppose it's possible for one of these to cause the above problem with MFC80U.DLL. But that's NOT likely, as CryptoPrevent mostly tries to prevent .exe files from running in the Applications folders (where ransomware apparently likes to hang out). (Please check out CryptoPrevent yourself for a better explanation than I can give.)

My Event Viewer also has this information in "Details":
- System
- Provider [ Name]
SideBySide - EventID 33
[ Qualifiers] 49409
Level 2
Task 0
Keywords 0x80000000000000 -
TimeCreated [ SystemTime] 2015-04-28T16:16:15.000000000Z
EventRecordID 8979
Channel Application
Computer [My computer name]
Security - EventData Microsoft.VC80.MFCLOC,processorArchitecture="x86",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",ver sion="8.0.50608.0" C:\Program Files (x86)\AOMEI Backupper\MFC80U.DLL

So, what should I do?


My System SpecsSystem Spec
29 Apr 2015   #2
Victor S

Windows 7 Ultimate x64

Cut your time losses by uninstalling it. Unless you're okay with crippleware. My understanding of Giveaway is that the software they provide can only be installed on the day you download it - it checks the website. I haven't personally used the site, so that's a caveat. But I would go the normal trial/purchase route for essential software.
My System SpecsSystem Spec
29 Apr 2015   #3

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit

Victor - Sorry, but disagree.

Most of the offers on Giveawayoftheday are uninteresting, but a few are good. Aomei is one of the better vendors, and their other products have been helpful to me. An earlier version of this that I had run on my old XP machine saved my tushy when that old XP machine blew up in the middle of extended tax season last August.

This isn't about Giveawayoftheday. It's about the specific error message I received. Any helpful thoughts?
My System SpecsSystem Spec

29 Apr 2015   #4

W10 Pro desktop, W10 laptop, W10 Pro tablet (all 64-bit)

It may be too late for you to do this but did you try to uninstall/reinstall? I installed the program yesterday from the Giveawayoftheday site on my 64-bit Win 8.1 machine and didn't encounter the error.

In case you're not aware, AOMEI is currently running a special where you can buy the Pro version of the software with lifetime upgrades for $19.60 (regular price $49). At that price I couldn't resist so I bought 2 licenses (each license is good for 2 PCs).

Lifetime Free Upgrades for GOTD Users - AOMEI Backupper Professional
My System SpecsSystem Spec
29 Apr 2015   #5

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit

Strollin - as it turns out, I had exactly the same error message before in 8.1 when I installed Aomei Partition Assistant Pro Edition 5.6 (also from Giveaway) a few months ago.

See MFC80U.DLL missing or wrong - error message - aomeitech .

It's the same actual PC - an Optiplex 7010MT on which I am dual-booting Win 7 Pro SP1 64-bit and Win 8.1 Pro 64-bit.

So I am getting the same error message in both 7 and 8.1 for two different products from Aomei.

Does anyone know what the error message means, or how one could fix MFC80U or its related files?
My System SpecsSystem Spec
29 Apr 2015   #6

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit

After some more research, it might be that the Aomei programs are looking for a YEAR or a VERSION of MS Visual C++ Redistributable that I don't have on my PC.

Maybe they are looking for 2005 C++ Redistributable version 8.0.50608.

I don't think I have any version of 2005 C++ Redistributable (yet), and maybe the only version available today is 8.0.5727 ??

How should I proceed?
My System SpecsSystem Spec
29 Apr 2015   #7

W10 Pro desktop, W10 laptop, W10 Pro tablet (all 64-bit)

Typically, when a program needs a certain version of a C++ redistributable, it installs it as part of it's install.

Have you tried contacting AOMEI tech support? Edit: I see from your link that you have been on their support forum.

You might try cleaning up your registry with something like CCleaner.
My System SpecsSystem Spec
29 Apr 2015   #8

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit

Strollin - yeah. See the link above. More for my practice and education, how should I proceed to install the 2005 C++ Redistributable if the version expected by Aomei is older than the version now provided by MS? Maybe just install the latest version and see if it fixes the problem?
My System SpecsSystem Spec

 Win ERROR meaasge for AOMEI Backupper Professional Edition 2.5

Thread Tools

Similar help and support threads
Thread Forum
Aomei Backupper Free now has Universal Restore
Extra new feature in Backupper v2.5 - also in the free (standard) version. I think it is the only program which has that in the free version. Free Windows 10, Windows 8.1/8, Windows 7 Backup Software - AOMEI Backupper Standard For Win7
Backup and Restore
AOMEI Backupper Pro 2.0.1 Giveaway (CNET)
Get your free copy of AOMEI Backupper Pro | Software Deals - CNET Free License Code of AOMEI Backupper Pro 2.0.1 for Users Valid until August 5th A Guy
Mounting with Aomei backupper
A lot of you are using this, and here is how you mount and manage your existing backup images. 1. To Manage They are usually listed under the Home tab. The dropdowns provide the functions If an image is not listed ( if you have just restored, or repartitioned, then it may not be),...
Free Giveaway: AOMEI Partition Assistant Professional Edition
And Aomei Dynamic Disk Manager Pro Edition Source A Guy

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:12.
Twitter Facebook