Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Clone failure with three different software programs

09 Jun 2015   #1
Deaf Dave

Windows 7 64-bit Home Premium
Clone failure with three different software programs

I have Win 7 64 bit Home Premium SP1. I have tried to clone my 2TB internal hard drive to the same size external hard drive. I have been doing this for a number of years and never had a problem until the other day.
Macrium Reflect Free v.5.2.6504 clone failed 3x.
Macrium said; "Clone failed - Read failed - 22 - Broken pipe"
EaseUS clone failed as well and no error messages appeared.


I also tried a clone with Acronis. It failed as well.Acronis said;

"Failed to read data from the disk". "Failed to read sector 686,886,784 of hard disk '2'. "Try to repeat the operation. If the error persists, check the disk using chkdsk utility and create a backup of the disk. Direct R/W operation has failed (0x69001). Input/output error (oxFF1).

I tried to repeat the operation 3x and each time it failed. In addition, when Acronis closed, it deleted all the partitions on the external drive except for System. The deleted partitions (3) are now one partition and is listed as unallocated.

After the first failure, I read somewhere that the VSS service needs to be started. It was already marked as automatic. The VSS function is started on the internal drive (I had to physically change it from stopped to started but left it as automatic) but I do not know how to check it on the external drive I'm cloning to. I did run chkdsk (auto fix file system errors and scan for and recover bad sectors) on the external drive and it appears there were no errors. At least no message appeared saying there were any problems and/or corrections. Why would the destination drive even need VSS start checked, if all the info is being overwritten anyway?
Any help would be greatly appreciated.

My System SpecsSystem Spec
13 Jun 2015   #2
Deaf Dave

Windows 7 64-bit Home Premium
Update to "Clone failure with three different software programs"

I'm replying to my own thread and not sure if this is the correct way to give an update on my situation. However, since I posted the "Clone failure with three different software programs" I've spent a lot of time on this problem . I previously failed to note that I ran sfc\scannow and it showed two corrupt files that could not be repaired:
(Info CSI 000001c1 [SR] cannot repair member file [l:24{12}]"" of Microsoft-Windows-Unified-Telemetry-Client, Version = 6.1.7601.18869, PA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch).

(Info CSI 00000319 [SR] Cannot repair member file [l:66{33}]"telemetry.ASM-WindowsDefault.json" of Microsoft-Windows-Unified-Telemetry-Client, Version = 6.1.7601.18839, PA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch)
I also failed to note that the last successful clone I did was two days (5-10-15) before the Microsoft updates on 5-12-15. Those updates included KB3022345 which i have learned through Seven Forums thread about KB3022345, is what I think has corrupted my files so the VSS could not read them. This is what I believe caused my last cloning attempts to fail. Using the instructions supplied by Ehasanov in that thread, hopefully it will fix those related problems as well as my clone problem. I will provide another update when I have done so. This is not the first time the Microsoft updates have caused problems for me and others as well. Regards, Dave
My System SpecsSystem Spec
20 Jun 2015   #3

Win 7 both 32 & 64
What I did as to the SFC errors

To fix the SCF error remove KB3022345 Update

The good news is that the service is optional even though it is listed
as recommended on the system.
DiagTrack can be uninstalled easily. Proceed exactly as follows:

Control Panel > Program and Features > View Installed Updates
  • Type KB3022345 in the search bar
  • Wait until found (if not found than proceed to KB3068708 below)
  • Select Uninstall.
(That did not solve the problem ... because KB3022345 was replace by KB3068708

Therefore I uninstalled KB3068708)
  • Type KB3068708 in the search bar
  • Wait until found
  • Select Uninstall.
There are remnant files: diagtrackrunner.exe in two locations.
  • C:\Windows\winsxs\amd64_microsoft-windows-a..xperience-inventory_31bf3856ad364e35_6.1.7601.18868_none_e83d75d9e59ba1ea
  • C:\Windows\System32\CompatTel
Do not delete diagtrackrunner.exe in either location as SFC will ID the missing files

Also, there are two of three services that I stopped:
Start Services by Typing into the Search window: "services.msc" (not the quotation marks!)

Locate the following services as they are related
  • Diagnostic Policy Service Automatic - Started (leave this alone)
  • Diagnostic Service Host Stop it then Disable it
  • Diagnostic System Host Stop it then Disable it
These issues may be the reason that you had the failures.

My System SpecsSystem Spec

20 Jun 2015   #4
Deaf Dave

Windows 7 64-bit Home Premium

Hi Dennis, Thank you for your response. I'm replying on my backup PC as the main one will not boot. I prevented both KB 30223545 and KB3068708 from being installed on this backup PC. When (if) I can get into the main PC hard drive (ED5S) I will use your suggested fixes (diagtrackrunner.exe and stop services). I have given a more detailed synopsis of what my problems are below. I have Win7 Home Premium SP1 64bit.

I tried to do a clone on 6-7-15 and it failed. After it failed, I found that three partitions on the disk I was cloning to "GQ0T" had been completely erased. The drive had been cloned before successfully last month on 5-11-15 from the same internal drive "ED5S". The hard drive I was cloning from "ED5S" , had (C:) drive letter changed to (E:). Other partition letters on "GQ0T" were changed as well! This is NOT supposed to happen! As a result, the hard drive "ED5S" is no longer bootable! I suspect the reason for the clone failure on 6-7-15 was recent MS updates that were corrupted and prevented reading to the VSS service. The MS updates were: KB3022345 and KB3068708. However, a clone failure should not cause the problems it did! Erasing partitions on the drive being cloned to "GQ0T" and changing drive letters on the drive "ED5S" being cloned. Fortunately none of the drive's information on "ED5S" was deleted but the drive is not usable!

I used another hard drive "MR3T" that had been cloned at an earlier date and swapped out the corrupt drive "ED5S" that will not boot. I then attached "ED5S" and was then able to see that all the partitions were intact and it appears that no folders/files were deleted and the total GB used was still the same but the drive letters had been changed. The O/S (C:) drive letter was changed to (E:). The (E) is for my CD/ROM. Naturally Windows can't boot from an empty (E:) drive. Anyway, I did a SFC /SCANNOW on the corrupt drive "ED5S" and the scan picked up two corrupt files: KB3022345 telemetry.ASM-WindowsDefault.json and "" . KB3068708 has these same issues. SFC /SCANNOW could not fix these. I deleted the updates using elevated command prompt and this program ( Inaddition, I had previously run chkdsk C: /F /R for disk "ED5S" and chkdsk replaced two bad clusters.

I also ran F-8 from a rescue CD to repair startup on "ED5S" which found the (C) drive misnamed as (E). Startup repair reported fixing this but when I installed the drive back in the PC it still would not boot. The (C) drive still shows as (E) when I used a rescue CD to access F-10 to check the boot order. I'm at a loss as to how to proceed from here to fix the boot menu and drive letter reversal problem. Any help or advise provided would be greatly appreciated.

Thank you, Dave
My System SpecsSystem Spec
21 Jun 2015   #5

Win 7 both 32 & 64
Clone Failure suggestions


There is quite a number of issues.

My concern is rooted in the thought that your receiving hard drive is by now corrupted.
Plan A:
Locate a rescue DVD/USB or Win 7 Install Disk and attempt a non-destructive system restore see:
Win7’s no-reformat, nondestructive reinstall

I have used the above twice with excellent results. Make sure that you accurately follow the steps in sequence.
Unfortunately, this may well fail because of a corrupt HD which may mean a format-drive. At least this approach may save your data files.

If you can get your system to boot then re-consider restoring a known-good image.
Plan B:
The dreaded: Reformat HD and reinstall System; Apps; Data.

My System SpecsSystem Spec
21 Jun 2015   #6
Lady Fitzgerald

Win 7 Ultimate 64 bit

A corrupted drive will often prevent a clone from succeeding, even if data can still be accessed on it. I had it happen to one of my data drives. When I tried to clone it to a backup drive, the clone failed, taking out the data on the backup drive (yikes!). Fortunately, I had a second backup drive. After reformatting both the data drive and the damaged backup drive, I cloned the second backup drive back to the reformatted data drive, then cloned the data drive to the reformatted first backup drive.
My System SpecsSystem Spec
21 Jun 2015   #7
Deaf Dave

Windows 7 64-bit Home Premium
Clone failure with three different software programs

Oh Boy! Lots to digest for this here Neophyte! Having said that, as to Dennis' suggestion of restoring to a known good image, the drive (ED5S) will not boot. There is a lot for me to digest in the second suggestion to "attempt a non-destructive system restore". Please bear with me as I'm very confused at this stage.

As to Lady Fitzgerald's suggestions, I do not know for certain if the clone failure destroyed anything that was on drive being cloned from disk (ED5S) to disk (GQ0T) as I currently can't access the ED5S drive. After the Clone failure, I did try to Image the ED5S drive to GQ0T using Acronis. That too came up as failed. However, after taking a good drive (MR3T)that had previously been cloned and switching drives, I was able to see in Disk Management that all of the previous partitions in GQ0T were erased except the System partition. And 376GB of 397Gb showed on GQ0T in new partition (I:). So hopefully only 21 GB was lost in the Imaging process on drive GQ0T.The drive being cloned to (GQ0T), I have not touched yet for fear of any potential further damage! I have reason to believe that in addition to the failure, the drive letters were changed in ED5S which I think would cause a boot failure as well. I tried changing them back using a system repair disk but the disk still failed to boot. I was able to run chkdsk C: / F / R on ED5S which said two bad clusters were replaced. sfc/scannow could not repair either of them. The drive still will not boot...

So, Lady Fitzgerald, my question is - I do have a good drive MR3T that was Cloned a number of months ago. It does boot. How exactly do I go about trying to restore everything in the corrupt ED5S drive that won't boot? I'd really hate to have to resort to trying Dennis' fixing remedy being unsure if that Image is a good one, unless I have to, if this would be easier and/or less time consuming and/or less likely for me to make any mistakes?
Thank you both,
My System SpecsSystem Spec
21 Jun 2015   #8
Lady Fitzgerald

Win 7 Ultimate 64 bit

Ok, if you have a good drive that you can clone (not image) to the corrupted drive, you can first format the corrupted drive, then use Macrium Reflect to clone the good drive to the reformatted drive. If the reformatted drive isn't damaged, the clone should succeed. If it fails, it will because either the reformatted drive is bad or the drive you are cloning from is corrupted, even though not enough to keep it from booting. One good thing about Macrium Reflect, it leaves the source drive untouched.
My System SpecsSystem Spec
21 Jun 2015   #9
Deaf Dave

Windows 7 64-bit Home Premium
Clone failure with three different software programs

Lady Fitzgerald, Thank you for your quick reply. Sorry mine is not as quick. OK, I have a good drive (MR3T) that I can Clone from. It's an older Clone from 10-10-14 and I hooked it up to make sure it would boot and that everything was there. Everything was ok. Except for all the necessary program and MS updates and any files and folders etc I created in the interim .

I have a question(s). When I format the corrupt drive (ED5S) will all the info on the drive be erased by re-formatting it? I have, or maybe had, 397GB of information on it that I do not want to lose if it's still there.

Secondly, if I clone the good drive (MR3T) to the corrupt one, won't that process replace all the info on it with the info from the drive I'm cloning from?? If so, I need to avoid doing that and in the process erasing anything that may be on the corrupt drive. I need to find a way to retrieve the info from the corrupted drive.

As mentioned before, I have the drive that after the Clone failed, I again used Acronis to this time make an Image instead of a Clone. I named the partition (I:) to replace the three partitions that Acronis had erased. Anyway, I think there may be 376GB that was actually Imaged before the Image failed to completion. Would there be some way to retrieve that info from the Image and then transfer it to a brand new bare drive?
If so, could you please tell me how to do so.
My System SpecsSystem Spec
22 Jun 2015   #10
Lady Fitzgerald

Win 7 Ultimate 64 bit

Yes, formatting a drive will erase everything on it. Are you able to read the data on the corrupted drive even though it doesn't boot?
My System SpecsSystem Spec

 Clone failure with three different software programs

Thread Tools

Similar help and support threads
Thread Forum
What free software is best to clone/image hard drive please?
Good evening, I got an old laptop running XP Pro for my sister and have managed to set it up so she has everything that she needs, programs etc and it is running nicely. My question is, what do you guys use to clone/image your hard drives? I ask this question because I know in the not too...
Backup and Restore
What software to use with SSD clone and for backup too? Many Choices!!
Hi I have few questions. Let me explain my situation. I picked up the 512 GB Samsung 840 Pro SSD to install in my Dell 17R N7110 laptop with the 64 bit Windows 7 Ultimate OS. To replace the stock 1 TB hard drive requires removing the keyboard, palm rest, optical drive and some more items. It is...
Hardware & Devices
Hardrive Failure? or Software?
my old system, roughly 2 years old(my dad is currently using it) has failed to boot. unfortunately i wasn't thinking when i had it build and put the operating system on a raid 0 array. Now Windows 7 is running startup repair. This only happened just then and so i don't know if it will succeed or...
Hardware & Devices
Looking for programs/software will clone or copy my system drive...?
Looking for programs/software will clone or copy my system drive for immediate recovery on separate hard drive? Hello. I have a question. What is the best software or even the best means for me to make a real time copy or clone of my system hard drive on a separate physical disk to record...
HDD clone software
Any software recommendations for cloning a SATA-I drive on mobo with Windows 7 installed to SATA-II drive on PCI controller card? I may need to do this for someone. Is Acronis Disk Director Suite "copy partition" function able to do this upon a reboot when windows is not yet loaded? It seems...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:24.
Twitter Facebook Google+