Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Attempting .bat Robocopy to USB drive, various errors

27 Oct 2015   #1
Ryanshaq

Windows 7 Enterprise 64bit
 
 
Attempting .bat Robocopy to USB drive, various errors

Apologies if the solution is found in another thread, but I have been unable to solve my problem so far.

I'm attempting to use Task Scheduler, to backup a folder of my projects to a 1 Tb USB drive via robocopy. I've been at this off and on for several days now, and I have had varying degrees of success. I work at a corporate company where IT can be strict. I have admin rights to my machine but I feel like I am still fairly restricted.

Currently, I have a .bat file, that when I run, it fails because I do not have backup and restore file user rights. Great. I get that. That is not my main problem. I know I need to change permissions some how. As far as I can tell, I have admin rights to all of the appropriate folders. I checked by right clicking, looking at security and seeing my user name in the groups and seeing that I have Full control, modify, read & execute, etc.

C:\Users\"MyUserName"\ - Full control
C:Users\"MyUserName"\_Projects - Looks like I have inherited full control rights

Side note, This may seem very noobish but I don't remember all of the folders being -Read Only- before. Not sure if this is a problem or if I did something to cause this.

Back to my main problem. At some point, I was able to run an iteration of my .bat file successfully, when I ran it manually. It copied all of the files I wanted to the correct USB drive. It was only once I tried to add it to Task Scheduler, the .bat file would fail. I looked through several forum posts describing that users needed to use a UNC path in order to back up to their network drive. However, I'm not using a network drive. I wasn't able to find out if there was a UNC path or not to a USB drive.

The errors that I have encounteres so far are: 0x1, 0x10, 0x8007052E

How can I set up a simple automated backup solution to a portable 1Tb USB drive?


Here is my current .bat file.

@echo on
robocopy C:\Users\MyUserName\_Projects E:\Project_BackUps /COPY:DAT /MIR /XJD /XJF /R:0 /NP /tee /B /LOG:BackUps_LogFile.txt

My task in Task Scheduler had the following selected:
-Run whether user is logged on or not
-Run with Highest Priviledges
-Configure for Windows Vista, Windows Server 2008
-Program/Script C:\Users\MyUserName\BackupProject.bat
-Star in (Optional): C:\Users\MyUserName\
- All 3 power options enabled under the Conditions tab
-Allow task to be run on demand


My System SpecsSystem Spec
.
02 Dec 2015   #2
Ryanshaq

Windows 7 Enterprise 64bit
 
 

Any ideas?
My System SpecsSystem Spec
Reply

 Attempting .bat Robocopy to USB drive, various errors




Thread Tools




Similar help and support threads
Thread Forum
WD Passport Crash, Multiple Errors While Attempting Recovery
Have an older model 1tb WD My Passport as a primary drive for photos and such. This is one of the stupid externals with no SATA connections, it's USB only. Was transferring about 1gb worth of files onto it two days ago when the drive suddenly made unusual noises (two clicks, a beep, and another...
Hardware & Devices
Errors 8E5E03FB and 9C57 when attempting to install updates
Hi, first time posting here, so please tell me if I'm missing anything needed. When looking up how to get my free upgrade to Windows 10, I found that the taskbar icon for registering was not there. I then found out that it was part of an update, so I went to Windows Update to install it. Upon...
Windows Updates & Activation
Is it safe to use Robocopy /mir on root drive?
I am backing up an entire drive to a external hard drive using Robocopy. Is it safe to use /mir on root drives? I've read somewhere that it's not recommended as it copies the hidden folders $RECYCLE.BIN and System Volume Information and may cause issues on the destination drive. Is there anything...
General Discussion
Attempting to setup MS Live Mail but receiving errors
Greetings, The AT&T email site that I have been using for email is finally getting on my nerves. I can't sort by name any longer, and the ads are very annoying. So, I want to use MS Live Mail. However, once I set up the account, and receive/send, I get the following error. Unable to send...
Browsers & Mail
Attempting repairs... Reparing disk errors.
Plz help my computer that ive had for about a week now was running fine starting up and all that was good. Then the other day i started it up but it was stuck on starting windows so i tried restarting it and it put me in startup repair so i left it on for about 8 hours and it was stuck on the sam...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:52.
Twitter Facebook Google+