Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No USB ports detected when trying to restore image

01 Nov 2016   #1

Windows 7 Professional x64
No USB ports detected when trying to restore image

I have a custom built laptop running Windows 7 Professional x64 with 2x USB2 and 2x USB3 ports. The USB3 ports have always been temperamental - working for a short while then seemingly disconnecting - so I rarely use them. The USB2 ports have always worked fine.

My problem is this - I have used backup software for a long time on a previous Win7 laptop with no issues (that was USB2 only). But this newish one is a nightmare. It will create a system image to external HDD easily enough. However, when I use the software image Live CD, (on either USB or CD), the USB2/3 works to start the backup software but then no USB devices are detected when it's running: including the mouse, external HDD or even the flash drive I used to start the software to begin with. It also makes no difference which Image Backup software I use.

I read up on what the problem might be and it seemed that maybe it was that USB3 doesn't play nicely with Win7. I followed the advice other people got to create a Live CD with USB3 drivers on and if necessary manually install from within the Image software - I got a message that the drivers had installed correctly but still none of the USB ports worked. I also tried removing and putting back in the plugged in devices to 'wake up' the USB ports but that also didn't work.

I looked in the BIOS and there is no option to disable or downgrade USB3.

In a last ditch attempt I installed Win 8.1, as I had read that that has native support for USB3, it made no difference - still no USB devices detected when Live CD running. Since I prefer Win 7 I have now reinstalled it, but ideally I would like to install the image that I had made about a week ago.

I have fairly basic computer knowledge but any help would be greatly appreciated. Thank you.

My System SpecsSystem Spec
02 Nov 2016   #2

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Hello and welcome Sharkie mate very hard to help without knowing what is in the machine please do this
System Info - See Your System Specs or just use the system specs in your profile.

Just one thing I would ask well two really have you updated the drivers for the USB's and if you are using an SSD and it is a Samsung have you loaded the Samsung Magician software - something I know that will make access to the USB ports go down because it has happened to me.

Plus between OS's did you clean the drive first before installing the next OS?

But the specs are what we need because we cannot direct you to the drivers until we know what you have component wise.
My System SpecsSystem Spec
03 Nov 2016   #3

Windows 7 Professional x64
Thank you!

I'm sorry it's taken so long to reply - I've been up so long trying to sort this out and I just crashed.

I downloaded the 'My System Specs' file, unfortunately I couldn't get it to run as I didn't have .net framework installed and Windows Update wouldn't work to download it.

I have solved the problem though.

I ran the system image software Live CD until it loaded the program but then ejected the CD while the program was still running and put in the main software drivers CD then loaded the drivers from that. Voila! It worked!

Apparently it would only load the drivers from the driver CD - not copies I had put on HDD that I could access through Live CD 'Explore My Computer' option, or even copies loaded onto the Live CD itself when I created it. Hopefully this may help someone in the future.

I have now written those instructions onto the label of my Live CD to remind me in the future.

I've now restored the system image to just a few weeks ago - it also wrote over the residues from the Win 8 and new Win 7 installation that I had tried. I am a happy Sharkie again!

I want to thank you for trying to help me - I really appreciate it. Thanks!

[QUOTE=ICIT2LOL;3294172]Hello and welcome Sharkie mate very hard to help without knowing what is in the machine please do this
System Info - See Your System Specs or just use the system specs in your profile.
My System SpecsSystem Spec

03 Nov 2016   #4

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Ok Sharkie glad it is ok now. Just in case you want to post in the future all you need to do is go to your User CP at the top of this post page and it will give you options for a lot of things and one is the specs of your system see pics of mine

If ypu want to fidn out exactly what you have use this - PART B:
Using HW Info
You can test the volts on the PSU with HW Info HWiNFO, HWiNFO32/64 - Download < download the right bit version and close the right hand window select Sensors and scroll down to the power section where you will see what the volts are doing see my pic. Now the section you want will be labelled - fpr example Asus boards usually have "Nuvoton" and Gigabyte boards "ITE" in any case the section you want will have Vbatt or VBAT in it (dead give away)
The original right hand window shows the machine running and is handy for that but for looking at the components in some detail close it and use the main left hand side panel
Open each small square with + in it on the section the components are in and then click on the individual component/s (it will highlight in blue) - in the right hand side will appear all sorts of details including brands speeds and other essential info that particular device. See pic for example.

Attached Thumbnails
No USB ports detected when trying to restore image-profile.png   No USB ports detected when trying to restore image-profile-2.png   No USB ports detected when trying to restore image-hw-info-devices.png  
My System SpecsSystem Spec

 No USB ports detected when trying to restore image

Thread Tools

Similar help and support threads
Thread Forum
How to restore windows 7 image created in EFI to restore in UEFI mode
Hello, first let me introduce myself, I am new to Seven forums, I am an expert in Windows OSes...... Now lets get to the question, I want to change my hard disk's partition table to GPT (its currently in MBR partition table) for that i created a system image of my windows 7, its currently booting...
Backup and Restore
USB Ports disabled after placing image on PC
Hello, I have 2 Lenovo think center m93P type 10a9 model 0014us. I have deployed my image on these 2 machines like I have done 100's of times on all different types of machines ranging from other lenovo system, HP, dell etc. I had recently updated the image that I am using to include some...
Backup and Restore
Restore from an image without an entry present in System Restore
Hi, I've made a restore point using system restore and saved the image onto my external HDD and later restored it to its factory state using Dell Local Backup. However, now that I want to restore from the image on my external HDD, I can't find the entry in system restore since I've restored...
Backup and Restore
Factory Restore not working, error 0xe0ef000d, Image Restore?
Hello people. I'm new to this so please bear with me. Okay so I'll give a brief explanation of what's going on. So a couple of years ago I gave my old computer(HP Pavillion p2 Series /with Windows 7 home) to my younger siblings, because I moved and got a new computer for school. I put a secure...
Backup and Restore
USB device not detected by all USB ports after fresh install of window
Hi guys, I know this is forum for Windows Seven. I'm just taking chances if someone can help me about my current computer problem regarding XP SP2. So here it's. My friend bring me his old Mobo (IBM Rev 1.6) and made a clean install of windows XP SP3 at first. After installing all drivers and...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:06.
Twitter Facebook Google+