Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Requesting Help With Windows 7 Partitions

30 Jun 2017   #1
Windows7Nubie

Windows 7 Pro 32bit and Windows 7 Pro 64bit
 
 
Requesting Help With Windows 7 Partitions

Hello Everyone,

Is it now REQUIRED that the boot partition for Windows 7 be separate from the partition with the OS files? Is there now a REQUIRED ORDER to the partitions on a Windows 7 disk.

Here is why I am asking:
Years ago I setup my system.

I have 7 hard disk drives in my system box.
Each drive has a power switch that can be actuated when the system is powered down to determine which drive I will be using/booting.
Each drive has a different setup, and is bootable.
3 of my drives are Windows 7 Pro 64 bit.
The other 4 are Windows XP Pro 32 bit.

Recently I decided to use an image of a Windows 7 drive to change one of the Windows XP drives to become a Windows 7 drive.

I deleted the Windows XP partitions to make the drive appear as completely unallocated space.
Then I tried to restore a Windows 7 image to that drive.
The program I am using is the latest version of Acronis Backup PC run from a Windows PE 3.0 CD.

The problem I think I am having is two pronged.
One is that the controller of the formerly XP disk is a Marvell and the controller of the disk that provides the Windows 7 image is an Intel. This should be handled by Universal Restore which is a part of the Acronis program.

Two, when I setup my 3 Windows 7 disks, I did NOT create a separate boot partition. I have one active partition that has both the boot files and OS files, and I have a second (D) non-bootable primary partition that just has data.

This appears to confound the Acronis program which forces the data partition (D) to appear first on the restored hard disk and the OS/boot (C) partition appears as a second partition on the restored disk.

I cannot get the restored drive to boot even though all the files are there.

I know with earlier versions of the Acronis program I have done restores of my Windows 7 disks on the intel controller successfully. And I have been doing backups regularly assuming that they would always restore.

Now I am worried that my backups created with the later versions of the Acronis program will not be restoreable because Acronis is assuming the presence of the 100MB boot partition and when I have none, it cannot cope.

Before I go opening a ticket with them that I will have to pay for, I would like to know is it required now with whatever Service Pack MS is up to that there be a separate boot partition and is there a required order to how the partitions appear on the hard disk?

Thanks for whatever guidance you can offer.


My System SpecsSystem Spec
.
30 Jun 2017   #2
samuria

win 8 32 bit
 
 

Can you post a screenshot of the partitions so we can see? Is this MBR. Disk with MBR you can't boot to a partition past 2gig as there isn't enough code space
My System SpecsSystem Spec
30 Jun 2017   #3
Windows7Nubie

Windows 7 Pro 32bit and Windows 7 Pro 64bit
 
 

Thank you for the reply, samuria.

I do have the motherboard set to use BIOS not efi.
There is a MBR which I restored from the Windows 7 image backup.
The Windows 7 partitions are NTFS.
The size of the hard disk is 1 TB.

I can only do a screenshot by photographing with a camera and then uploading the jpeg.
Would this be helpful?
My System SpecsSystem Spec
.

30 Jun 2017   #4
samuria

win 8 32 bit
 
 

That would help
My System SpecsSystem Spec
30 Jun 2017   #5
Windows7Nubie

Windows 7 Pro 32bit and Windows 7 Pro 64bit
 
 

Okay, attached are two photos from Paragon Disk Manager Pro 15 Win PE 3.0 Recovery Disk


Attached Thumbnails
Requesting Help With Windows 7 Partitions-list.jpg   Requesting Help With Windows 7 Partitions-map.jpg  
My System SpecsSystem Spec
30 Jun 2017   #6
Windows7Nubie

Windows 7 Pro 32bit and Windows 7 Pro 64bit
 
 

I should also mention that I tried to recover again and this time I selected "create new nt signature" and as a consequence Acronis appears to have restored the partitions in the correct order, but even with Universal Restore the drive still does not boot.
My System SpecsSystem Spec
01 Jul 2017   #7
Windows7Nubie

Windows 7 Pro 32bit and Windows 7 Pro 64bit
 
 

Here is a photo of the bsod when it tries to boot.

It does not like some aspect of the Marvell Driver, but I cannot understand whether it is missing, wrong, too old, too new, or what?


Attached Thumbnails
Requesting Help With Windows 7 Partitions-bsod-marvell_driver.jpg  
My System SpecsSystem Spec
02 Jul 2017   #8
Windows7Nubie

Windows 7 Pro 32bit and Windows 7 Pro 64bit
 
 

I did some more research and experiments.
Now I am more confused.

I am able to install Windows 7 on the drive attached to the Marvell controller from scratch without loading any Marvell driver during the install process. This installation has the 100 MB System Reserved partition as the boot partition.

I checked my other Windows 7 drives on the Intel controller and they have the Marvell driver 1041, and show the presence of the controller in Device Manager as a Marvell controller.

If I try to install that same Marvell driver (1041) onto the drive directly attached to the Marvell controller (the one with the System Reserved boot partition) the drive crashes upon attempting to boot.

I looked at the other drive with Windows XP on the Marvell controller and I see that the Marvell driver 1008 is present in the drives file hierarchy; however, when I look at the Windows XP Device Manager, I only see generic references to the controller and it appears that the Marvell driver is not loaded for those generic references.

I am starting to wonder if the motherboard needs a bios update. I would not even try this as I have no way of knowing if it will solve this problem or create new ones.

So if no one has any ideas for me I will probably just setup Windows 7 from scratch without the Marvell driver.

But I would still like to know whether that system reserved boot partition is necessary and is there any required order to how the partitions appear on the disk.

TIA
My System SpecsSystem Spec
Reply

 Requesting Help With Windows 7 Partitions




Thread Tools




Similar help and support threads
Thread Forum
Will not boot after requesting Windows updates
Working on a computer - chose to download and install all Windows updates - after about 80% installed the computer restarted and will no longer boot into Windows. Booting without a repair disk tries to go to a network boot instead (I have checked the boot order). Booting with a repair disk...
Windows Updates & Activation
Requesting more information about In-Place Installs of Windows 7
I was just wondering if someone can explain what can possibly be lost from an in-place upgrade of windows 7. I've got a lot of errors that I'm working on in another thread, and it's not looking too hopeful. So I'm considering this in-place upgrade. My concerns; Does it mess with the registry?...
Installation & Setup
Suddenly Windows requesting activation
My PC has recently been asking for activation. I have run CHKDSK (some repairs were made) and SFC scan. Then WGA Diag. Both appended. My SSD is always giving trouble and needs CHKDSK treatment every 8 weeks or so..... Very grateful for any hints. Diagnostic Report (1.9.0027.0):...
Windows Updates & Activation
Windows Explorer Starts-up Automatically (w/o my requesting it)
Hello, Upon every boot up Windows Explorer ( not Internet Explorer) automatically loads and displays. This has been going on for some time. I thought this would be solved once I did a "Install Repair" , yet this is not the case. I have looked in the startup folder to see if it is being...
Installation & Setup
Requesting for a Windows 7 Start Orb
Hi can i make a request to make me a Start Menu Orb for my Windows 7 Ultimate 32bit TY in Advance Picture:
Themes and Styles


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:52.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App