Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Attempting Data Recovery Using TestDisk- Arrow Keys Not Working

31 Jul 2018   #1
lapis00

Windows 10 x64, Bootcamp
 
 
Attempting Data Recovery Using TestDisk- Arrow Keys Not Working

Hi everyone! I'm using a 2013 Intel Macbook Pro. I was running BootCamp with a Windows 10 Partition and I was messing around with the registry, when I probably shouldn't have been, and I ended up getting a BSOD and was unable to boot up into the BootCamp Windows 10 Partition anymore, so I tried to reinstall Windows 10 onto the BootCamp partition, though accidentally (through many steps) ended up using the clean command on diskpart in the cmd menu while reinstalling Windows. I'm very worried about my data and now no longer have an OS at all on my Macbook Pro. I'm attempting to use TestDisk on a bootable freeDOS USB drive, though as soon as I run testdisk.exe in DOS, I arrive at the "Use arrow keys to select, then press Enter key:" option to select whether or not I'd like to create a new log file, though as soon as I reach this point, my keyboard seems to stop working. I'm unsure of what to do. I can provide any more information, if needed! Thank you!


My System SpecsSystem Spec
.
01 Aug 2018   #2
jumanji

Windows 7 Home Premium 32 bit
 
 

Hi lapis00,

Welcome to Seven Forums. Well, I don't know anything about MacBook Pro,, bootcamp etc., but generally I remember Wireless/bluetooth keyboards do not work even on Windows PCs for certain operations.. I vaguely remember hunting for a wired keyboard/mouse when Wireless keyboard was not working. So try a wired keyboard.

I also found this suggestion from Christophe Grenier, the author of TestDisk . Don't know whether it applies to your situation.
"Try 4 for left, 6 for right, 8 for up and 2 for down.
Good luck"
My System SpecsSystem Spec
Reply

 Attempting Data Recovery Using TestDisk- Arrow Keys Not Working




Thread Tools




Similar help and support threads
Thread Forum
Arrow Keys Not Working
My four arrow and delete keys have stopped working on my Lenovo V570 laptop (Win 7). The arrow keys still work if I press Fn + arrow, but not alone. I have searched but came up with nothing. Any ideas?
Hardware & Devices
E key and arrow keys working intermittently
Hello everyone.. The "e" key and arrow keys (not sure if there are others yet) are working intermittently. I either have to a) reboot the computer only to have it stop working again later, or b) wait for it to start working again on its own. The odd thing about this is that it doesn't matter...
Hardware & Devices
Changing the Win+Arrow Keys?
I use those keys a lot and I dislike having to press two keys to change the windows. I want to know if there is a way to remap them to one button? (I was thinking of the F9 to F12 keys)
General Discussion
Laptop Arrow keys not working!!!!
I have just bought a new Studio 15 laptop from dell and i have had it for about a month now and when i try to play a game online my left arrow key is stuck and my character is constantly going left. Any help?
Drivers
sub folder viewing using arrow keys
When I scroll through my subfolders using explorer on the left hand side, it doesn't automatically display the contents on the right unless I use my cursor to manually select the folder, not just by scrolling up or down (right to left work to expand and contract folders). annonying. Ive tried the...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:43.
Twitter Facebook Google+