Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Difficulties in creating restore points

15 Aug 2018   #1

Windows 7 x64 Ultimate
Difficulties in creating restore points

I have attempted to make restore points. The routine shows completed. But when I restart
it says no restore points available.

In working with some anti virus tools which claimed to make restore points, those also showed
no evidence in the reboot and attempt to find them.

Somehow I got past an access denied error to make any restore points manually in Win7.

So multiple problems exist. How can I fix my settings as administrator to make restore points?

And why are the restore points not being saved?

I have a backup drive but will wait for any answers to fix the problem.
This cropped up, I should add, after using a suite of anti virus scans which I've mentioned in another thread. There seemed to be a 'stray screen' where Hitman Pro popped up as a simple
text phrase during one of my restarts. One of these progs might have an exploit or other
problem. I deleted all the remants of the suite of programs.

My System SpecsSystem Spec
15 Aug 2018   #2

Windows 7 x64 Ultimate

One followup on this.

Malwarebytes older Junk Removal Tool which I still have successfully created the restore point.

I first tried this in my usual way on the backup drive and then ran JRT on this drive which
would not take a restore point from the question posed.

Perhaps some settings need adjusting for permissions or the like?

But with all this, I will suspend trying to use anti virus tools as that is where the problem seems to
have started..
My System SpecsSystem Spec
16 Aug 2018   #3
F22 Simpilot

Windows 7 Ultimate x64

I had a system restore issue once, and I could never figure out what it was. Finally, after some major digging around on my machine and with persistence I nailed it down to my RAM drive software from SoftPerfect. After I uninstalled the RAM drive software I was then able to create system restore points again.

So with that, your problem could very well be with software like your anti-virus software or something else recently added. Retrace your steps. What did you install prior to this happening? That you noticed at least.

If it's not a software issue, then perhaps you have an infection. You can try Herdprotect portable which uses 68 anti-virus engines. It may require two scans. Depending on how much data you have it could take awhile. Since it uses so many anti-virus engines it's bound to find false positives. So if it lists a possible virus, research it before you commit to its removal.

Download Portable herdProtect Beta

The link I usually use is gone. I think that's the correct one. Herdprotect as an install rather than portable can't be used right now for some reason so you're resorted to using the portable version.

On the subject of anti-virus software, I have to tell you. You're better off with something like Faronics anti-executable or Shadow Defender. I've tried both in VMware with a boat ton of malware and nothing got past it. If OS sandboxing is not your thing, then Faronics anti-executable would be the ticket.
My System SpecsSystem Spec

16 Aug 2018   #4

Windows 7 x64 Ultimate

I will look into these things. Thanks for answering and in detail. It seems there's no end of different programs names for this.
It started out for me just wanting to get 'stalls' speeded up where the throbber (spinning indicator) came on for a long time between actions on the PC.

But the reason I'm writing here is that all of these programs never find anything wrong. My goal
was performance and cleaning of excess files like all those telemetry ones in the browser.

But the fact that Restore ran at the command line in Junk Removal Tool should be some kind of clue.

And yes I deleted all the virus suite progs with Revo Uninstaller.

My test of Junk Removal Tool was first done on my backup HD where I looked for differences
in installed programs and such from last clone job. It seems to be a 'permission denied response' where
user privileges or some such is denying the restore point command.

I have no RAM disks enhancement.
My System SpecsSystem Spec
16 Aug 2018   #5

Windows 7 x64 Ultimate

today I looked into this again.

JRT (see above) restore point was in there. I ran it and it was successful.

Within Windows proper I then logged out and logged in as I am the only user.

This action allowed me to make a new restore point which recorded in the log. If this is the solution then it was an authentication error and I don't know how it cropped up unless from the AV programs described above.

But the JRT restore point was no longer there.

I need help in setting up the parameters of the restore procedure. Somewhere in the text
at restore it says previous restore points are eliminated under a certain disk space option.
I've seen the slider in Restore setup but don't know how to change it effectively to allow more
restore points to record and be available. A month would be a good example.
My System SpecsSystem Spec
02 Sep 2018   #6

Windows 7 Home x64

loninappleton, sorry to come here late, but did you ever learn how to use the slider option in the section that lets you create Restore points? I'm baffled by it myself. Any which way I slide, it doesn't save what I did. I'm now unable to create new Restore points after I stupidly wiped all the previous ones. But as soon as my computer is fixed I want to create retire points. I read Windows creates one automatically once a week but I wasn't able to access them. Did you figure it out?Thanks.
My System SpecsSystem Spec
02 Sep 2018   #7

Windows 7 x64 Ultimate

Hello and thanks for answering. Yes I did try to fiddle with the slider once. I could not understand about the 'capacities' or whatever described in the action and have no solution yet.

Perhaps we can both get a response that makes sense. In another topic I did learn that using JRT the Junk Removal Tool from
Malwarebytes,( a trusted source,) will create a valid restore point that will hold in system and after a reboot.
Anything else with that slider at Zero will remove the previous entry. I found out the Restores were not
working right while using some cleaning tools, all of which make restore points, but none were being saved.

We should be able to get this straightened out.
My System SpecsSystem Spec
02 Sep 2018   #8

Windows 7 x64 Ultimate

I'm on this again today.
Howrogeek has a procedure:

I followed the action by entering the System Protection as shown by right clicking on Computer on the desktop > Properties > System Protection tab and then Configure. I have diskspce so just set it at 20%.

Over the days, I've seen that my automatic restore point for the current day shows up, but nothing else had. Will see if that and a few JRT loads record and save.
My System SpecsSystem Spec
14 Sep 2018   #9

Windows 7 x64 Ultimate

I am back. Yes, problesm here as well even after I used the slider. One the restore point created last saves which in this case was same day.

There must be an answer but even helper books don't have much on this.
My System SpecsSystem Spec
14 Sep 2018   #10

Windows 7 x64 Ultimate

Howtogeek shows a completely different action than sliders and such in the restore menu.

Task Scheduler is described here:

but I'm not figuring out how to simply tell it what to do.
My System SpecsSystem Spec

 Difficulties in creating restore points

Thread Tools

Similar help and support threads
Thread Forum
System Restore isn't creating (or saving?) restore points properly
For some reason my System Restore function isn't automatically creating (or isn't showing) System Restore points as it should be doing for "major" system events (e.g., isn't automatically creating restore points before/after Windows Updates and software/driver updates). I'm not sure if it isn't...
Backup and Restore
System restore not creating points?
I was wondering if my System restore is working properly. I wanted to roll back a couple of days as i installed java to get a program to run but there seemed to b a problem a few days later so i went to use system restore but there was only one restore point created and was after the java had...
Backup and Restore
System Restore Has Stopped Automatically Creating Restore Points
My last automatically System Restore Point automatically created by the passage of time was created 2013-01-23. No further automatic system restore points are being created (that means not ever, not daily, not weekly, simply no longer created automatically by the passage of time since last...
Backup and Restore
Windows 7 not creating enough restore points
I had to do a system restore recently. I was limited to restoring to 3 days earlier, when all I wanted to do was restore to the day before, but unfortunately no restore points had been created. System Restore is turned on obviously, and I have allowed about 25 gigs of space for restore data, and...
Backup and Restore
System Restore not creating automatic restore points
System Restore is no longer creating automatic restore points. All the necessary services are set to automatic, ie: task scheduler, volume shadow copy, microsoft software volume shadow copy, windows backup, and remote procedure call. I tried disabling SR, then performed a disc cleanup,...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:17.
Twitter Facebook Google+