Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 'Access is denied' message when copying

08 Mar 2020   #1
Firefox1701

Windows 7 Ultimate
 
 
'Access is denied' message when copying

Anyone who's masochistic enough to want to read the full back-story to this is welcome to indulge themselves by reading my first thread on this forum; however, that's left me with two problems which I'm posting separately.


I'm sure this is another 'easy when you know how' thing; but still: having just installed a new SSD as my primary C drive, I'm using what used to be my C drive ( a 1TB HDD ) as what is now my backup D drive. In fumbling my way through that process, I've had to do a handful of bits of work using the old C drive ( now the D drive ). I thought it would be a simple case of copying the files that had been worked on, from the D drive to the new C drive; however, although some of the files seem to have copied successfully, I'm getting a large amount of 'Target: access is denied' messages, which, as you'd expect, result in the files not being copied, which in turn means the new C drive still isn't fully operational.


Obviously I realise that the workaround is to continue to use the old C drive ( now the D drive ) for the time being; but that's cumbersome and obviously not a long-term solution. I usually use TeraCopy for all my copying and backups, and it's always copied the files from the working drive without a problem; however, this is the first time I can remember that I've had to copy files to the working primary drive, and it's really not having it. I've tried TeraCopy, I've tried drag-and-drop, I've tried copy-and-paste, and it's the same result each time. I don't know if it makes any difference, but far and away the majority of the files are pictures and music files, and a handful of documents.


I sense this might be something to do with 'administrator privileges' or 'permissions' or some-such ( that's nothing more than a vaguely-educated guess ), but since I'm the only one using the computer, I wouldn't have thought I'd need to get my own permission to do stuff!!!


As previously, any inspiration gratefully received.
My System SpecsSystem Spec
.
08 Mar 2020   #2
samuria

win 8 32 bit
 
 

Were exactly are you coping to its telling you you don't have permission to write to that folder if you are trying to copy software then the folders will be owned by system.
My System SpecsSystem Spec
08 Mar 2020   #3
Firefox1701

Windows 7 Ultimate
 
 

There were quite a lot of files involved all told, but from memory, most of them would have been going to the 'My Pictures' folder, some to the 'My Music' folder, and some to the 'My Documents' folder.


'Owned by system' sounds decidedly 1984ish! If I want to put stuff in those folders, particularly given that I'm the only one who ever uses this computer, surely that must be do-able ...?


P.S.: There was no software involved, in the sense that nothing I was trying to copy was software.
My System SpecsSystem Spec
.

08 Mar 2020   #4
Barman58

Windows 10 Pro x64 1909 - 18363.657 XP/Vista/Win7/Win8.1 in VM for testing
 
 

Ok this appears to be the old "New drive permissions" issue that has been around for a while ,(I first came across it in NT3.5), on NTFS folder structures.

Basically the user that we see is based on a Name of some sort, it's human friendly, the system on the other hand uses a digital user ID this shows to us humans as a long set of numbers starting with S it's known as a security Identifier or SID.

If you install windows onto a system twice using the same user name they will look the same but due to the way that the permissions system works each will have a different SID. as the SID is what the system uses to allocate and use file access permissions, you have to set both sets of files to have the same Owner at the SID level.

This is a fairly simple task, from the new install, navigate to the top level of your data tree on the old drive, Right Click select security, then advanced and at the top of the tab will be a the controls for taking ownership of the files, ensure that the inherit checkbox is ticked and set the owner for the files to your new user, this is then automatic and should complete without issues. Sometimes< permissions can get a little confused and give an error, in this case OK through making a note of the location and later you can apply this reset procedure from that point at the top of the subtree.

Sounds complex, it's a pain but once you've done it a few times it's simple
My System SpecsSystem Spec
09 Mar 2020   #5
Firefox1701

Windows 7 Ultimate
 
 

Unless I'm doing something wrong or I've misunderstood the instructions ( either of which is entirely possible ) that hasn't seemed to work, which is to say that the exact same files that were showing as 'access denied' the first time round, still are.


I've assumed that the 'top level of the data tree' would be the C drive as shown in 'My Computer'. I've gone to Properties>Security>Advanced; I assume the next thing you intended me to do was to click the 'Owner' tab? If so, there is no 'inherit' checkbox within that window ( or elsewhere that I can find ).


You say 'set the owner for the files to your new user'; there seems to be no way to do that without clicking 'edit', so I've done that; however, it still won't allow me to edit the 'current owner'.


By the by, I have no idea why it seems to have taken this position for certain files but not others!
My System SpecsSystem Spec
09 Mar 2020   #6
Barman58

Windows 10 Pro x64 1909 - 18363.657 XP/Vista/Win7/Win8.1 in VM for testing
 
 

The drive you need to "fix" is the D: drive that has the original data files on it (from when it was the C: drive)

You may achieve more success, if you used windows default setup, Documents, downloads, pictures Etc, if you start the resetting procedure at the root of these folders Rather than the whole of the drive which may contain remnants of the original system files

The reason for some files working and some not is usually due to another User that windows creates, "Everyone" - any files owned by "Everyone" are available to any user that is logged in to the system
My System SpecsSystem Spec
09 Mar 2020   #7
Firefox1701

Windows 7 Ultimate
 
 

Hello Nigel,


When you say 'fix' ...?
My System SpecsSystem Spec
.
09 Mar 2020   #8
Barman58

Windows 10 Pro x64 1909 - 18363.657 XP/Vista/Win7/Win8.1 in VM for testing
 
 

This is your system as I understand it ...

You have recently created a new windows install on a new SSD
You have renamed/assigned your your existing old C: drive as your D:drive
You cannot access the files that are on the D: drive - the system requires you to use permissions for access

Due to this ...

The files on your D: are still owned by your old user on your old system, permissions are written to the individual files and folders with the unique SID numbers that I spoke of, (even if the User names appear the same to us, to windows they are different and Unique so you need to "Fix" the permissions by using your new current user to take ownership of the old files. to do this you need to follow my initial instructions on your old c: drive, now allocated as D

Rather than me write a full explanation of File Permissions in windows this link gives a simplified version of the full system

NTFS permissions (Windows NT) – Network Encyclopedia

It is based on Windows NT from the 1990's but still applies to Windows 7 and every Issue of Windows since NT It,s not required reading but may help to understand the underlying system

Our Admin Shawn Brink has developed a shortcut that works with the right mouse click to assign permissions automatically

Take Ownership Shortcut

This should allow you to change permissions, as you go, to either Folders or files (after using it on an item you do not need to do it again)
My System SpecsSystem Spec
Reply

Thread Tools




Similar help and support threads
Thread Forum
Access Denied (5) message on Shutdown or Restart script
I have two shortcuts on my desktop Shutdown shortcut C:\Windows\System32\shutdown.exe /f /s /t 0 And Restart Shortcut C:\Windows\System32\shutdown.exe /r /f /t 0 I noticed today that when I try to run either one, I get this message: Access is Denied.(5) This is something new. Anyone familiar...
General Discussion
Access denied message on G drive
I am attempting to retrieve files from a Sandisk Cruzer flash drive, but I get a message saying "G not accessible, access is denied." I went to change the permissions to take ownership of the drive but there was no security tab. I searched thru the forums and first tried the recommendation...
General Discussion
Cannot open file Access is denied message
Hi all. I have a strange issue (or so it seems to me that i am a newbie) . I try to use a small utility which reads massively *.txt files and if they are saved as ANSI it saves them as Unicode. The problem is that when i run it (run as administrator) i get an error message saying "Cannot open...
General Discussion
administrator account/access denied message
How do i access the already built-in administrator account so i can make security/privilege changes so that i can change time servers using the command line. because every time i use the NET TIME command it gives me a "access denied" error; which tells me something, only Im not sure what needs to...
General Discussion
Access denied message
I am trying to copy my Firefox profile folder from my older pc to my Win 7 net book. In the past i used the "run/%applicxxxxxx/profile" syntax to reach my profile. Now, when i do the same in Win 7, i had to create a new folder "profile' and then paste my older profile. In doing this I get the...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:12.
Twitter Facebook