Error creating System Restore Point

  1. Posts : 53
    Windows 7 Pro 32 & 64 bit

    Error creating System Restore Point

    Windows 7 SP1. When I try and create a Restore Point, I get the following:

    " The restore point could not be created for the following reason:
    The writer experienced a non-transient error. If the backup process is retried, the error is likely to reoccur.

    Things I have tried:

    I restarted the PC
    I restarted the Volume Shadow Copy Service and ensured it is running
    I ran a full chkdsk including the sector check (took hours)

    I ran vssadmin list writers and see several "Timed Out" errors. I looked in event viewer for VSS error and see the following

    Ran out of time while expanding file specification \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy15\Windows\softwaredistribution\Download\*.*. This was being done for the WUA subscriber.

    Ran out of time while expanding file specification \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy15\Windows\softwaredistribution\*.*. This was being done for the WUA subscriber.

    The VSS service is shutting down due to idle timeout.

    I stopped the Windows Update service, renamed the SoftwareDistribution folder, tried again, same error

    Any ideas?
      My Computer

  2. Posts : 6,086
    Windows 7 Ultimate x64

    I've had this issue in the past where try as I might could not for the life of me create a system restore point. And I'm no dummy when it comes to computes. I did EVERYTHING and ANYTHING and still couldn't fix the issue. Finally after about six months I wondered if it was a piece of software that somehow caused the system restore functionality to muck up. Sure enough, it was Softperfct's RAM Disk software. Once I uninstalled that I was then able to create a damn restore point. Unreal!

    This was many years ago so perhaps newer versions don't produce that error anymore, or the issue was very specific to my computing environment. I really don't know. Today, I use ImDisk for RAM drive needs.

    Having said this. Is it possible a software you installed caused the ability to create restore points to crap its self? You'd have to retrace your steps to a time when this issue first appeared. I'd also check the error logs. You can run these two batch files in the zip to get the first 50. I made it 50 because I like detailed logs more so than the freaking Terminator.

    Just extract to the desktop and double click on each one. The resulting logs will be on the desktop. You can zip those two log files and upload here.

    For the nerdy: SHA256: C2E59C5C91F5BA4B1F7600209644C95504BE9A331F9CC14F9823A9415205B951
      My Computer

  3. Posts : 53
    Windows 7 Pro 32 & 64 bit
    Thread Starter

    So on a whim, I tried making a Restore Point again. I have changed nothing. And it worked. Bizzare.
      My Computer

  4. Posts : 6,086
    Windows 7 Ultimate x64

    If it happens again I'd look at the error logs. You might want to run those two batch files to save the error logs for a comparison to new error logs should the issue occur again.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:37.
Find Us