Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Backup service missing 0x80070424

06 Dec 2009   #1
thrawn86

win7 pro x64
 
 
Windows Backup service missing 0x80070424

Windows backup doesn't even seem to exist on my computer. trying to change settings yields this 0x80070424 error:

http://dl.dropbox.com/u/21159/backup%20restore%202.JPG

and going to "backup and restore" in control panel yields a blank screen:

http://dl.dropbox.com/u/21159/backup%20restore%201.JPG

The Windows backup service is not even listed in my service list.
I've tried the one fix circulating around here involving deleting the wbengine registry key and restoring it, to no avail.

My backup drive ran out of space a few weeks ago and I'd been ignoring it until now, before that it had been chugging along happily, not even missing a beat when I re imaged my boot drive over to a newer, faster one.

I'm lost here.


My System SpecsSystem Spec
.
06 Dec 2009   #2
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Did you try a repair install?

Repair Install
My System SpecsSystem Spec
06 Dec 2009   #3
thrawn86

win7 pro x64
 
 

running setup inside of windows throws out errors involving wdsutil.dll being missing (it isn't), and autorun.dll being corrupt (its not). I fully redownloaded and recreated my usb boot drive to be sure.

edit: image restore to 1 month ago before the problem started didn't fix it, so it must have been occuring then too. Thats the oldest image I have :/
My System SpecsSystem Spec
.

04 Mar 2010   #4
FishMan

Windows 7 Ultimate x64
 
 
Backup Service gone !

Hi,
I realise this is an old thread, but I have the same problem, and wondered if anyone managed to fix it ?

Regards,
My System SpecsSystem Spec
04 Mar 2010   #5
tw33k

Windows 7 Ultimate (x64) SP1
 
 

SIW2's suggestion is where I'd start.
My System SpecsSystem Spec
06 Mar 2010   #6
FishMan

Windows 7 Ultimate x64
 
 
Backup blank page and missing service

OK, I tried all sorts -
Importing registry sections (that brought the service back into view, but I still couldn't run backup)
SFC /scannow (no problems)
Changing permissions and taking ownership on various files (lots of diferent files noted in various forums)
Re-registering various DLL's
and probably loads more things that I can't remember

I have now done a repair install which was very straight forward (although time consuming), nothing was lost or changed, and everything is now back to nornal.

I am just writing here so if anyone else is looking for a fix to their problem, then I suggest they go straight to the repair install and forget the other so-called "fixes".

Regards,
------------------------------------------------------------------------------
Sorry about this, but I cannot find a section to include tags to help anyone
searching, so I am just adding words here to help.
* missing data,service gone,window blank,window empty,backup & restore,vista,windows 7,win 7,w7,sdrsvc,sdrsvc.exe,rpc,dcom
My System SpecsSystem Spec
07 Mar 2010   #7
Flavius

Windows 7 Professional x64 PL
 
 

Quote   Quote: Originally Posted by FishMan View Post
OK, I tried all sorts -
Importing registry sections (that brought the service back into view, but I still couldn't run backup)
Some persons report restoring wbengine key in registry is enough,but of course not for all,like for you.
I can only suspect apart missing wbengine key you may had corrupted or missing wbengine.exe file -this file should be stored in C:\Windows\System32 folder.It's hard to say more without analysis logs - services status,SFC report
My System SpecsSystem Spec
29 Apr 2011   #8
aredub

Windows 7
 
 

I had the same problem -- Backup just showed a blank screen. I found that the Windows Backup service was disabled. Setting it to Automatic fixed the problem.

Robert
My System SpecsSystem Spec
Reply

 Windows Backup service missing 0x80070424




Thread Tools




Similar help and support threads
Thread Forum
My Windows Installer Service is missing. How do I get it back?
My Windows Installer Service is missing. How do I get it back? I'm unable to install any programs or open my Outlook due to the missing install service. Can anyone help me on fixing this issue?:confused:
General Discussion
Windows Update Service not installed error: 0x80070424
PC 64bit Windows 7 home premium Windows Update does not work What I did for diagnose and solving the problem: 1. Tried installing System Update Readiness Tool (SURT) received "Installer encountered an error: 0x80070424 The Specified service does not exist as an installed service" 2. SFC...
Windows Updates & Activation
Windows Update Service not installed error: 0x80070424
I'm having the exact same problem as Jeff. I followed through on the Farbar Service Scanner, and these are my results: Farbar Service Scanner Version: 18-08-2013 Microsoft Windows 7 Home Premium Service Pack 1 (X64) Boot Mode: Normal...
Windows Updates & Activation
Windows Firewall missing from Services Menu and Error 0x80070424
Hello, Two days ago there was a virus on my computer, and I called Microsoft to remove it. But ever since then, I have noticed that my McAfee Verizon Internet security Suite Firewall does not stay on. It may appear on in the home window, but when you want to go into firewall settings, it...
System Security
Windows Update Service not installed error: 0x80070424
PC 32bit Windows 7 Ultimate Windows Update does not work What I did for diagnose and solving the problem: 1. System Update Readiness Tool (SURT) Error: errorcode0x80070424 The service is not installed. With fixit this is solved the 32 bit update is installed pc restarted
Windows Updates & Activation
Backup & Restore, Missing Service?
When I try to run Windows back up (not system restore) I get error 0x80070422. The error message reads something like “This service can not be started because it is either disabled or it has no enabled devices associated with it.” I looked around and found a list of services associated with Backup...
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App