Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: System Restore Points Keep Getting Deleted

26 Jan 2010   #1

Win 7 x32 Pro
System Restore Points Keep Getting Deleted

I have system protection for system settings and files set to 2gb on c: for c:

there are two triggers in the scheduled tasks, and both work (a restore point gets created when the conditions are met)
  • when i install updates or uninstall a program
  • when i start the machine
Also, when i manually run the task or the command line used by the tasks, a restore point is created.

BUT the restore points eventually get deleted. I had two of them earlier today, using less than 400mb, now I have none. they don't get deleted after a restart. i haven't been able to pinpoint when they get deleted, but they don't last more than a day or two. and they never get anywhere near the allowed 2gb, though they do get past the allocated 300mb

VSS service is set to manual start, which is the default.

system protection is ONLY on for drive C:. I tried to disable it for drive C:, restart the machine, then re-enable it. no go.

i ran a SFC, no errors.

I ran MSE, MBAM, Temp Folder Cleaner and Sophos anti-rootkit, nothing found.

I ran a registry clean and compact (eusing), no difference.

my system was upgrade from Vista, where system restore worked fine.

i don't know what else to do. I have a daily backups, but system restore is a lot more convenient. I would like to get it to run.

thank you in advance for any input

My System SpecsSystem Spec
26 Jan 2010   #2

64-bit Windows 10 Pro

Hello Crashnet,

See if increasing the max disk space storage for restore points to say around 10 GB instead will allow them to continue to be stored.

System Protection - Change Disk Space Usage

Hope this helps,
My System SpecsSystem Spec
28 Jan 2010   #3

Win 7 x32 Pro

growing the storage to 10gb didnt work. the restore point I had available yesterday got deleted. the one created a 6am on schedule is the only one available as of 10:30am today.
My System SpecsSystem Spec

28 Jan 2010   #4

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

I am sorry that you are having a problem and the solution provided by Brink has not worked.

I have seen this problem, before, from other members of this forum. One possible cause is that you are are scheduling a automatic defrag, which includes the partition where the restore points are activated. If this is the case, you will have to save your restore points to another partition. You can check on the task scheduler to verify the schedule of defrag. Sometimes 3rd party software, also schedules a defrag, such as and A/V.

I have included information on this problem as provided by MS

Shadow copies may be lost when you defragment a volume

Here is another information bulletin from MS, that may provide you with other information that may help you to solve your problem
My System SpecsSystem Spec
28 Jan 2010   #5

Win 7 x32 Pro

I have been getting Event ID 33 via Volsnap: The oldest shadow copy of volume C: was deleted to keep disk space usage for shadow copies of volume C: below the user defined limit.

But there is plenty of space

C:\Users\user>vssadmin list shadowstorage
vssadmin 1.1

Shadow Copy Storage association
   For volume: (C:)\\?\Volume{efbde587-d98c-11dc-a5ff-806e6f6e6963}\
   Shadow Copy Storage volume: (C:)\\?\Volume{efbde587-d98c-11dc-a5ff-806e6f6e69
   Used Shadow Copy Storage space: 7.306 GB (16%)
   Allocated Shadow Copy Storage space: 7.626 GB (16%)
   Maximum Shadow Copy Storage space: 9.001 GB (20%)
7.3gbs used and I have NO restore points available right now...

The cluster size on C: is 4k

And I have Diskeeper running.

The only part in the whole thing that doesnt make sense is in KB 312067

If the file system's cluster size is 16 KB or larger, the provider can recognize disk defragmentation I/O and handle it correctly. Microsoft recommends that you use a 16-KB or larger cluster allocation unit size when you format the volume if you plan to defragment volumes that are used for shadow copies of shared folders.

I am NOT creating shadow copies of shared folders. What would the solution possibly be in my case, besides changing cluster size to 16kb (which would be a pain)?

I thought of excluding from defragmentation the area with the restore points are stored, but I am not sure this would make any difference because the purported cause of the problem is

If the file system's cluster size is smaller than 16 KB, the System Shadow Copy provider cannot easily determine that disk defragmentation I/O is different from typical write I/O, and performs a copy-on-write operation. This might cause the Shadow Copy storage area to grow very quickly.

There has got to be a simpler solution to this problem than changing cluster size... this seems to be VSS problem, not a diskeeper problem. it occurs with other defragmenters too:
My System SpecsSystem Spec
28 Jan 2010   #6

Win 7 x32 Pro

Problem solved!

Diskeeper has a (VSS) Compatible Mode defrag which was not turned on.

thanks Richard and everyone else
My System SpecsSystem Spec
28 Jan 2010   #7

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Thanks for telling us. We are glad that we could help.

Come back any time to share your expertise or to utilize our knowldege.

Take care.
My System SpecsSystem Spec

 System Restore Points Keep Getting Deleted

Thread Tools

Similar help and support threads
Thread Forum
Deleted my Restore Points!!!
My laptop was taking about 8-9 minutes to restart and it took forever to close down and various other uglys. I got in an deleted all my old restore points and now it takes about 1 minute to restart:cool: I had researched all sorts of things to speed up the shutdown, googled 'takes to long to...
Backup and Restore
System restore points deleted on Win 7 in dual boot with XP
Because of the differences in the system restore technologies between windows 7 and windows XP, when booting out of XP and into Win 7 Pro the Win 7 restore points will have been deleted. My scenareo is XP - original system on first physical disk (boot loaders are here) and Win 7 on third physical...
Backup and Restore
System Restore Points Being Deleted After Reboot
I have had this problem ever since I installed my Windows 7 Ultimate x64. I did a clean install, and everything is perfect, I haven't had problems with the system, but I think it's good to have restore points for the times when, and if, I need it, so I ask for help till it's not too late. I...
Backup and Restore
System restore points missing/deleted
Whenever I re-start my PC ALL my system restore points are gone W7 Ultimate 64bit Single boot from drive c: System restore for c: turned on - no others current usage (one created manually) 32Mb max allocated 7.5 Gb Free disk space 29 Gb restore not set for other drives 107Gb free (same...
Backup and Restore
as system restore fillup all space all points r deleted
hello, ive set up 4gb for system restore service, so anythime shadow copy and system restore makes files and restore points this reserved space is filled up, but when all 4gb are reached up all the restores point and files are deleted. so i can see in system protection tab the system restore...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:36.
Twitter Facebook