Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: System Restore points disappearing

09 Mar 2010   #1

Windows 7 Home Premium 32-bits
System Restore points disappearing

System Restore points always disappearing at reboot! Help!

I keep getting the “volsnap” error messages in the Windows system event log during the early stage of the boot.
Error 09/03/2010 16:33:08 volsnap 25

The shadow copies of volume C: were deleted because the shadow copy storage could not grow in time. Consider reducing the IO load on the system or choose a shadow copy storage volume that is not being shadow copied.

Error 09/03/2010 16:34:04 volsnap 27

The shadow copies of volume C: were aborted during detection because a critical control file could not be opened.

I Installed Windows Seven 32-bits on a HP Pavilion dv6000 notebook 3 weeks ago, everything fine till I noticed that no restore point was kept longer than one day as of the beginning of my installation. I have 16 GB free on my system and set up the snapshot parameter max capacity to 9.3 GB which leaves plenty of space for the restore points.

Shadow Copy Storage association
For volume: (C:)\\?\Volume{f85119a2-15d8-11df-b8a7-806e6f6e6963}\
Shadow Copy Storage volume: (C:)\\?\Volume{f85119a2-15d8-11df-b8a7-806e6f6e6963}\
Used Shadow Copy Storage space: 81.594 MB (0%)
Allocated Shadow Copy Storage space: 448 MB (0%)
Maximum Shadow Copy Storage space: 9.316 GB (10%)

I did a clean install over windows XP with the Microsoft easy transfer tools and the Old Windows directory to setup the personal user profiles. My system is not dual booting. Just plain Windows 7 without raid and mirroring.

Application installed: Office XP with FrontPage, Office 2003 for Powerpoint Word and Excel, Adobe Creative suite v2.0, HP Quickplay, HP photosmart, Skype, Sonic DvdPlus, Google Earth and iTunes
Antivirus is “Microsoft Security Essentials”. No Norton products, CCleaner nor Spybot installed

The “create restore points” and the backup software is working without error messages.

My restore points are valid and working fine although not kept longer than one day. As well the manual ones as the window updates ones and the installation ones have been tested in a successful restore operation.

I am desperately at risk of loosing the system properties not being able to rollback after a system update or application installation. I tried everything, nothing helped.

Here are the things I tried out to cure the problem:

- Did the process with disable system protection, delete all the existing restore points, boot, re-enable the restore points, create a couple of them and test the reboot. No success.

- I deleted the “System Volume information” directory in case it got corrupted, playing around with ACL’s and ownership settings. No problem for win7, the directory was re-created, owned by system and when I re-enabled the system protection the restore points were again created without a flaw, but … deleted at next reboot.

- With Vssadmin I assigned the Max storage capacity (90GB) and even setting it to unbound. No success.

- I made a Clean-Boot disabling all services not belonging to windows and disabling all service start-ups. No success.

- I checked the disk c: with “Sfc /scannow” and “Chkdsk”. No errors detected.

- I did twice a complete Windows Seven upgrade/repair installation: one with only the minimum recommended safety settings and one with the complete recommended and safety settings. Still the same, no success.

Help me please, what can I do else ?

My System SpecsSystem Spec
09 Mar 2010   #2

Win 7 Home Premium-64bit
Restore Points

Im having the same problem but dont quite understand this: NOTE: With Windows 7 instead of Vista, you will still see the OS's drives listed in Computer, but when you open them, they will be blank and unaccessible instead of seeing the files afterwards.
in the instructions that u mentioned?
My System SpecsSystem Spec
09 Mar 2010   #3
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate

Hello Fdc, welcome to Seven Forums!

Start by having a look at the threads below.
My System SpecsSystem Spec

10 Mar 2010   #4

Windows 7 Home Premium 32-bits

Hi Barefoot, thank you for replying so quickly.

I had a look at the threads you suggested me and here are some remarks and thoughts about the various actions I took to resolve the problem:

Thread 1 (Crashnet): I do not use diskeeper or 3rd party tools except Acronis for my image backups. I have a scheduled Windows defrag running each Wednesday. So I take that in account when testing. I have some other sheduled tasks running. Some of them could perhaps influence the restore points but I don't know which ones. I shall have a closer look to identify them and inform you.

Thread 2 (Tedredted): my purpose here is not to save image restore points to another location because I need my restore points wherever I might be out of home. I want to make my laptop working as it should in every condition. I make regulary image backups of my system, the problem is that they are so time consuming.

Thread 3 (Jacktenenbaum): set system protection off , all RP's deleted, shutdown and reboot, put protection on, create RP,s shutdown and reboot. No way, all RP's deleted. I have only one c: drive primary NTFS partition.

I did not do the reset of the repository as Capt.JackSparrow suggested. Anyway I am able to make automatic and manual RP's.

Thread 4 (Whoosh7): I made 2 upgrade repairs already with my original Win7 DVD simulating an upgrade. This didn't fix the problem.

Perhaps my disk capacity could be the cause. I have a total of 93Gb from which roughly 16.4GB is free, 9.3GB (10%) is reserved for max snapshot SR. This should be OK as I am not doing image backups with windows. I use Acronis for image backups on external media. Drive C: is formatted in one single primary NTFS partition and contains no backups.

What are the minimum requirements for SR ?

I hope I will not have to erase my disk and reinstall everything.

Attached Files
File Type: doc Helprestorepoints-1.doc (98.0 KB, 57 views)
My System SpecsSystem Spec
11 Mar 2010   #5

Windows 7 Home Premium 32-bits

I have some other information about the snapshot capacity. During an Acronis image backup from my laptop to an external disk this afternoon I did some windows updates selecting the updates in 4 or 5 runs. Each run created a restore point. In the vssadmin shots I attached you can see the increase of the shadowspace. I noticed that even when no restore point was taken the shadowspace grew, probably due to the image backup running. Suddenly after a while, the backup was already finished at that time, the last restore point forced a delete with a volsnap event id 25 in the system eventlog. See attachments of the System and Application eventlogs. Now I know the boundaries of the used and allocated shadow spaces.
Used space : 350.22MB, Allocated space : roughly between 729MB and 800MB. Beyound that both used and allocated space is flushed and deleted. How is that possible with so many room available!!! The Max shadow copy storage was set to "Unbounded" during this test. There was 11Gb free space on the disk. See attachments.

Attached Files
File Type: doc VssadminExtracts.doc (39.5 KB, 85 views)
File Type: zip (7.9 KB, 21 views)
My System SpecsSystem Spec
11 Mar 2010   #6
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate

If the total "free space" (11GB total?) on the HDD was that low SR may not be able to create a point; I can't remember right off how much space has to be available for SR to create points.
My System SpecsSystem Spec
12 Mar 2010   #7

Windows 7 Home Premium 32-bits

Hi Barefoot, it doesn't seems to be the 11GB causing the problem because I did the same test with 28GB free on the HDD and the results were exactly the same except the shadow storage capacities. I got the same 4 restore points. During the fifth one the shadow storage space was deleted with the volsnap eventid 25 in the system event log.
At that time the used shadow copy storage was something above 393.422MB
The allocated storage 1.785GB
There was no Vssmax limit (unbounded).

Now that there is 28GB free I will again upgrade/repair windows 7 because during the previous attempts there never has been so much free space. Perhaps this repair will fix the problem as it was mentioned in other threads.
My System SpecsSystem Spec
12 Mar 2010   #8
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate

Hello Fdc.

Here's an excellent tutorial that I just found yesterday looking for info for you, at the link below; have a look through it to see if there's anything we've missed.

System Restore General Troubleshooting to Fix Issues

I'm pleased you're starting to get it sorted.
My System SpecsSystem Spec
14 Mar 2010   #9

Windows 7 Home Premium 32-bits

Hi Barefoot,

I sorted it out and managed to make the system Restore Points working but now it is again going wrong, back to its starting point. History of what I did:

- First I freed 30Gb HDD space and did an upgrade/repair of win 7 but I got no results except that I was able to make a larger number of restore points. The system kept deleting them at each reboot as usual.

- In a second attempt I made 61GB free by removing files, pictures and music, no applications. I did an upgrade/repair of Win 7 and success: the system kept the restore points as it should. I played with the maximum allocated space, set it to 25Gb from unbounded. When it reached the max allocated it deleted correctly the oldest restore points adapting the capacity to the max usage. It did that a couple of times. In the event log it's traced with volsnap id 33. I played a while with reboots, creating restore points manually and also some with windows updates. I managed to create 31 restore points of which +/- 23 restore points were kept in the shadow space when suddenly during a reboot all restore points dissapeared the shadowstorage area got deleted. In the event log appears the classic volsnap errors 25 end 27. The fault occurs at the reboot not during the actual run and it doesn't always depend on a reclaim of space when the shadow space bounderies are reached. When it happened there was plenty of space free, on the HDD, around 35GB. The shadow max allocated usage didn't change, still 25GB.

- I tried to make it work again but no way, the shadow space keeps deleting at each reboot with the volsnap event ids 25 and 27 in the system event log. There is 58Gb free space now

Perhaps I should reinstall windows 7 ? What can I do else to repair the system restore points process. Any suggestion is welcome.

I send you in attachment the event log extracts of yesterday and today so you can easily trace the volsnap messages.

Attached Files
File Type: zip (868.8 KB, 10 views)
My System SpecsSystem Spec
14 Mar 2010   #10
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate

Hello again Fdc.

Geez mate I was hoping that was sorted.

I know we started to discuss this and I think we got sidetracked, have you been through the whole (above) process with the max set at 4GBs or less?

Have a look at the tutorial at the link below to set the "max allotted" space to 4GB and see how that goes and let me know, this is how we were doing it in Vista before Windows 7 was released.

System Restore - disk space - Vista Forums
My System SpecsSystem Spec

 System Restore points disappearing

Thread Tools

Similar help and support threads
Thread Forum
System restore points are disappearing?
Hi guys so i wanted to do a system restore on my machine due to somthing i installed giving me issues. I wanted to restore to a point about a week ago but when i clicked show more restore points all it came up with was a critical update installed today. I have no idea why my system restore points...
Backup and Restore
why do my Restore Points keep disappearing?
Generally speaking, I like to maintain an "archive" of Restore Points that cover about a month's worth of recent activity. More recently, I've become really concerned because for some unknown reason, the number of Restore Points in my archives seems to be dwindling and /or disappearing,...
Backup and Restore
Problem with disappearing restore points
I was going to set a manual restore point and was quite shocked when the screen opened and indicated that I had NO restore points. I know that old ones are removed as new ones are added, etc., but something (not me) had deleted ALL restore points. After I set the new restore point it was recorded...
Backup and Restore
Restore points are disappearing every time I reboot, need help
Hi, everyone Recently, I got my pc cleaned from virus/malware, but now is in good/health shape.. When I create system restore point, it's succeed, but every time I reboot or turn off computer, my restore point is missing.. and I'm newbie about computer can you please help me? I'm using...
Backup and Restore
Restore Points Disappearing: Allocated Space Still Available. Why?
I have allocated approx 18gb of space for system restore and it is currently sitting around 12gb. My question is, why do I only have 2 days worth of system restore available? When there is still more space, I would expect it to go back a bit further and the way that I understand it, Windows 7...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:45.
Twitter Facebook Google+