Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Very slow Youtube

11 Aug 2010   #1
gundamcyclone

Windows 7 Ultimate
 
 
Very slow Youtube

Ever since I upgraded to Windows 7 Ultimate, my Youtube has become very slow. It used to be that a video would load within seconds of me clicking on it. Now, it takes a minute for the video to even start playing.

Is there any way I can accelerate the loading speed of Youtube?


My System SpecsSystem Spec
.
11 Aug 2010   #2
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

This sounds more like an internet connection speed problem. Test your speed here:
Speedtest.net - The Global Broadband Speed Test
and post the result. There is a link on the test to do just that!
My System SpecsSystem Spec
11 Aug 2010   #3
DeaconFrost

Windows 7 Ultimate x64 SP1
 
 

Update your NIC drivers and also make sure you have the latest Flash plug-in installed.
My System SpecsSystem Spec
.

12 Aug 2010   #4
roncerr

Windows 8 Pro w/MC 32-bit
 
 

Quote   Quote: Originally Posted by gundamcyclone View Post
Ever since I upgraded to Windows 7 Ultimate, my Youtube has become very slow....
Windows 7, like Vista, uses significantly more resources than XP. Everything is a bit slower. Then there is the effect of the browser itself. IE8 is not the fastest, hence the forum discussions about the "fastest" browser. I have noticed a slight delay in the fetching of Youtube embeds but in my case the most annoying part is my connection speed since that affects playback. It seems like playback only works well with at least 1.5 mbps of bandwidth. Have you done a speed test: www.speedtest.net .
My System SpecsSystem Spec
12 Aug 2010   #5
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by roncerr View Post
Quote   Quote: Originally Posted by gundamcyclone View Post
Ever since I upgraded to Windows 7 Ultimate, my Youtube has become very slow....
Windows 7, like Vista, uses significantly more resources than XP. Everything is a bit slower. Then there is the effect of the browser itself. IE8 is not the fastest, hence the forum discussions about the "fastest" browser. I have noticed a slight delay in the fetching of Youtube embeds but in my case the most annoying part is my connection speed since that affects playback. It seems like playback only works well with at least 1.5 mbps of bandwidth. Have you done a speed test: www.speedtest.net .
I agree it is more likely to be a slow internet connection than anything else, but as you say the browser can make a difference. It seems as if Chrome is one of the fastest although I use IE 8 without a problem. My download speed just now was 6.89 and that is slow for me, the weather is not so good here so probably all the school children who are on holiday are probably "Gaming". I would not expect to have a problem with You Tube at that speed. My service is going up to 21 Meg in two days time so I am looking forward to that!
My System SpecsSystem Spec
12 Aug 2010   #6
Wishmaster

Windows 7 Home Premium 64bit
 
 

I too have been having a few issues with YouTube lately (last 5days to week)

Videos taking really long to buffer or stopping part way through .. as if a bad connection.

I've noticed its usually happens during peak hours though, then all is fine again.
As i said, just started about a week ago for me but has never happened before.

I thought it was just Youtube being extremly busy, but if no one else has the issue, perhaps its a ISP issue or the general area.



That internet speed test gives me crazy results as well for some reason.

One run its at 3.5 Down next its at 11Mb down.
Always different and can be anywhere in between 3.5 -> 11.

My ISP says the max is 5mbps down.

Odd
My System SpecsSystem Spec
12 Aug 2010   #7
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by Wishmaster View Post
I too have been having a few issues with YouTube lately (last 5days to week)

Videos taking really long to buffer or stopping part way through .. as if a bad connection.

I've noticed its usually happens during peak hours though, then all is fine again.
As i said, just started about a week ago for me but has never happened before.

I thought it was just Youtube being extremly busy, but if no one else has the issue, perhaps its a ISP issue or the general area.



That internet speed test gives me crazy results as well for some reason.

One run its at 3.5 Down next its at 11Mb down.
Always different and can be anywhere in between 3.5 -> 11.

My ISP says the max is 5mbps down.

Odd
Sounds like you have a connection problem. If your max is 5Mb then showing 11 seems very odd. Can you post a couple of screenshots just out of interest. Are you on Cable or DSL? That speed test is one of the most reliable there is. Sure your connection will slow at peak times that's when the Contention Ratio gets near it's maximum!
My System SpecsSystem Spec
12 Aug 2010   #8
Wishmaster

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by mitchell65 View Post
Quote   Quote: Originally Posted by Wishmaster View Post
I too have been having a few issues with YouTube lately (last 5days to week)

Videos taking really long to buffer or stopping part way through .. as if a bad connection.

I've noticed its usually happens during peak hours though, then all is fine again.
As i said, just started about a week ago for me but has never happened before.

I thought it was just Youtube being extremly busy, but if no one else has the issue, perhaps its a ISP issue or the general area.



That internet speed test gives me crazy results as well for some reason.

One run its at 3.5 Down next its at 11Mb down.
Always different and can be anywhere in between 3.5 -> 11.


Odd
Sounds like you have a connection problem. If your max is 5Mb then showing 11 seems very odd. Can you post a couple of screenshots just out of interest. Are you on Cable or DSL? That speed test is one of the most reliable there is. Sure your connection will slow at peak times that's when the Contention Ratio gets near it's maximum!
It may be. I just ran a couple test.
First 2 were back to back from default, closest.
I then ran multiple tests from Dallas,Houston, and St.Louis and they all were pretty well close to each other and consistant.
It is cable. According to the ISp its 5mbs and ... 1.5 up if i remember correctly.

And come to think of it, never had issues before but i did just move so .. maybe something to do with wiring at the new house and I ve just noticed it in the last week.


Attached Images
Very slow Youtube-capture.jpg Very slow Youtube-capture2.jpg Very slow Youtube-capture4.jpg 
My System SpecsSystem Spec
12 Aug 2010   #9
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Sorry I have never used Cable, the nearest cable to me is over 150 miles away although ironically I am but 50 yards from the Fibre optic cable that joins the UK to the US! Have no knowledge of the cable arrangements within a house but I suggest a junction box might be the problem! Just a thought though!
My System SpecsSystem Spec
12 Aug 2010   #10
Wishmaster

Windows 7 Home Premium 64bit
 
 

Thanks.

Might call em out here to check just to be safe.

Those results are just all over the place, for some reason. Quite inconsistant
My System SpecsSystem Spec
Reply

 Very slow Youtube




Thread Tools




Similar help and support threads
Thread Forum
Voices too deep & slow watching YouTube etc.
Having problems with voices on YouTube and other videos being too low and slow which makes me wonder if it's somehow playing too slowly, as when using VLC player there's a play faster "Speed" option which solves this. I've looked in "Sound" but can't find anything similar to click on so any...
Sound & Audio
Notebooks runs slow and freezes when I watch youtube.
1. Product Name and Number HP Pavilion dv6628us Entertainment Notebook PC 2. Operating System installed (if applicable) Windows 7 32-bit 3. Error message (if any) Computer sometimes runs slow & often freezes when watching youtube or other video sites. 4. Any changes made to your...
Performance & Maintenance
Youtube video so slow
Hey i dont know if this is the right section, if it isn't can a admin please move it. Youtube lately has begun to run very slow on my system and i do mean very slow, i cant watch a video without it buffering every 3 seconds even in 480p and below i cant watch mostly anything, remember that my pc is...
Graphic Cards
Youtube slow today?
Have any of you noticed that youtube is slow on all web Browsers? I've tried all the Browsers in my PC.. FF, GC, IE Opera. But nothing? I can load any pages well, but not youtubr
Browsers & Mail
Youtube, Hulu and other streams load very slow!
Lately I've been encountering incredibly slow load times for streaming videos. I use Google Chrome (though have tested with IE and Mozilla to rule out the browser being the problem) and never used to have to wait for small videos to buffer. Now I experience buffer sessions every 5~10 seconds. ...
Network & Sharing
HELP!! YouTube is dead slow
hey guys, really appreciate some help here I am facing a strange issue with You tube in my Windows 7 pc. Its dead slow since last couple of days. For example, a 0:20 sec video takes almost 10 mins to buffer and play and sometime it doesnt start to buffer at all....i tired it with IE 8, Chrome,...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App