Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Google Chrome 7 dev released

28 Aug 2010   #11
Dark Nova Gamer

Windows 7 Ultimate, OS X 10.7, Ubuntu 11.04
 
 

Quote   Quote: Originally Posted by MilesAhead View Post
Quote   Quote: Originally Posted by DarkNovaGamer View Post
...
Glad to hear that. Sometimes it will kill extensions but it could be 'log-in' based ones like GMail ones. Let me know if you have anymore questions regarding Google Chrome/Chromium.
Thanks. Funny how it goes. I hated the idea of Speed-dial when it came out in FF. Had to find out how to kill it right away. Now using it in Chrome I got hooked. I finally put it on both my FF browsers. Better home page than about:blank

edit: seems snappy. Guess it should. Just running Speed-dial it has 8 processes going.
Try unpinning any 'Chromium' pins you made on your taskbar and start menu.

Then go to any shortcuts for Chromium you've made (desktop, start menu, etc) and add the following to the end of it (Put a space between .exe and the following):

--enable-gpu-plugin --enable-gpu-rendering --enable-accelerated-2d-canvas --enable-accelerated-compositing --enable-video-layering --enable-webgl --enable-fastback --apps-panel --web-apps


My System SpecsSystem Spec
.
28 Aug 2010   #12
MilesAhead

Windows 7 32 bit
 
 

--enable-fastback seems beneficial. But the rest of it kills off my Speed dial on new tab. Anyway, I don't think my GPU is ballsy enough to benefit from acceleration. At least not in browsers. Maybe for software video players.

edit: thanks for the options. I'll try various combos. Right now these seem to peacefully coexist: -enable-gpu-plugin --enable-gpu-rendering --enable-fastback
My System SpecsSystem Spec
28 Aug 2010   #13
Dark Nova Gamer

Windows 7 Ultimate, OS X 10.7, Ubuntu 11.04
 
 

Quote   Quote: Originally Posted by MilesAhead View Post
--enable-fastback seems beneficial. But the rest of it kills off my Speed dial on new tab. Anyway, I don't think my GPU is ballsy enough to benefit from acceleration. At least not in browsers. Maybe for software video players.

edit: thanks for the options. I'll try various combos. Right now these seem to peacefully coexist: -enable-gpu-plugin --enable-gpu-rendering --enable-fastback
Kills it for me as well. Though I have noticed a major boost in things since enabling the flags. Hopefully the new tab page will be fixed in the next few builds
My System SpecsSystem Spec
.

28 Aug 2010   #14
Alphamale

Windows 7 U/64
 
 

Trying it out now.
My System SpecsSystem Spec
29 Aug 2010   #15
Gornot

Windows 7 Home Premium x64
 
 

Any useful feedback yet?

I found it annoying that the current GC stable version builds up on RAM usage when the browser is open for, like, an hour or more. In addition to that, when I click on a bookmark/type in an address and hit enter etc. and then immediately resize the browser window, the page which is loading does not adopt to the new window size, instead it just loads as if I haven't resized the window at all.

Extensive usage of Flash produced choppiness and stuttering; its not as bad as in Firefox, where it completely freezes for a fraction of a second, but it is more constant (the best example for this? Playing JamLegend)
My System SpecsSystem Spec
29 Aug 2010   #16
MilesAhead

Windows 7 32 bit
 
 

Quote   Quote: Originally Posted by DarkNovaGamer View Post
Quote   Quote: Originally Posted by MilesAhead View Post
--enable-fastback seems beneficial. But the rest of it kills off my Speed dial on new tab. Anyway, I don't think my GPU is ballsy enough to benefit from acceleration. At least not in browsers. Maybe for software video players.

edit: thanks for the options. I'll try various combos. Right now these seem to peacefully coexist: -enable-gpu-plugin --enable-gpu-rendering --enable-fastback
Kills it for me as well. Though I have noticed a major boost in things since enabling the flags. Hopefully the new tab page will be fixed in the next few builds
btw- do you have a source for all the command line switches? Maybe with capsule descriptions?
My System SpecsSystem Spec
29 Aug 2010   #17
Dark Nova Gamer

Windows 7 Ultimate, OS X 10.7, Ubuntu 11.04
 
 

Quote   Quote: Originally Posted by MilesAhead View Post
Quote   Quote: Originally Posted by DarkNovaGamer View Post
Quote   Quote: Originally Posted by MilesAhead View Post
--enable-fastback seems beneficial. But the rest of it kills off my Speed dial on new tab. Anyway, I don't think my GPU is ballsy enough to benefit from acceleration. At least not in browsers. Maybe for software video players.

edit: thanks for the options. I'll try various combos. Right now these seem to peacefully coexist: -enable-gpu-plugin --enable-gpu-rendering --enable-fastback
Kills it for me as well. Though I have noticed a major boost in things since enabling the flags. Hopefully the new tab page will be fixed in the next few builds
btw- do you have a source for all the command line switches? Maybe with capsule descriptions?
I wish, I generally find these things by going through Neowin and reading what people say regarding Chrome/Chromium.
My System SpecsSystem Spec
29 Aug 2010   #18
MilesAhead

Windows 7 32 bit
 
 

Yeah, there was a list on one of the Chrome forums, but it's ancient. Anyway, the combination I'm running seems pretty snappy.
My System SpecsSystem Spec
30 Aug 2010   #19
MilesAhead

Windows 7 32 bit
 
 

Quote   Quote: Originally Posted by DarkNovaGamer View Post
...

--enable-gpu-plugin --enable-gpu-rendering --enable-accelerated-2d-canvas --enable-accelerated-compositing --enable-video-layering --enable-webgl --enable-fastback --apps-panel --web-apps
One good turn deserves another. I don't know if you do AutoHotKey but I hate that middle mouse click on a link opens a new tab in the background. So I did this ahk. When you middle mouse click on a link in Chrome, it sends Control Shift Left Click to open it in a new tab in the foreground:

Code:
SendMode Input

#IfWinActive, ahk_class Chrome_WidgetWin_0
MButton::
  Send, ^+{LButton}
Return
The line #IfWinActive, ahk_class Chrome_WidgetWin_0 restricts it so that the hotkey is only active when Chrome is the active window. Avoids interfering with other uses of Middle Click.

It will also work with Speed-dial. The dial you middle click will open in a new foreground tab instead of replacing the Speed dial page.
My System SpecsSystem Spec
30 Aug 2010   #20
Dark Nova Gamer

Windows 7 Ultimate, OS X 10.7, Ubuntu 11.04
 
 

Quote   Quote: Originally Posted by MilesAhead View Post
Quote   Quote: Originally Posted by DarkNovaGamer View Post
...

--enable-gpu-plugin --enable-gpu-rendering --enable-accelerated-2d-canvas --enable-accelerated-compositing --enable-video-layering --enable-webgl --enable-fastback --apps-panel --web-apps
One good turn deserves another. I don't know if you do AutoHotKey but I hate that middle mouse click on a link opens a new tab in the background. So I did this ahk. When you middle mouse click on a link in Chrome, it sends Control Shift Left Click to open it in a new tab in the foreground:

Code:
SendMode Input

#IfWinActive, ahk_class Chrome_WidgetWin_0
MButton::
  Send, ^+{LButton}
Return
The line #IfWinActive, ahk_class Chrome_WidgetWin_0 restricts it so that the hotkey is only active when Chrome is the active window. Avoids interfering with other uses of Middle Click.

It will also work with Speed-dial. The dial you middle click will open in a new foreground tab instead of replacing the Speed dial page.
Thank you for that. That looks helpful.
My System SpecsSystem Spec
Reply

 Google Chrome 7 dev released




Thread Tools




Similar help and support threads
Thread Forum
Google Chrome Not logging into Google account, white screen
Before I even say anything, I have tried to reinstall Chrome 3 times and the problem still stands. So my problem is that when I try to login to my Google account on Google Chrome, the web page goes white and Chrome does not log in. The steps I took are as follows: It starts on the regular...
Browsers & Mail
Google Chrome 12 Final released
Won't install on my PC Why is there no info on what version you are downloading ? Google Chrome - Get a fast new browser. For PC, Mac, and Linux If you want to read something about version 12 goto Download Google Chrome 12 Final
Browsers & Mail
Google Chrome 11 Final Released
April 27, 2011 Google Chrome 11.0.696.57 stable is available. Chrome 11 contains some really great improvements including speech input through HTML. Google Chrome Releases Download
Browsers & Mail
Google Chrome v8 developer build hints at future of Chrome OS
more
News
[Dev] Google Chrome 8.0.552.0 Released
Some things I've noticed right off the bat. If you go to About:Labs you'll see a new option called "GPU Accelerated Canvas 2D". Download: http://www.google.com/chrome/eula.html?extra=devchannel Source: http://googlechromereleases.blogspot.com/2010/10/dev-channel-update_12.html
Browsers & Mail
Google Chrome 3.0.191.3 Released
direct link: http://dl.google.com/chrome/install/192.1/chrome_installer.exe Highlights in this release: Highlights in this release: (Mac) Enabled support for the Mac OS X spellchecking service. (Mac) First cut at popup blocking for Mac. (Linux) Accelerator keys like ctl-C for copy should...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:07.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App