Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No internet connection but Skype works

31 Oct 2010   #11

Windows 7 Ultimate 64 bit

I had hard coded but didn't reboot; I just tried hard coding again and rebooting. Still no luck.

My System SpecsSystem Spec
31 Oct 2010   #12

Windows 7 Ultimate 64 bit

it's a tx2z 1000.
I clicked to uninstall the network adapter and the screen went all pixelated and my computer turned itself off entirely
My System SpecsSystem Spec
31 Oct 2010   #13

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer

Your computer should not get pixelated nor turn off by uninstalling a network driver. Can you restart the computer? If not, does it at least go to bios or splash screen?
My System SpecsSystem Spec

31 Oct 2010   #14

Windows 7 Ultimate 64 bit

So after a reboot, I uninstalled the broadcom and realtek adapters from device manager. Broadcom automatically started to reinstall itself while realtek was uninstalling. I downloaded the broadcom and realtek drivers, and tried to update the broadcom driver but it said the driver was already up to date. Then it re-installed realtek after a scan for hardware changes and same thing for the update.
Connected to internet but still no browser still no true internet.
I should mention the download and driver update attempt were off a usb that i downloaded to off another computer.
My System SpecsSystem Spec
31 Oct 2010   #15

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer

This seems almost identical to another post we had. Except he didn't have a BSOD...

Connected with no internet access
My System SpecsSystem Spec
31 Oct 2010   #16

Windows 7 Ultimate 64 bit

Reading that post there doesn't seem to be a fix from that problem, he ordered a new wireless adapter but no post of the results.
I have a warranty on the computer so if it's hardware then I can get that fixed but it seems to be more software than anything because I can actually access the pages if I type the direct IP address as mentioned in that forum (although not the entire page b/c it seems the pictures are hosted elsewhere). But I know its not linked to my router or my ISP b/c I'm using my roommates computer to use the forum and everything works fine for him and also I have the same issues at the University connecting to their network. I even tried VPN earlier and even that doesn't work (as I mentioned nothing works except skype).

I should mention I have to go to a meeting where since I have no internet on my laptop I won't be able to check this forum until an hour from now when I'll be back. Thanks for the attempts to help.
My System SpecsSystem Spec
31 Oct 2010   #17

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer

Just for the heck of it...

First - run malwarebytes and your anti-virus program.

Reboot. Any luck? If not ...

Uninstall your anti-virus program - just for testing purposes.
Remove Windows and/or any other firewall

Reboot. Any luck?
My System SpecsSystem Spec
01 Nov 2010   #18

Windows 7 Ultimate 64 bit

So I had already done a MSE full system scan right before i posted to the forum, found nothing. I've installed the Malwarebytes you suggested and ran it. It found a developer program to be a potential threat, I've had that installed for several months with no problem and haven't used it in the last month even so I doubt that is the cause but just in case I uninstalled it and removed it.
Reboot. No luck.
Uninstalled MSE and i've already turned off the firewall in all domains to try that earlier.
Reboot. No luck.

Reformatted my computer in the end.
LUCK. haha (although I knew that would work). I figured two days of messing with correcting the problem was enough and on top of it I got two BSODs (one during the malware scan) and another just randomly. So I figured it was probably better to reformat than try and solve the problem as the underlying issue was clearly some system files got severely messed up (from what I don't know).

Thanks for the attempts to fix it, sorry that in the end for anyone else having this problem there is no fix. I'm sure a system restore would have fixed it had I had a restore point to go back to.
My System SpecsSystem Spec
11 Sep 2011   #19

win 7 64bits

Hi, It seems I have got the same problem. After reading all the discussions, i still cant resolve it.

Please find below more details. Please let me know !

I just got a new machine fromDELL win7 64 bits. The machine was set up in the office and was connected to the network at that time.

When back home, I can’t get on the internet with cable and I can’t get on internet with wireless after entering WEP (which is recognized)

(All works fine with the old machine)

• I am not using any proxy
• IP and DNS obtained automatically
• I can see the new machine from the web interface of the internet provider “neuf box”.
• The new machine is given an IP Adress by the neufbox :
• I can’t ping the new machine from other laptop on the same network
• From the new machine, I can ping the neufbox @
• The status of the Wireless IPV4 wireless connection is enabled Ativity is good: Bytes are sent and received (about same number of bytes)
• From the new machine, I can’t ping Google
• I run into safe mode with network and I had the same issues
• My skype works and connects !!
• I installed earlier on a virtual machine from my old computer, and I was able to connect to internet from there. (Note that, for some unknown reasons, I can’t anymore)

I spent one hour on the phone with my internet provider. The technical support was able to connect to my box remotely and was able to see the new machine on the network. We checked there are no filter or anything that could block the access and we didn’t find issues.

Please help me troubleshoot the problem thanks
My System SpecsSystem Spec
11 Sep 2011   #20

Windows 8 Pro w/MC 32-bit

Can you ping Google's IP adderss: If you can just check your DNS server in the router or substitue for what's there just on your own PC via the network properties of the adapter you are currently using.
My System SpecsSystem Spec

 No internet connection but Skype works

Thread Tools

Similar help and support threads
Thread Forum
USB internet connection works, Ethernet internet connection does not
OK. I'm trying to switch from wireless to a faster(?) ethernet cable based internet access. I use a Dell Optiplex 755, 32 bit OS, Windows 7. I'm the utilizing Comcast high speed internet supplier, a LinkSys E4200 wireless router, a LinkSys WUMC710 (wireless-ac universal media connector; with...
Network & Sharing
Internet drops for browsers/Steam/AVG but Skype still works
The internet randomly stops working for browsers (IE, Chrome) but Skype always works. The outages will last for about 5 minutes or so. During these outages, the Store section of Steam also does not display anything and AVG cannot update. So in other words, everything but Skype will periodically...
Network & Sharing
Internet Connection Working But Web Pages Do Not Load. Skype Works!
My Internet was working fine this morning but now it says im connected but chrome and ie cannot load pages. I have tried stuff in dns and done the resetlog.txt in CMD. But that did not work. I can sign in to skype though and that works and connectes to the internet fine. And its not the router...
Browsers & Mail
Internet Connection works but web applications are not. Needs help.
Hi there. Let me start by saying that I have a background in computer programming and so I understand most jargon, however I don't have much experience with computer hardware problems and networking, so I may not have tried some very simple things. I believe I've tried everything and I have thus...
Network & Sharing
Internet browsers don't work' but Skype works fine
Last night my Internet suddenly crashed, and now both Internet Explorer and Firefox are unable to connect to the Internet although Skype strangely works perfectly. This makes me think it is a DNS issue but I don't know how to proceed. I have tried: Restarting Resetting winsock, IPv4, IPv6...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:07.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App