Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet Explorer 8 Stucks at Loading

04 Jan 2011   #1
boogieboy

Windows 7 Ultimate x64 SP1 | Windows 10 Pro
 
 
Internet Explorer 8 Stucks at Loading

Hi everyone. Whenever i try to open any blog link searched from Google they usually get stucks at loading and the cursor changes to rolling and i can't go back, close page or anything other than watching white blank page either they take several minutes to load or they just get stuck and i have to close it from Task Manager. I installed windows 7 updates and hotfixes and it's a no go. I installed IE9 beta before but i was'nt comfortable with that coz it looks boring and dull and it does'nt have good options relating to downloading any files but still that's my opinion Pages dont stuck on FireFox so what's the problem with IE? is'nt it optimized enough or it has'nt fixed bugs? HELP!

Regards.
Bilal


My System SpecsSystem Spec
.
04 Jan 2011   #2
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

IE is fine, I don't have those issues. What sort of system security are you running on your PC?
My System SpecsSystem Spec
04 Jan 2011   #3
roncerr

Windows 8 Pro w/MC 32-bit
 
 

You might post a link to a page that hangs so we can try it. You could also try a reset (Tools/Internet/Options/Advanced/Reset). I have a slow processor and sometimes have the same problem. I'm waiting for IE9 to come out of Beta before using it; it may work better since it's faster and more efficient.
My System SpecsSystem Spec
.

04 Jan 2011   #4
boogieboy

Windows 7 Ultimate x64 SP1 | Windows 10 Pro
 
 

@ Golden

Right now i not using any Securtiy Program but i used new MSE before

@ roncerr

ok i will post the link next time actually i was looking for some pictures and now forgot which link it was
My System SpecsSystem Spec
04 Jan 2011   #5
EzioAuditore

Winbdows 7 ultimate x64 | Ubuntu 12.04 x64 LTS
 
 

Quote   Quote: Originally Posted by roncerr View Post
You might post a link to a page that hangs so we can try it. You could also try a reset (Tools/Internet/Options/Advanced/Reset). I have a slow processor and sometimes have the same problem. I'm waiting for IE9 to come out of Beta before using it; it may work better since it's faster and more efficient.
Did you try the reset option as suggested?
My System SpecsSystem Spec
04 Jan 2011   #6
boogieboy

Windows 7 Ultimate x64 SP1 | Windows 10 Pro
 
 

i did reset but i will let u know if it will hang up on loading again
My System SpecsSystem Spec
04 Jan 2011   #7
ie9

Windows 7 Ultimate (SP1)
 
 

Quote   Quote: Originally Posted by boogieboy View Post
i did reset but i will let u know if it will hang up on loading again
Helpful link on how to do a screenshot if you need it. Good luck with IE!
My System SpecsSystem Spec
05 Jan 2011   #8
EzioAuditore

Winbdows 7 ultimate x64 | Ubuntu 12.04 x64 LTS
 
 

So, is that ok now?
My System SpecsSystem Spec
Reply

 Internet Explorer 8 Stucks at Loading




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 installation stucks when loading win 7 logo(icon)
My Samsung RV520 came with Windows 7 Home Premium 64-Bit installed, i formated the HDD and Partitioned it into 2 Drives @ 250gb in a bid to dual boot XP&Win7. After succesful installation of XP-SP3, ive encoutered a problem with Win7 Ultimate (both 64x and 86x) installation as i booted from dvd...
Installation & Setup
Windows Explorer Not Loading
I have an alienware m14X with windows 7 home premium 64-bit. Until recently my computer has ran fine, but now when i click the window browser button on the task bar, it won't load. The green bar in the path never runs all the way through, and the tabs on the right only show a rotating magnifying...
Performance & Maintenance
Internet Explorer crashes within 5 - 10 seconds of loading a page!!!
Hi All, I recently re-installed Windows 7 from some rescue disks, and everything, with the exception of Internet Explorer is now running fine! Basically whenever I load a web page in IE it crashes after a short time (5 - 10 seconds), and I then have to exit with CTRL + SHIFT + ESC (Task...
Browsers & Mail
Explorer not loading any contents
When I open the libraries from the taskbar, the icons for documents, pictures, music, etc. are not visible. The tree that should appear on the left pane also doesn't load. Just 'Libraries' is visible in the pane, with a magnifying glass moving on its icon. The same thing happens when I open My...
General Discussion
Internet Explorer Not working or loading
Does anyone know what this means. I have Mcafee, but I Don't see site advisor. I also have Kapersky! Please help! Thanks! Description: A problem caused this program to stop interacting with Windows. Problem signature: Problem Event Name: AppHangXProcB1 Application Name: ...
BSOD Help and Support
Windows explorer not loading up
Whenever I start up my laptop I get to where I put my password in, input password, Windows loads up but then freezes. The taskbar does not show and I am unable to get the taskbar up by pressing the windows button next to alt. The only thing that loads up is my documents folder but with no taskbar...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:35.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App