Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: One web site broken: one system, multiple browsers

18 Mar 2011   #1
richw42

Windows 7 Pro x64
 
 
One web site broken: one system, multiple browsers

This is really weird. If I go to www.OpenDNS.com, or almost any of the pages at that site, the browser tab hangs. The activity indicator shows busy, but nothing shows up in the display. I can right-click to view source, and see that some source has been loaded. Apparently there is something about the pages that hangs the browser.
This happens on both chrome and windows explorer 8. The system is windows 7 pro x64 oem, new system. I do not have the same problem on an xp system.
Help! How can I figure out what's causing this problem?
The fine print: I installed some old software (VB6), clicking past two incompatibility warnings. Perhaps it replaced an important dll?
I tried sfc /verifyonly and no problems were found.
I have not found any other "broken" web sites.


My System SpecsSystem Spec
.
18 Mar 2011   #2
Capt.Jack Sparrow

Windows 7 Ultimate - 64-bit | Windows 8 Pro - 64-bit
 
 

Hi there,

Go to C:\Windows\System32\Drivers\etc and open the Host file with Notepad and check if that website is listed there.
My System SpecsSystem Spec
19 Mar 2011   #3
richw42

Windows 7 Pro x64
 
 

Quote:
Go to C:\Windows\System32\Drivers\etc and open the Host file with Notepad and check if that website is listed there.
That's an interesting idea. However, hosts is just comments so far. Note that it appears that the browser is fetching the page, but dies trying to display it.
My System SpecsSystem Spec
.

20 Mar 2011   #4
richw42

Windows 7 Pro x64
 
 

OP here. I may be crazy, but it seems like the opendns DNS servers are incompatible with the opendns.com web site. I changed my DNS server to be 4.2.2.1, ran ipconfig /flushdns, and rebooted. Everything started working normally. I restored the opendns DNS servers, did ipconfig /flushdns, rebooted, and the problem returned. That is, the opendns.com web site does not load normally. If I wait long enough, I do get something, but it's missing much of the pretty stuff.
My System SpecsSystem Spec
20 Mar 2011   #5
Dwarf

Windows 8.1 Pro RTM x64
 
 

Works for me. And I use OpenDNS for my DNS server.
My System SpecsSystem Spec
20 Mar 2011   #6
richw42

Windows 7 Pro x64
 
 

Quote   Quote: Originally Posted by Dwarf View Post
Works for me. And I use OpenDNS for my DNS server.
I wonder if you are in a different geographical area, and thus use a different server? They do claim redundancy, don't they? Perhaps something is wrong with a local server? Or maybe my ISP is doing something interesting, although I have no idea what that could be. Since I have the same problem with multiple computers here, I'm not sure what I could be doing to cause the problem. I did try rebooting my Linksys router.

Hmm, maybe comparing trace routes would answer the question of whether we are using the same servers:
Code:
$ tracert 208.67.222.222

Tracing route to resolver1.opendns.com [208.67.222.222]
over a maximum of 30 hops:

  1     1 ms     1 ms    <1 ms  192.168.1.1
  2    23 ms    24 ms    23 ms  L100.STTLWA-DSL-04.verizon-gni.net [71.113.17.1]

  3    23 ms    23 ms    23 ms  P3-2.STTLWA-LCR-02.ncnetwork.net [184.19.242.192
]
  4    25 ms    25 ms    25 ms  50.34.2.37
  5    74 ms    50 ms    50 ms  ae3---0.cor01.sttl.wa.frontiernet.net [74.40.1.1
53]
  6   116 ms    50 ms    50 ms  ae1---0.cor02.ptld.or.frontiernet.net [74.40.2.1
53]
  7    49 ms    49 ms    49 ms  ae0---0.cor01.ptld.or.frontiernet.net [74.40.4.1
09]
  8    51 ms    51 ms    87 ms  ae1---0.cor01.plal.ca.frontiernet.net [74.40.2.1
58]
  9    50 ms    50 ms    52 ms  so--0-0-0---0.br01.plal.ca.frontiernet.net [74.4
0.3.150]
 10    50 ms    50 ms    50 ms  xe-0.paix.plalca01.us.bb.gin.ntt.net [198.32.176
.14]
 11    50 ms    50 ms    50 ms  po-3.r04.plalca01.us.bb.gin.ntt.net [129.250.2.2
18]
 12    48 ms    49 ms    48 ms  ge-2-3.r04.plalca01.us.ce.gin.ntt.net [140.174.2
1.166]
 13    49 ms    48 ms    48 ms  resolver1.opendns.com [208.67.222.222]

Trace complete.
I just figured out what I have to do. I have to use wireshark and capture the DNS traffic, and see if there is a difference between working and non-working configurations. Sigh. I didn't want to make a career out of this.
My System SpecsSystem Spec
21 Mar 2011   #7
richw42

Windows 7 Pro x64
 
 

I just did some debugging, and found the following:

With DNS server 4.2.2.1, www-files.opendns.com resolves to 208.67.216.142, and everyone is happy.
With DNS server 208.67.222.222 (which is one of the two opendns servers), www-files.opendns.com resolves to 204.194.237.142, and the web page does not display properly.
It is interesting that after a delay of about 30 seconds, there are a bunch of java DNS requests, and then the opendns.com page is displayed without decorations.
In the 4.2.2.1 case, the page displays correctly immediately with no java DNS requests.
My System SpecsSystem Spec
Reply

 One web site broken: one system, multiple browsers




Thread Tools




Similar help and support threads
Thread Forum
Multiple Browsers with multiple issues
Hey guys, I've currently got 4 different browsers installed on my computer (IE, Firefox, Chrome, Opera). I've had different issues with each and every one of them. Right now I'm using Opera and for the most part it's been pretty good. Although lately it's been starting to act up. I stopped...
Browsers & Mail
New to this site and have issues with Windows7 browsers
Hey folks. Just joined your website. Looks like a nice place. I hope to visit here often. :D I'm by no means a computer expert. I know the basics and have learned a lot from just asking questions and reading up on certain topics. However, I've got a couple problems that I'm unable to...
Browsers & Mail
Browsers blocking site access
I have just set up a new system running Windows 7 Professional 64 bit. For some reason I cannot access certain sites in any browser (IE, Firefox or Safari (Haven't tried Chrome yet)). Example sites that are blocked may be redirects such as those starting with Email Marketing Software & Email...
Browsers & Mail
Browsers can't open specific site but works fine in another account?
I have a job that requires me to log in to a webpage. In my current Windows user account, no matter what browser I use, I always get a 500 Servlet Exception error. I tried updating Java and disabling my firewall but I still get the error. Then I created another user account and am able to log in to...
Browsers & Mail
All Browsers Crashing trying to upload .doc on web site
Hi: I am trying to post a Word document on various web sites (my resume to apply for jobs) and when I click on the option to browse for the document (which is on my desktop) the browser "encountered a problem" and crashes. Any suggestions would be appreciated. Thanks Tim
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App