Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Browser issue driving me insane

17 Apr 2011   #1
sdk13

Windows 7 Home Premium 64bit
 
 
Browser issue driving me insane

I could just be dumb but when I type in the address bar to go to a site i have to click the green arrow to be able to go to the sire rather than be able to hit the enter/return key. Is there any way to fix this so that every time I want to change pages I dont have to keep clicking the green arrow to change pages and I can use my keyboard like a normal civilised person???

Also I'm using Friefox v4.0 if that helps.


My System SpecsSystem Spec
.
17 Apr 2011   #2
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Welcome to Seven Forums sdk13. You might try reinstalling FF, as the enter method should work. See the instructions here:

Uninstalling Firefox - MozillaZine Knowledge Base

Take note of this warning:
Quote:
Starting in Firefox 3, the uninstaller includes the option, "Remove my Firefox personal data and customizations". This will also remove your Firefox user profile data (bookmarks, passwords, cookies, extensions, preferences, etc.). DO NOT select this option if you want to keep your Firefox profile data and settings.
You may have a corrupted profile, and need to delete it:

Delete corrupted profile

A Guy
My System SpecsSystem Spec
17 Apr 2011   #3
sdk13

Windows 7 Home Premium 64bit
 
 

As it turned out it was an AVG safe search add on in Firefox restricting me. All I had to do was go to Tools - Add Ons - Extensions and disable the AVG safe search.
My System SpecsSystem Spec
.

17 Apr 2011   #4
marsmimar

Microsoft Community Contributor Award Recipient

 
 

Glad to know you got it sorted out. And thanks for posting back so others can benefit from your experience.
My System SpecsSystem Spec
17 Apr 2011   #5
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Good going sdk13, glad you got it sorted

A Guy
My System SpecsSystem Spec
Reply

 Browser issue driving me insane




Thread Tools




Similar help and support threads
Thread Forum
Sound crackling is driving me insane.
Based on my research, I appear to be another victim of windows 7 sound glitches. My specific problem seems to only happen when playing music. Or, at least, I have yet to truly notice it while playing a game or watching video. I've been trying to find a solution for a couple of weeks, including...
Sound & Audio
BSOD driving me insane - files attached - please help!
I'm not a supertech and am really hoping one will take pity on me and help me out here. You'd save me a couple of grand bc I'm about to put my fist through my laptop screen. I get BSOD crashes most days, with no pattern and they're making me crazy Running Windows 7 x64 as originally installed on...
BSOD Help and Support
BSOD's driving me insane!
Hi! I'm new one here and I have huge problem. In july BSOD's started to show up. I didn't bothered about it. Then I figured out that when I'm looking videos on youtube. So I didn't watch movies on youtube anymore. But then problem appeared again in December! I played Counter-Strike but suddenly...
BSOD Help and Support
Help Required... Driving me insane!!!
Hello everybody! Firstly i'm new here (so hi, hope you're all well and all that!) and also new to Windows 7. I have a second hand ASUS Eee PC netbook, running W7 Starter. I recently installed Skype and can't seem to get the built in webcam to work. I keep getting the "This device can perform...
Hardware & Devices
WMP12 Album Art driving me insane
Sup boys! This is my first thread over here. I am no noob to computers, or forums. My computer is running better than ever coming from XP, with one exception. I take pride in my music collection. It is small, but everything is just the way I want it. All tags are tagged in WMP and my PPC...
Media Center
Windows explorer lag driving me insane
I have looked and found a few references to problems similar to mine on these forums but no solutions. Apologies if i have missed any. I have a clean install of the retail version of W7 HP 32bit on a W7 formatted HD (300gb velociraptor). I have a pretty fast system with 4gb ram, E8500 CPU and...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 20:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App