Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Shockwave plug-in showing 92% CPU Usage in all browsers

17 Oct 2011   #1
cooldudeclan

Windows 7 Home Premium x64
 
 
Shockwave plug-in showing 92% CPU Usage in all browsers

Can't figure out what to do in all browsers this plug-in is running at extremely high percentages and slowing down my whole computer.

Videos are all playing very slow and choppy as well.

What the heck is going on?


My System SpecsSystem Spec
.
17 Oct 2011   #2
Zomby88

Windows 7 Ultimate 64Bit
 
 

Uninstall shockwave, you don`t need it.
My System SpecsSystem Spec
17 Oct 2011   #3
cooldudeclan

Windows 7 Home Premium x64
 
 

I need it for watching videos online don't I? I disabled it and now no videos will play?
My System SpecsSystem Spec
.

17 Oct 2011   #4
roncerr

Windows 8 Pro w/MC 32-bit
 
 

Quote   Quote: Originally Posted by cooldudeclan View Post
I need it for watching videos online don't I? I disabled it and now no videos will play?
The item called "Shockwave Flash Object" appears in the add-ons list in IE when you install "flash player" from the Adobe website. So you need to be careful that you download ONLY Flash Player from Adobe and nothing else. You don't need Shockwave or the Shockwave Player from the Adobe website just to play Flash videos like Youtube.
My System SpecsSystem Spec
17 Oct 2011   #5
cooldudeclan

Windows 7 Home Premium x64
 
 

Do you know of the page where I can download only the flash player and nothing else?
My System SpecsSystem Spec
17 Oct 2011   #6
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

Link> Adobe - Install a different version of Adobe Flash Player

Select your Windows version which your specs show 64bit. If for IE select it or "all others" in second drop curtain.

Chrome has Flash already loaded in the Chrome download.

Hope that helps.

I would uninstall old versions first.
Listed in Control Panel> Program and Features.
My System SpecsSystem Spec
17 Oct 2011   #7
Zomby88

Windows 7 Ultimate 64Bit
 
 

Quote   Quote: Originally Posted by roncerr View Post
Quote   Quote: Originally Posted by cooldudeclan View Post
I need it for watching videos online don't I? I disabled it and now no videos will play?
The item called "Shockwave Flash Object" appears in the add-ons list in IE when you install "flash player" from the Adobe website. So you need to be careful that you download ONLY Flash Player from Adobe and nothing else. You don't need Shockwave or the Shockwave Player from the Adobe website just to play Flash videos like Youtube.
Exactly .
My System SpecsSystem Spec
19 Oct 2011   #8
cooldudeclan

Windows 7 Home Premium x64
 
 

Followed the link and installed just flash, but got the "plug in:shockwave flash player" sometimes showing 107 under the cpu chart in chrome's task manager, and lagging all my videos in ff as well. Tryed wiping my hard drive and reinstalling windows same problem came right back.
My System SpecsSystem Spec
Reply

 Shockwave plug-in showing 92% CPU Usage in all browsers




Thread Tools




Similar help and support threads
Thread Forum
enable automatic updates not showing shockwave flash firefox
hi when i click on more under shockwave flash add on it doesn't show automatic updates to either set to default, turn on or turn off but it shows up on other add ones how do i get this to show up as i keep having to update shockwave flash manually and i just want it to update automatically...
Browsers & Mail
Web Browsers on 2nd Extened Display not showing up right
Ok, first of all everything in my PC is fine, the problem is that im using a usb/hdmi adapter to connect to a 40' inch TV. On my Display settings, i have it to mirror my PC screen to my TV. Ive been doing this like for 2 years with no problems but about 2 months ago when it mirrored on to my TV...
Browsers & Mail
Shockwave flash ridiculous memory usage.
In every single browser, flash has always been the biggest problem. I often had one or two GB of memory used up by Firefox or Chrome, even after getting a TabUnloader and having no YouTube videos open. I recently switched to Vivaldi, a power user browser, and it has a task manager that lets me see...
Browsers & Mail
Downloads on all browsers not showing up but still downloading
Well, weird issue I'm having here which started last week. Whenever i try to download something from a site, no prompt will show up asking where i want to save it or anything, but it will still download. Once the download is done, it THEN asks what i want to name it and where I want it to...
Browsers & Mail
My laptop is not charging but showing plug in.
Yesterday I encountered a problem. My Dell laptop not charging. But is showing in notification area charger plug in but not charging. I check my battery heath from bios. It's showing battery health normal. But adapter type showing as a unknown. I am confused If my adapter is going to dead, then why...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:56.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App