Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: I don't have permission to install Firefox ???

31 Jan 2012   #1

I don't have permission to install Firefox ???

After 35 years of using windows products I have come across another one that leaves me in the dark. Maybe its old age (74). Can you help a senile old man?
I am using Chrome and I want to listen to AOL radio. It plays awhile then I get a message that flashplayer has crashed. Flashplayer is enabled. This is a constant problem with Chrome. Pain in the butt.
So I start up IE 9 thinking I will listen to AOL Radio. IE9 cannot find AOL Radio. In fact it says I am not connected to the internet. I am connected 24 hours a day and the MSN web page comes up before the message I'm not connected. So how could I not be connected to the internet?
So, I decide I will try Firefox. Have not had it for a cupola years because of previous firefox problems. I download it from File Hippo with my Internet Download Manager.
I open it, it extracts, then I get a message that says I may not have permission to run the program. It asks me to check one of two boxs. One with my user name or Administrator with a password. I don't have a password, but neither boxes work, no matter what I check. I am not allowed to run Firefox.
Is there something new with Firefox that you have to have permission to run it?
No. I do not have any bugs. I ran Avira & SuperAntispyware.
I only use IE for updates. I use Chrome as primary browser. I am the only one that uses this computer.
Thank you

My System SpecsSystem Spec
31 Jan 2012   #2

Win 7 Home Premium x64

I can't quite tell from your post, did it install and now it can't run?

If yes try right clicking when you open the program and choose "run as administrator".

If not installed, similarly, right click the installation file and choose "run as administrator".
My System SpecsSystem Spec
31 Jan 2012   #3

Microsoft Windows 7 Home Premium 64-bit 7600

perhaps try a download from mozzilla here.

Mozilla Firefox Web Browser
My System SpecsSystem Spec

31 Jan 2012   #4


It did not install or run. A run box came up with this message:
"You may not have the necessary permissions to use all the features of the program you are about to run. You may run this program as a different user or continue to run the program as the current user" What? No matter what I checked, it does not run.

Who's on first
What's on second
I don't know is on third

I downloaded it from the Mozzila website using Chrome. Again, IE 9 cannot find anything. No matter what I put in the search box, it stays on the MSN web page.
Right now only Chrome works except for the Flash thing. Is Google taking over the world and not letting other browsers operate?
I have an XP note book in the house. I'm going to try that.

I tried IE again and no matter what I put in the search box it either stays on the MSN page or I get the Internt Explorer Cannot Display the Webpage
My System SpecsSystem Spec
31 Jan 2012   #5

Microsoft Windows 7 Home Premium 64-bit 7600

does seem odd, i have never seen this message when installing firefox.
My System SpecsSystem Spec
31 Jan 2012   #6


I went back to file hippo and downloaded Opera. The program ran and I will try AOL Radi with that.

I think this problem has to do with a system permissions. Something is locked or inaccessible. Don't knopw what. I'm going to play with Opera now.
My System SpecsSystem Spec
31 Jan 2012   #7

Win7 Pro-64 Bit

You could try this. Go to Control Panel > User Accounts, click the Change user account control settings and set the slider to never Notify. Or if it is already set to never notify set it back to default settings.
My System SpecsSystem Spec
31 Jan 2012   #8

Windows 7 Ultimate 64 bit

Download & save Firefox to your desktop then right click the file & select run as administrator.
My System SpecsSystem Spec
31 Jan 2012   #9

Windows 7 Ultimate SP1 - 64 Bit

Try #Post 7, Step 3 here:
cookies disabled???
My System SpecsSystem Spec
01 Feb 2012   #10


Downloaded to desktop, slider set to don't notify and CCleaner deletes cookies every day and my browser does not save them.
Will not try to install Firefox anymore. Opera works fine for AOL radio and I am not having Flash problems, yet.
Now I am going to work on why IE 9 will not do any searchs and comes up with not connected to the internet (while both Opera and Chrome can connect. Maybe I'll start another thread or find one with a similar problem. Thanks for your responses. Maybe I'm on Firefox's blacklist, though I have not sent complaints to them. ???
My System SpecsSystem Spec

 I don't have permission to install Firefox ???

Thread Tools

Similar help and support threads
Thread Forum
Using gpedit.msc for install for permission
I have a program on many computers in the office that every so often the company that created it rolls out a update, the Problem is that the users are standards users so I have to go to each machine make them a admin then update the program and then go back and make them a standard user again... is...
General Discussion
Tried to install HP printer but keep getting don't have permission
Guys/Gals, I did clean install and tried to install my HP printer but keep getting don't have permission from Administrator to install. The thing is, I'm the only user on this pc and I don't know how to get permission. I've tried to install it 3-4 times with same results but on a couple occasions...
Hardware & Devices
Install permission dialogue box not popping up
When I install something and it asks whether I will allow such and such a program to make changes/install, it does not pop up with the window but is running as I'll eventually notice it in the task bar. How can I make it so it actually pops up and gets my attention..?
General Discussion
Have to give permission to open Firefox
I am using Firefox 3.5.9. Operating system is W7 64 bit Home premium,. FF worked fine until a few days ago. Now when I click to open I get a box pop up asking if I will allow this software (FF) to make a change to my computer. Click yes it works fine. I have made no changes but figure there...
Browsers & Mail
install msi with admin permission
how to do this? it tells me i dont have permission to write to msvp80.dll
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:43.
Twitter Facebook Google+