Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Browsers not working, internet connection is fine

08 Aug 2017   #21
Olu

Window7
 
 

I don't know how to start a new thread here... And I'm using chrome and Mozilla on my laptop, and I have not been using the internet explorer before but I tried it too now...all browser are not connecting


My System SpecsSystem Spec
.
08 Aug 2017   #22
ethel

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Hi Olu, If you click on the link below it will show you how, and choose network and sharing to ask your

question.




How to Post a Question in a New Thread at Seven Forums
My System SpecsSystem Spec
Reply

 Browsers not working, internet connection is fine




Thread Tools




Similar help and support threads
Thread Forum
Internet Connection Timeout, across all browsers
Good afternoon, For the past week I've been having internet connection problems on my Asus laptop. This happens only on my laptop, not my tablets, phone, PS4, Xbox or anything else. I usually use Chrome for browsing, but have tested this error across all browsers (Firefox, IE) with the same...
Network & Sharing
Internet not working, windows update, ping, DNS, etc. working fine
Hello, I've got a Dell laptop here that isn't functioning properly. I can't get this to work for the life of me! I am currently using this laptop with a different hard drive, it's the install on the SSD that doesn't work. I know that the quick fix would be to simply reload windows, but I don't...
Network & Sharing
Browsers Not Working - Internet Connection Fine - Tried "Everything"
I mainly use Google Chrome as my internet browser and about a week ago it started acting up. It would get stuck on a page or would repeatedly send me back to my homepage. I was able to use Skype, Ventrillo, World of Warcraft, etc. My AVG wasn't catching any problems, but the problem was...
Browsers & Mail
Internet browsers don't work' but Skype works fine
Last night my Internet suddenly crashed, and now both Internet Explorer and Firefox are unable to connect to the Internet although Skype strangely works perfectly. This makes me think it is a DNS issue but I don't know how to proceed. I have tried: Restarting Resetting winsock, IPv4, IPv6...
Network & Sharing
Losing internet connection after 10 minutes to browsers. Please help!
So since last night, I have been having some issues, staying connected to the internet I can get on either browser (whether it be IE, FF, Chrome) and it will work just fine, but after 10-15 minutes, I can no longer access any sites. I haven't downloaded anything recent either so I can't figure...
Browsers & Mail
32 bit browsers not working 64 bit fine ???
I am Having problems after doing a full clean install of windows 7 64 bit on my pc about two weeks ago I was pleased to see that everything seemed to be working well but over time the nagging faults have started to creep in it has started to restart itself just after the log in screen and also to...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:44.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App