Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: IE9 taking4ever and not loading page, Firefox OK.

04 Dec 2012   #1
soryu

win7homepremium 64 sp1
 
 
IE9 taking4ever and not loading page, Firefox OK.

IE9 just upgraded from 7 or 8 not sure but it's not loading pages i just get the little spinning circle on the tab and nothing happens. i have reset to default in internet options, same thing. i downloaded firefox on a different laptop saved it to flashdrive installed it on said PC and it works fine.
anyone know what else i can do?
one weird thing i saw was there was a chinese search provider in manage-addons.
i removed it.
i've done some scans malwarebytes anti malware, ccleaner, MSE, they come up clean.


My System SpecsSystem Spec
.
04 Dec 2012   #2
marsmimar

Microsoft Community Contributor Award Recipient

 
 

It's possible that something may have interfered with a clean install of IE9. You could remove it and then reinstall it. When you uninstall, the previous version will be reinstated.

Internet Explorer 9 - Uninstall

Before attempting to reinstall IE9 you might want to look through these Microsoft articles.

Prerequisites for installing Internet Explorer 9

Troubleshoot problems when you cannot install Internet Explorer 9
My System SpecsSystem Spec
05 Dec 2012   #3
soryu

win7homepremium 64 sp1
 
 

i removed some unnecessary (apple) programs, used ccleaner a couple of more times ran MSE it found a virus. removed it IE seems to be working now.
My System SpecsSystem Spec
.

06 Dec 2012   #4
marsmimar

Microsoft Community Contributor Award Recipient

 
 

Glad to hear you got it sorted out. Thanks for posting back.
My System SpecsSystem Spec
Reply

 IE9 taking4ever and not loading page, Firefox OK.




Thread Tools




Similar help and support threads
Thread Forum
GOOGLE Search page always displayed on Firefox new page (+) openings
Using Mozilla Firefox. I have set Home Page as blank, so the initial screen is blank. When the + to open a new tab is clicked the page is always displayed as a FIREFOX START page displaying a GOOGLE Search in the middle of it. (happens on at least v-24.0 thru 26.0 beta) ...
Browsers & Mail
Some help with page not loading completely
If this is in the wrong place, don't hesitate to move it. This is the URL in question: Daily Deals, 1 Sale A Day I can't capture the entire page because I have to scroll down but you should get the idea of my problem which has been bugging me for months. Note capture one is from the...
Browsers & Mail
Forum Page Loading
HI, Since updating to Firefox 4 I have noticed that moving to the next page when viewing 'New Posts' for example seems to take forever. Whats it like using other browsers. ? :(
Browsers & Mail
Loading Next Page Message
Hello, As I scroll to the bottom of a web page after a search, I get these popups saying loading next page. Can I turn this off? Also, If I set windows update to automatic, do I still have any say in what downloads? For instance, I don't want windows live updates and I don't need any language...
General Discussion
Web page not loading
Any idea what would stop my brouswer from not opening a web page. It's the county school page so it's nothing you'd expect to be blocked in some way. I've checked (or uncheck) the usual suspects and I don't seem to have any problem with any other site. My Vista machine loads it just fine. Both pcs...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App