Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Firefox, Thunderbird, Interner Explorer issues

29 Dec 2012   #1

windows 7 home premium
Firefox, Thunderbird, Interner Explorer issues

Win 7, SP1 running on a tower with an EVGA motherboard.

On my tower at my desk I seem to have a problem with both firefox(FF) and thunderbird(TB)!
Here it is: For several days now I have not been able to run either TB or FF. When I click on either one, I get an error msg that states:

"Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system"

So I call up msconfig.exe and find no 'program' or 'process' that would interfere with TB or FF. I open up 'Services' and nothing installed as a service.

So, now I think "Virus". So I run Zonealarm AV and it reports 'no virus'. I install Comodo AV and it reports no Virus. The same for

I have installed and reinstalled both TB and FF 4 times now and there is no change to that message. Now let's talk about Internet Explorer. When I open either 32bit or 64bit I get the following:
"A program on your computer has corrupted your default search provider setting for Internet Explorer. Internet Explorer has reset this setting to your original search provider, ( Internet Explorer will now open Search settings, where you can change this setting or install more search providers"

I have uninstalled all firewalls and antivirus programs and there is no change.

Now all I can think of is 'rouge toolbar'. And it is hiding way up in the troposphere where I can not see it and it is out to get me!

Anyone that can point me to new actions to take would be appreciated!


My System SpecsSystem Spec
29 Dec 2012   #2

W7 Ultimate SP1, LM18.3 MATE, W10 Home, #All 64 bit
Try this

Check that Firefox isn't listed in the Task Manager processes.

As a temporary workaround try this:
Open the "Run" box (or the you can use the Start Menu search box) and try typing:
Firefox -no-remote
There is a space between the "x" and "-".

Have a look at these articles too.
My System SpecsSystem Spec
30 Dec 2012   #3
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

lehnerus2000 has posted good info on the FF problem, so I will add some info for IE. Have a look here:

Internet Explorer 8 restores the search provider settings when the "Prevent Internet Explorer Search box from displaying" Group Policy setting is enabled

Or for IE9 try deleting the file mentioned as the Answer in this thread (note the need to Show hidden, and unhide OD files as mentioned by Mushaf a couple of posts below)

IE9: A program on your computer has corrupted your default search - Microsoft Community

You may be well served to run the System File Checker and see if it finds any issues to correct.

SFC /SCANNOW Command - System File Checker

A Guy
My System SpecsSystem Spec

30 Dec 2012   #4

W7 Ultimate SP1, LM18.3 MATE, W10 Home, #All 64 bit
FF Safe Mode

If you think that a faulty add-on or rogue toolbar is causing your problem, try starting Firefox in "Safe Mode".

Firefox - Start Firefox in "Safe Mode"
My System SpecsSystem Spec
31 Dec 2012   #5

windows 7 home premium


Thanks for the quick reply! After looking at the articles you noted in your reply, I found that from then on the job was done!

A: I deleted the 'parent.lock' files from the firefox and thunderbird default profiles.
B: When I got to: 'Check access rights' in the "Firefox is already running but is not responding" error message - How to fix it | Firefox Help page, I found them 'Read Only'.

I have a feeling that this problem was a self inflicted one. I remember that about a week ago I was fooling around with 'Permissions' but do not recall working them in that area. However, I found that ever file under 'AppData' had been checked read only.

So, the mystery has been solved by the Win7 Team and I thank you all very much!

My System SpecsSystem Spec
31 Dec 2012   #6

W7 Ultimate SP1, LM18.3 MATE, W10 Home, #All 64 bit
Backup HDD Image

Good to hear that your problem has been solved.
Thanks for reporting the solution that worked for you. :)

For future reference:
You should create a backup HDD image, BEFORE tinkering with your System Permissions and other settings.

Windows has a built-in backup tool, but I use Macrium Reflect (Free) to create my images.

Backup User and System Files
Imaging with free Macrium
My System SpecsSystem Spec

 Firefox, Thunderbird, Interner Explorer issues

Thread Tools

Similar help and support threads
Thread Forum
Firefox-Thunderbird Questions
When downloading a new Thunderbird email from the link provided by MoxMom... once installed and ready to start, do i create a new email handle/address such as or do i skip that procedure, but then again (common sense-wise-dah) is that there has to be email address created...
Browsers & Mail
How to move Thunderbird/Firefox profiles to Truecrypt Drive properly?
Hello, I have been using Truecrypt for a while now. Got to thinking that my email is only protected by being hidden, probably as well as Firefox Data. Is it a good idea to move the storage locations to an encrypted disk and if so what would be a surefire way to do it safely and correctly? Thanks...
Browsers & Mail
Running W7 64 bit home accessing interner ONLY in protected mode
Since two days ago I cant access internet anymore. Called the provider, they send a tchnician and he told me that its a new problem in a recent (1 week old) version of windows 7. In normal mode I cant acces but in protected mode I can (without all funcionalities). The technician told me to...
Network & Sharing
U 32 Bit SP1: Long Boot, Freeze on Firefox, Thunderbird, Word etc.
Hello All, I have an Acer Aspire 5734Z running Windows 7 Ultimate SP1. In the last week the initial OS boot (from the time I see the cursor until the long screen appears) has increased in length from 10 or so seconds to around a minute. More importantly, though, several applications I routinly...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App