Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Forever loading web browser

27 May 2013   #1
snakes27

Windows 7 Ultimate 32bit
 
 
Forever loading web browser

This always happens when after i watch couple videos from youtube and then the internet stops working. The browser takes forever to load. The loading bar just keeps spinning doesnt load the page at all. This happens to all the web browsers. The internet is connected but it doesnt work at all. Its not only the browser, the online games i play take forever to log in. It runs for 3hours and nothing happens. When ever this happens i have to restart my computer to make the net work again. I have already tried re installed windows since it thought it was a malware but problem is still there
Could you please help me fix this...
Thank you


My System SpecsSystem Spec
.
27 May 2013   #2
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

You're going to have to give more information about your PC before anyone can help you.
Click on your "User Control Panel" and fill out your system specs :)
My System SpecsSystem Spec
30 May 2013   #3
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Yes please add more details,
Standard processes to try,
Delete your browser history,
Open Internet explorer,
Hold the Alt key down and type these letters TD, (or Gear symbol on the top right/ Internet options/ Delete button)
Check All of the boxes and Uncheck the very top box,
Click on Delete.
Close ie,
Reset ie9 or ie10 manually,
Click the Start button on the Taskbar,
Click on Control panel,
Click on Internet options,
Go to the Advanced section,
Click on Reset button on the bottom,
Check the box to Delete personal settings,
Use the recommended setup and install options.
Shut down your machine.
My System SpecsSystem Spec
.

31 May 2013   #4
Scottyboy99

Windows 7 Ultimate 64 bit
 
 

If he has re-installed Windows and the problem is still there then I don't think the computer is the problem. I would suspect a router issue. OP, have you tried power cycling the router?
My System SpecsSystem Spec
31 May 2013   #5
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64
 
 

Can it be the router, sure can but knowing the system specs would help a bunch.
My System SpecsSystem Spec
31 May 2013   #6
Faladu

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1
 
 

Yes if the internet performance goes BAD, I always cycle my cable modem AND router first.

OP should tell us of any recent changes to their system BEFORE the performance went bad, also.....

For instance, ran any so called internet speed enhancement tools?

Called your ISP and have them check your connectivity?

Some cable could have gone bad or is loose, network cards or on-board Ethernet certainly go bad, mine went goofy and put in a PCI card I had lying around unopened, and was back in business.

Routers/Cable Modems DITTO, over last 10 years, replaced router once, cable modem twice and the router didn't technically need it, but it was old dinosaur with mediocre encryption and bought a much improved one.
My System SpecsSystem Spec
Reply

 Forever loading web browser




Thread Tools




Similar help and support threads
Thread Forum
Browsers take forever loading same website/websites but only on one pc
IE, Opera, FF, Chrome, all have problems loading the same websites while other sites load right away. Just for an example... racerxonline.com will not load on any browser, but only on one of my windows 7 pc. My second win7 and linux pc work fine using the same router and all three computers are...
Network & Sharing
Youtube doesn't load tumbdnails, keeps loading forever
As the title says bringing up a YouTube page doesn't load all thumbnails including my own in the top left and users/videos ones. Page looks like this: http://i60.tinypic.com/16a41v6.png http://i58.tinypic.com/dn1ysy.png This happens in Chrome and Firefox. It started about a week ago...
Browsers & Mail
Computer searching or loading problem. Takes forever.
Okay , here is what I got.. basicly , I can't access to my folders (Only through programs and shorcuts that I saved , I can access to those folders like "downloads" ,"My personal files"). This started after my laptop became very slow , I downloaded "CCleaner" and "Avast Free anti-virus" , and...
General Discussion
Browser Not Loading Up :(
I try to access Google chrome and click the icon or the .exe, it shows the loading cursor and then just does nothing, completely forgets about it! I try internet explorer and still nothing. I Use my antivirus software (avast) to scan but it finds nothing. I Try cCleaner but now cCleaner wont...
Browsers & Mail
Windows starting up loading screen forever!!!
k i created a partition and formatted it of 70gb to install windows 7 in it. Im obviously using the clean install method, everything goes fine. It expands the files, it installs them,copies them, etc. When my system is booting up, it shows me the screen of windows below saying "windows is starting...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App