Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Should I run Ccleaner if browsers are slow?

13 Jan 2015   #141
Jesse Williams

Windows 10 Home 64-bit

John, I understand completely. Just help me out when you can and when you have time.

My System SpecsSystem Spec
14 Jan 2015   #142

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

That's that out of the way then mate.
My System SpecsSystem Spec
14 Jan 2015   #143

windows 7 home 64bit

Yes John nothing else needs to be done ... The OP has done several scans for Malware and Viruses so this should be the end of the Thread ...
My System SpecsSystem Spec

20 Jan 2015   #144

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1

Hi Jesse, browsers running okay, everything else okay?

I'd of posted sooner, but we just got my Mum in rehab and I'm now catching up.

Thank you for your thoughts and prayers.

My System SpecsSystem Spec
20 Jan 2015   #145
Jesse Williams

Windows 10 Home 64-bit

Yes! Everything is working great. You are welcome. I will continue to pray for her. Thanks for your help!
My System SpecsSystem Spec

 Should I run Ccleaner if browsers are slow?

Thread Tools

Similar help and support threads
Thread Forum
All browsers suddenly slow
For some reason, only half the number of images load on facebook, youtube videos are slow to load and all the browsers I have tried (default Chrome) are very slow. Usually however my browser speed is fast for 2 minutes after resetting the PC. I have tried clearing history, cache, and my internet...
Browsers & Mail
Need Help With CCleaner Results-VERY slow/none existant browser search
Hi everyone ....... My browsers, chrome, IE etc wont load anything.......ive tried a number of things and just installed CCleaner ( via erthernet cable ) I have saved the resuklts which i shall attach.......any help would be gratefully appreciated :) Thanks in advance
Network & Sharing
Browsers Vey Slow
Last week I had a catastrophic failure. I donít need to get into details but bottom line is that Windows 7 (x64) had to be completely installed from scratch. My buddy at the shop had the foresight to save all my data files before formatting and installing. Everything is back running well except my...
Browsers & Mail
Suddenly very slow browsing, all browsers
Since two days ago all my browsers function very slow. A new tab can take 15 seconds to open, typing in addressbar has very long delay (I type an address and hit Enter, it takes up to 20 seconds for first letter to appear, then other letters appear one in every 0.5 to 1 second). Typing this post...
Browsers & Mail
Slow Browsers Startup
Hi, Recently I have noticed that IE9 and Firefox 5 take a really long time to load up on startup, whereas Opera loads up instantly on startup. I have tried disabling all add-ons for both these browsers, as well as disabling all startup entries to see if these have an effect. I have also ran...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App