Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot Connect to Library Website

07 Mar 2015   #1

Windows 7 Home Premium 64 bit
Cannot Connect to Library Website

Well, actually, I can connect to the library's website, but it's from that point on where I run into trouble.

It's kinda strange, because I am able to access several of the library's features by clicking on their website links, but I can't use the one which is for "My Account." Whenever I try that one, I get the "This page cannot be displayed" message.

When I contacted the library's "Help" service, they tried to figure it out, but without any luck. In their opinion, it seems as though Java is not installed on my computer; however, I have uninstalled the old version of Java, then installed the latest one, all to no avail.

Additionally, I have gone through the following sequence of steps, once again, to no avail: IE's "Tools," "Internet Options," "Security" tab, "Custom Level" button, scrolled down to "Active Scripting," made sure the "Enable" button was checked, clicked "OK," closed IE, revisited the library's website...same result. Actually, I have tried all of this more than once, both without restarting my computer, as well as restarting it, afterwards. Still no soap.

I have tried using System Restore, no change.

I have uninstalled all of my security software (AVG, IOBit Advanced System Care), still no luck. The library system uses a program called "Polaris."

Any help would be greatly appreciated. I am using an Acer Aspire 5742Z-4097 laptop, running Windows 7 Home Premium, Internet Explorer 11.0

Okay, now for a shamefaced admission: I'm pretty sure that I caused this problem, myself, when I became curious about some of those interesting-looking functions that the Advanced System Care program offered. My computer was running kinda slow, so I was trying to speed it up a bit, and went into some of those options offered and began monkeying around. I can't really remember, now, if that's when my problem with the library system's website began or not, but I think so. Shot myself in the foot by messing around with things over my head, I know. Actually, I know just enough to be dangerous, but no more.

So, given all of that, maybe I just need to do some kind of a major reset of all defaults on my computer but I don't know how to do that without getting into even deeper trouble.

Any thoughts?

Thanks, in advance, for anyone who was nice enough to read all of this and to stick with me for some help.

My System SpecsSystem Spec
07 Mar 2015   #2

Win-7-Pro64bit 7-H-Prem-64bit

Hi and welcome to SevenForums,
Unfortunately you've used two of the most windows killing utilities possible IOBit and advanced system care,
Clean install will only fix your machine now unless you have a system image before you used them :/
IOBit has allot of crapware floating around I have no idea why or who is recommending it's usage
Repair Install

Clean Install Windows 7
My System SpecsSystem Spec
07 Mar 2015   #3
A Guy

Microsoft Community Contributor Award Recipient

Windows 10 Home x64

I am also not a fan of IObit, nor ASC, and you are likely right about that causing this. Before attempting the Repair or Clean install, I'd try resetting IE

Internet Explorer - Reset

You could also try running the System File Checker

SFC /SCANNOW Command - System File Checker

ASC can make both browser changes, and system changes, so it is hard to say where the problem lies

A Guy
My System SpecsSystem Spec


 Cannot Connect to Library Website

Thread Tools

Similar help and support threads
Thread Forum
email website links and taskbar pin website defaulting to Chrome
Links to websites, either from emails or from shortcuts pinned to my PC desktop's task-bar have suddenly been directed to Google Chromes search page. There are four icons pinned to the task-bar that work;Windows Media Player, Internet Explorer, Google Chrome, Google Earth and Windows Live Mail all...
Browsers & Mail
cannot connect to the real "website"
Please see the attached pictures I cant connect to https sites ?
Browsers & Mail
The download button in MS Website got covered by its website!
This is what happens when I tried to download ANYTHING from Microsoft (most of them are free applications): I've tried to uninstalled silverlight and re-installed it. I've also tried with updating graphic driver,...
Browsers & Mail
Library Conundrum: 'Arrange By Folders' is Missing in Custom Library!
A year ago, I created a custom Library and have been using it successfully until the beginning of this week (11/7/2011). The library's folder location is similar to the following: C:\Users\USERNAME\FOLDERX Now, when I open the Library, it shows a listing of all of the files found within all...
General Discussion
Fifefox: 1 computer opens website other can't connect?
Basically Ive seen this before when proxies become enabled and it won't let u access internet. But here's what happens: Some big websites, like, or some microsoft websites are just "unable to connect" as if there's no connection. I tried to get on my laptop- and used same...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:03.
Twitter Facebook