Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Browser links not working

23 Mar 2015   #1

Windows 7 Home 64 bit
Browser links not working

Having a problem with IE and Firefox in Windows 7(on a different computer) .........they both work
properly after switching off and back on for a while but then links will not open in either browser. I have refreshed Firefox and reset IE to defaults but makes no difference. Tried resetting the router (it is a wireless connection) but the same thing happens. Has anybody any ideas please?

My System SpecsSystem Spec
23 Mar 2015   #2

Dual Boot: Windows 8.1 & Server 2012r2 VMs: Kali Linux, Backbox, Matriux, Windows 8.1

Will need a little more information but what about if you use something like Junkware Removal Tool or Adwcleaner?

Sounds like it could be a browser hijack of some sorts.

AdwCleaner Download
Downloading Junkware Removal Tool

Adwcleaner will force you to restart your PC

After that, please post a little more information. When this started, if you installed something to cause this.. any other symptoms?
My System SpecsSystem Spec
23 Mar 2015   #3

Windows 7 Home 64 bit

Thank you for your reply. I will do what you advise and report back tomorrow. (Nothing has been installed to cause this problem)
My System SpecsSystem Spec


 Browser links not working

Thread Tools

Similar help and support threads
Thread Forum
links is missing when pasting text with links in any browser or office
Hi, When I'm copying text withe links from the web and trying to paste it, The links is missing. I try to paste it into word or excel, and in all kinds of html editors in all browsers but the links are still missing. only text is shown. Is anybody here knows how to fix it? Tx very much...
Browsers & Mail
Keep Links As Link Not In A Browser But Taskbar, Question?
I'm made a short cut that opens up a web browser then goes to a website I told it to. I launch the icon from the desktop it works. I launch the icon from the task bar and it works. In the taskbar it changes from a link to the application when it is launch it does everything I want it to do but if I...
Browsers & Mail
Erratic browser behavior (links not working) - DNS problems?
I have a weird problem that has been plaguing my Dell Studio 1555 for the last couple months. Most of my web browsing seems to work just fine, but i have certain links or pages (or elements within a page) that don't work. I have tested these sites on IE, FF (my default) and Chrome, and the same...
Browsers & Mail
Browser search links hijacked
1) IE 8 / Google search results, click on any and get redirected to another site. IE 8 / Bing search results, click on any and get redirected to another site. Google Chrome, complete a search, click on any and get redirected to another site. Mozilla / Google search results, click on any and...
System Security
Links open in Word Doc not Browser
I'm using Windows Live Mail. Something must have changed recently that I am unaware of, but here is my problem. All links in an email (such as open in MSWord and not my Firefox browser? It use to work just fine. I check my 'extensions' and it show anything with a .com to use...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:07.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App