iexplore.exe possible memory leak/cpu usage


  1. Posts : 21
    Windows 7 Home Premium 64-bit SP1
       #1

    iexplore.exe possible memory leak/cpu usage


    So I have been experiencing this problem for awhile now and cannot for the life of me figure out what the culprit is. Whenever I tend to watch videos (on any browser) I occasionally encounter an issue in which I would close my browser and I would still see 2 instances of iexplore.exe appearing in my task manager. One of these always uses a set amount of cpu usage of 13% and usually using up the same amount of memory as when I closed the browser. Iexplore.exe continues to sit there using CPU and RAM until I manually end task. This tends to happen frequently when viewing multiple videos back to back, youtube especially, and I have tried several things to try and fix it. I've uninstalled adobe flash thinking it was the culprit, it was not. I tried disabling all add-ons, the problem still persists. I've used 3 different kinds of virus scanners thinking it was a virus, they didn't detect any virus. I'm very stumped and would appreciate any advice for a solution to this problem.
      My Computer


  2. Posts : 5,605
    Originally Win 7 Hm Prem x64 Ver 6.1.7600 Build 7601-SP1 | Upgraded to Windows 10 December 14, 2019
       #2

    Do you use feeds or slices?
    Go to Tools >IE Options >Bottom of Content Tab >Click on Settings >Remove check mark, if checked at Automatically check feeds or slices. Then test.

    Also go to Control Panel\All Control Panel Items\Programs and Features\ Turn Windows Features on or off in left pane. Let it populate and check if any Internet Information Services are selected or anything you think would do a call to the internet, then unselect them, and test.

    These first two need a process running in order to call out on intervals to check on what they were set to check for. Ergo, the process you're seeing in task manager.

    There is a possible hotfix, but I hesitate to mention it because you need to:
    analyze the call stack of the process when this issue occurs, you notice that a thread is blocked in the ntdll!NtReleaseKeyedEvent() function.

    Source: https://support.microsoft.com/en-us/kb/2582203/en-us
    For that you would need a utility like Process Explorer or PsTools.
      My Computer


  3. Posts : 21
    Windows 7 Home Premium 64-bit SP1
    Thread Starter
       #3

    Possibly solved: I believe I narrowed the cause of the problem to McAfee. After switching anti virus software, I found that the problem went away, however if it comes back, I'll check back to this thread and work from there. Thanks for the help though.
      My Computer


  4. Posts : 5,605
    Originally Win 7 Hm Prem x64 Ver 6.1.7600 Build 7601-SP1 | Upgraded to Windows 10 December 14, 2019
       #4

    That's great to hear Kerf!
    You're welcome, McAfee might have something running that it needs IE to call out periodically to update definitions.

    Give it a few days, a week, to make sure everything is working okay and if it is, you can come back and finalize your thread by marking it solved. If you're sure now you can do it now, if something does go awry later on you can always re-mark it Unsolved.

    Its the green button next to the orange Post Reply button that only you can see because it is your thread.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:49.
Find Us