Websites not loading in IE9, but work in Firefox or Chrome.

Page 1 of 2 12 LastLast

  1. Posts : 5
    Windows 7 Professional 64bit
       #1

    Websites not loading in IE9, but work in Firefox or Chrome.


    Hi,

    I'm Phil. I've worked in IT for a few years now, and the following is one of the most confusing problems I've had to deal with.

    At our organization, we run a network split over 8 sites. We have approximately 400~ computers. Our kit is of mixed quality - we have some solid computers, but our backend is still Windows Server 2008 R2 (we have one server at each site, linked via an internal network, and access to the Internet is routed through a proxy which handles filtering). Users login and receive settings via Group Policy.

    Anyway - the actual issue we're having is that some of our machines with Internet Explorer 9 installed can only access a limited pool of websites (e.g., bbc, amazon, microsoft). Most websites do not work ("Internet explorer cannot display the webpage"), and it doesn't seem like the machine is even trying to connect to anything - it just goes to that screen in maybe 0.5 seconds.

    Has anyone run into anything similar / does anyone have any ideas as to what could be causing this?

    Cheers,

    Phil

    P.S -


    - Notes:

    • The machines can access the internet via Firefox or Chrome.
    • We're unsure exactly when this began to pop up, but we think it was approx. April 15th~.
    • It's nothing to do with our proxy, Firefox/Chrome pick the settings up from the same place as IE and they work.
    • System time is synced across all machines.
    • There's no immediately noticeable similarities between broken machines in Active Directory - we have two users in the same container and one has a broken laptop and one does not, etc.
    • Upgrading to IE11 does fix the issue - IE11 works. But it's important that we have IE9 on some of our machines for reasons that are outside of my sphere of influence.



    - Things we've tried:

    • Flushing dns
    • Resetting winsock
    • Resetting tcp/ip stack in winsock
    • Checked Hosts file (it's all normal)


    • Resetting advanced settings in IE
    • Resetting normal/all settings in IE
    • Deleting Browser Cache in IE
    • Checked Sites in IE (everything seems normal, like settings are on default and there no websites in any trusted/untrusted lists), and reset all IE Zones to default level.
    • Removed all addons from IE
    • Cleared SSL state from IE certificates


    • Disabling all non-microsoft services
    • Disabling antivirus (Sophos)


    • Disabling proxy settings on and running a machine from a totally unrelated internet connection that does not go through a proxy (same result re: only some web pages work in IE, Firefox/Chrome work fine).
    • Trying to get into sites via direct IP address (in case of a DNS issue) - no luck.


    • Going through registry deleting any settings pushed out via Group Policy on the offchance there's some conflict somewhere. This is like... the thing I'm most unsure about. I think there's maybe something, somewhere that I haven't picked up on.
    Last edited by Philip Addis; 07 May 2015 at 09:01.
      My Computer


  2. Posts : 20,583
    Win-7-Pro64bit 7-H-Prem-64bit
       #2

    Hi and welcome to SevenForums,
    One thing you might try is go to internet options/ advanced and uncheck all of the ssl boxes and check all of the tls boxes.
    Those are the only differences in 9/ 10 and 11

    If there's a 32 or 64 bit difference in the machines that work and don't it might be a 64 bit that might not
    64 bit has Active x filtering that might be getting activated for some reason = Gear symbol or tools/ Safety see if anything there is checked if so uncheck anything that is,
    Try In-Private browsing and or safe mode with networking to see if either of those have an issue,

    Otherwise I'd also ask here,
    https://social.technet.microsoft.com...tprocurrentver
      My Computer


  3. Posts : 5
    Windows 7 Professional 64bit
    Thread Starter
       #3

    Thanks ThrashZone,

    I tried unchecking SSL boxes & checking TLS boxes with no joy. Nothing is checked in Safety, In-Private browsing is the same way. (All the same error as before).

    BUT, Safe Mode with Networking actually works. So that's great in that it indicates it must be something on the machine/solvable. I'm still very much unsure as to what though.
      My Computer


  4. Posts : 1,049
    Windows 7 Pro 32
       #4

    Try Developer Tools (F12). Click Play on the Network tab and then reload the page. Hopefully you'll see what it tries to load and the HTTP return code.
      My Computer


  5. Posts : 1,049
    Windows 7 Pro 32
       #5

    Also I'd try and uninstall Sophos and not only disable it. The fact that it works in Safe Mode suggests the problem is with a 3rd party program.

    To test IE without add-ons: iexplore.exe -extoff
      My Computer


  6. Posts : 5
    Windows 7 Professional 64bit
    Thread Starter
       #6

    Thanks Tookeri,

    I uninstalled Sophos and tested using IE with no addons - problem is still the same.

    I also checked Windows Firewall settings - it's completely off.

    In Dev Tools -> Play (Network tab), on trying to load Google, I get:

    Items: 1
    Taken: <1ms
    Sent: 0B
    Received: 0B

    In detailed view, the only frames that have anything in are Initiator and Timings - Initiator just has info about res://ieframe.dll/dnserror.htm, and Timings has nothing useful. It's like the machine is not even trying to go out to the internet on requests except for BBC/Amazon/Microsoft.
      My Computer


  7. Posts : 20,583
    Win-7-Pro64bit 7-H-Prem-64bit
       #7

    Hi,
    Well lets try this if you haven't already although no add-ons mode as described earlier works the best,
    Go to the manage add-ons page,
    Where it says Show click the down arrow and choose Run without permissions
    It's a long list but disable all of those too,
    You can also verify in the show all list that all are indeed disabled
    Cheers.
      My Computer


  8. Posts : 1,049
    Windows 7 Pro 32
       #8

    Try the IE programming way of a web request. Save this code in a file ending with .vbs
    Code:
    url = "https://www.google.co.uk"
    localFile = "googleResponse.html"
    
    With CreateObject("MSXML2.XMLHTTP")
      .open "GET", url, False
      .send
      a = .ResponseBody
    End With
    
    With CreateObject("ADODB.Stream")
      .Type = 1 'adTypeBinary
      .Mode = 3 'adModeReadWrite
      .Open
      .Write a
      .SaveToFile localFile, 2 'adSaveCreateOverwrite
      .Close
    End With
    
    MsgBox("Done!")
    Double-click the .vbs file to run it. If no errors pop-up it will only display a message box with the word Done!. Then look in the file googleResponse.html or double-click it to open in the default browser.

    I had to use https or it didn't work. Maybe related to Google using redirects to other pages/domains.
      My Computer


  9. Posts : 5
    Windows 7 Professional 64bit
    Thread Starter
       #9

    Hi again ThrashZone, Tookeri.

    Thanks for all the help so far.

    ThrashZone: I disabled all of the addons individually, and I still get nothing.

    Tookeri: I saved and ran your vbs script, and I do get the google homepage as a response (as source code in the .txt).

    Still confused.

    e: We also went through all settings on a machine that worked, and a machine that didn't work (in advanced etc), and compared them. Some were slightly different, but even after updating to exactly the same settings as a working machine it doesn't work.
      My Computer


  10. Posts : 1,049
    Windows 7 Pro 32
       #10

    Ok, have you tried that exact URL in IE as well? https://www.google.co.uk To rule out any redirect issues you might get when going to google.com

    Have you tried looking at differences between sites that work and sites that don't? Some examples would be nice to see if there's perhaps a pattern. Entire URLs including http/https

    You think the problem started around April 15 and latest MS Patch Tuesday was April 14 which is a little suspicious. Check when these updates were installed. Although it works in Safe Mode it could be worth doing a restore(if possible) prior to that date.

    Also you could try to clear the Font Cache. In CCleaner it's System - Font Cache. That's been known to cause strange problems but I found this specific issue related to IE9 not working but FF and Chrome did:
    Here's another possibility I discovered after three days hard work during which I noted someone had encountered a font problem which caused IE9 (but not FF or Chrome) to fail.
    Using cleanboot (including disabling MS services except those you can't!)) I eventually narrowed the problem down to Windows Font Cache Service which prevented IE9 working on all but one user account.
    If you stop this service and then go to Windows Explorer and navigate to “C:\Windows\ServiceProfiles\LocalService\AppData\Local” (requires admin privileges and hidden files) then Delete the FontCache dat files. (They will be regenerated over time.)
    Reboot and hey presto!

    Seems astonishing that Microsoft seem to be quite oblivious to this glitch which would appear to a common result of malware clearance affecting thousands of their customers.

    Hope this helps someone somewhere to save a few days of their life!
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:51.
Find Us