Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: This page can't be displayed Fix connection

26 May 2015   #1

win 7 premium
This page can't be displayed Fix connection

All of a sudden when I try to access a link on a site that I use all the time, the link is opening a page that says This page can't be displayed and at the bottom it says Fix connection and if I click on it, it says no problems detected. I have tried other browsers such as firefox and chrome, and I get the same message. So far it only does it on the one site. I have tried everything I can thing of to fix it, but nothing as worked.
the site I am trying to access it I can get to the main site, but when I click on the Forms link which is the above link, it comes up This page can't be displayed. I can access the site and the link on my smart phone, but not from my pc. If I switch my anti virus (Avast)to safe mode then it works, but it is a hassle to do that every time, besides I need my pc to work correctly and not to work around things. Any ideas?
I have had other people try the site and it works fine for them

My System SpecsSystem Spec
26 May 2015   #2

Windows 7 Pro x64 Windows 10 Pro x64

Get rid of Avast.

MSE and MBAM are all you need

I get all kinds of login pages if I click on a link, but they all work

Attached Thumbnails
This page can't be displayed Fix connection-capture1.jpg   This page can't be displayed Fix connection-capture2.jpg   This page can't be displayed Fix connection-capture3.jpg   This page can't be displayed Fix connection-capture4.jpg  
Attached Images
This page can't be displayed Fix connection-capture.jpg 
My System SpecsSystem Spec
27 May 2015   #3
Not Myself

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Works correctly with Avast for me, which leads me to suspect some setting in Avast; what that setting might be, sorry, I have no idea whatsoever. I would post your problem on the Avast forum, .
My System SpecsSystem Spec

27 May 2015   #4

Win-7-Pro64bit 7-H-Prem-64bit

Export Favorites to html file before resetting Internet explorer/ just to be safe.
Internet Explorer - Import and Export Favorites

Tutorial of Resetting Internet explorer Please don't forget to Check the box to Delete personal settings,
Internet Explorer - Reset

Manage add-ons this works for all version of ie,
Manage add-ons for Internet Explorer - Windows Help

Turn Internet explorer off and boot when prompted then turn ie back on,
Windows Features - Turn On or Off
My System SpecsSystem Spec

 This page can't be displayed Fix connection

Thread Tools

Similar help and support threads
Thread Forum
This Page Can't Be Displayed
I'm having issues connecting to one website that I've verified is up, but not for me. Windows Network Diagnostics seems to indicates a problem with this website, but not for the internet in general. The windows network diagnostics report:
Network & Sharing
IE 11 'This page can't be displayed... Turn on TLS 1.0...'
Currently using IE 11.0.18 with settings in Security Tab set to Default and 'Internet Options; Advanced' also using the default settings . Using Windows Firewall and Microsoft Security Essentials. I have not 'messed' with either of them other than keeping everything current. OS is also up to...
Browsers & Mail
this page can't be displayed
thats what it says. I can update the computer. and it says its conected to the internet.I bought this laptop to run RC Heli simulator. I would be nice to go online. I have a Mac I use for most things
Browsers & Mail
GOOGLE Search page always displayed on Firefox new page (+) openings
Using Mozilla Firefox. I have set Home Page as blank, so the initial screen is blank. When the + to open a new tab is clicked the page is always displayed as a FIREFOX START page displaying a GOOGLE Search in the middle of it. (happens on at least v-24.0 thru 26.0 beta) ...
Browsers & Mail
Page cannot be displayed
before i start off let me give u my specs Microsoft Windows Copyright (c) 2009 Microsoft Corporation. All rights reserved. C:\Users\tevin mcknight>ipconfig Windows IP Configuration
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App