Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet Explorer 11 gone missing

10 Aug 2015   #1
SingularityRS

Windows 7 Home Premium 64-bit SP1
 
 
Internet Explorer 11 gone missing

Hey,

Lately the "Get windows 10" app hasn't been working correctly - it would open for like 1 second and then instantly close (it says please wait.. then closes). I did some research and found that this may be happening because IE11 isn't installed/is not available.

So, I did some checking and found that IE had vanished from my system (so it appears). After more researching, I was led to the "Turn windows features on or off" utility where I should be allowed to enable/disable windows features, such as Internet Explorer, and this is where the problem lies.

I see "Internet Explorer 11" appear in Windows features (it's unchecked obviously) and find that for some reason, I'm unable to enable it. If I check the box, it will just disable itself (unchecked box) upon clicking ok. Even a reboot will not help. It's like something is stopping it from re-enabling and I don't know what.

I remember having IE before and it worked fine, I've no idea why it suddenly decided to disable itself. The "Get windows 10" program originally worked fine too. One day it just stopped opening properly and IE11 being disabled is probably why this is, so I'm determined to get IE11 up and running on my system.

Things I've tried:

Reinstalling IE 11 via offline/online installer - Returns "Internet explorer did not finish installing error".
Uninstalling the Windows update itself and then attempting to reinstall - this returns a 9C59 error. The offline installer returns the same error (did not finish installing)
Running sfc/ scannow - it found some corrupt files and said it fixed them
Ran System update readiness tool - According to the logs, it managed to fix some things but not all.

I actually did manage to install IE11 eventually after all this troubleshooting; however, upon restarting windows encountered DLL errors (relating to advapi32) instead, which prevented some programs (such as IE) from running. I had to do a system restore to return my system to a point where it had IE11 appear in Windows features.

Not sure what's up really.


My System SpecsSystem Spec
.
10 Aug 2015   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello and welcome SingularityRS mate as I understand it the IE11 will only go "across" if one upgrades 7 to 10 as the 10 has that new browser. I stand to be corrected of course but that is what happened on one of my desktops at my place.

It maybe worth a run of this in safe mode just to see if the system can be got back.

https://www.sevenforums.com/tutorials/433-disk-check.html< if necessary include the /f and /r in the command line as per Option2
My System SpecsSystem Spec
Reply

 Internet Explorer 11 gone missing




Thread Tools




Similar help and support threads
Thread Forum
Internet explorer missing favorite titles but not favorites themselves
Ok so this is really weird what happened here. I dunno how but a few of my IE favorites have somehow lost their names when you view them from the favorites tab in IE. Opening the folder shows it still has their names but they themselves don't. Clicking on them also still works, an example is here....
Browsers & Mail
Inprivate Filter Settings are missing in Internet Explorer 11
I am attempting to personalize my InPrivate filter settings. However, when I click 'Safety' on the command bar, there is no longer an "InPrivate Filter Settings" in the drop down list. All it has is "InPrivate Browsing." In my former IE there was an "InPrivate Filter Setting." That would...
Browsers & Mail
Internet Explorer 9 not opening/inetcpl.cpl missing
Internet Explorer 9 not opening. It takes about 10-30 mins for an error to finally show up with something along the lines of "Internet Explorer could not open.... missing file inetcpl.cpl I searched for solutions, tried deleting the 2 updates that caused the error and such, still no hope. Before...
Browsers & Mail
missing internet explorer 6
I installed the trial version of AVG after that my internet explorer6+ disappeared I reverted back to the free AVG but still no internet explorer when I try to downlaod it im told its already running there is nothing on add/removewould appreciate any advice iv tried system restore but that dosnt...
Browsers & Mail
Internet Explorer Task jumplist missing
Hey on my other computer if I right click internet explorer it usually comes up with tasks like "start in private browsing" or "new tab" just installed a new windows 7 on my computer and when i right click internet explorer it has only unpin and run when I right click it, no tasks? How do I...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App