Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Firefox won't play twitter videos

15 Mar 2016   #11

Windows 7 Home Premium x64

I'm positive it's not a virus because I can run every other executable I can find

My System SpecsSystem Spec
16 Mar 2016   #12

Linux (Mint is primary) / XP, Win7 Home / Win7 Pro, Ultimate / Win8.1 / Win10 archived VM

Problem is with mommy Mozilla trying to protect you. If you visit MozillaZine you'll find others with the same issue. Version 45 will help but you must load the latest version of Flash or FF will block it. There are ways around this but I'm not ready to go there on this forum.

My System SpecsSystem Spec
16 Mar 2016   #13

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Quote   Quote: Originally Posted by randomwin7user View Post
C:\Documents and Settings\User\Desktop\autodetectutility.exe is not a valid Win32 application
I think that you get that sort of error when there's a problem with MS Visual C++ (version or security update missing) or corrupt version that needs removal and then reinstalling.
Firefox won't play twitter videos-ms-visual-c-.jpg

Quote   Quote: Originally Posted by FerchogtX View Post
Are you using an Administrator account (I mean, any account that is an administrator, not the admin account itself)? Looks like a Basic account limitation...
To help out FerchogtX run netplwiz and post a screenshot of the results.
Firefox won't play twitter videos-netplwiz.jpg

My System SpecsSystem Spec

19 Mar 2016   #14

Windows 7 Home Premium x64

Firefox won't play twitter videos-user.jpg

My System SpecsSystem Spec
19 Mar 2016   #15

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Thanks for the screenshot.

I can replicate the problem using Cyberfox (Firefox 64bit variant).

1) Tested Twitter video playback in Cyberfox and it worked fine.

2) Modified preference
and set it's value to false

3) Restarted Cyberfox (Firefox) and get the following error:
Firefox won't play twitter videos-twitter-video-cyberfox.jpg
If I undo the change then Twitter videos will play.

So to test - launch firefox and in the address bar type:


Accept the warning. In the search box type:

Set it's value to true by double clicking.
Firefox won't play twitter videos-twitter-video-cyberfox-2.jpg
Exit Firefox and launch it again. Try playing a Twitter video.

Of course this will not help if that preference is already set to true

My System SpecsSystem Spec
19 Mar 2016   #16

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

In addition you might want to check that the following preference is also set to true
Firefox won't play twitter videos-twitter-video-cyberfox-3.jpg

My System SpecsSystem Spec
19 Mar 2016   #17

Microsoft Windows 7 Home Premium SP1 64-bit Build 7600 / Microsoft Windows XP Professional SP3

Quote   Quote: Originally Posted by Callender View Post
I'm impressed you find out the problem, the trobleshoot page didn't exhibit this particular issue... I wonder why since it's supposed this settings are set to true by default, and if set to false, it's non defaut, thus has to be shown on about:support... (that just means I'm so dumb XD)

Anyway, I'm certain this will fix his problems with video playback. Thanks for this
My System SpecsSystem Spec
20 Mar 2016   #18

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Quote   Quote: Originally Posted by FerchogtX View Post
I wonder why since it's supposed this settings are set to true by default, and if set to false, it's non defaut, thus has to be shown on about:support.
It should show up in profile info (about:support) and looking at the list of modified preferences that were already posted - it doesn't show up so I guess that it's not the problem!

Anyway if it's any help Twitter video works for me and here's my list:

Application Basics

Name: Cyberfox
Version: 45.0.2
Build ID: 20160316131255
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0 Cyberfox/45.0.2
Multiprocess Windows: 0/1 (default: false)
Safe Mode: false


Name: CanvasBlocker
Version: 0.3.0-Release
Enabled: true

Name: Certificate Patrol
Enabled: true
ID: CertPatrol@PSYC.EU

Name: Click to Play per-element
Version: 0.3.3
Enabled: true

Name: Click&Clean
Version: 4.1.1-signed
Enabled: true

Name: CyberCTR
Version: 1.5.1
Enabled: true

Name: Disconnect
Enabled: true

Name: eCleaner
Version: 1.4.1-signed.1-let-fixed
Enabled: true
ID: {c72c0c73-4eb0-4fb3-af0f-074e97326cfd}

Name: Empty Cache Button
Version: 2.7.1-signed
Enabled: true
ID: {4cc4a13b-94a6-7568-370d-5f9de54a9c7f}

Name: Extension Defender
Enabled: true
ID: {281944CE-E7F4-4A43-A5D0-EAC0B3E71BFF}

Name: Foundstone HTML5 Local Storage Explorer
Version: 1.1.1-signed
Enabled: true

Name: friGate - unlock sites
Version: 2.2.1
Enabled: true

Name: HTTPS-Everywhere
Version: 5.1.4
Enabled: true

Name: Metascan Online Firefox Plugin
Version: 0.2
Enabled: true

Name: Preferences Monitor
Enabled: true
ID: {517f9e52-c795-4764-bf77-5e2db596cee6}

Name: Redirect Cleaner
Version: 2.4.0
Enabled: true

Name: Resurrect Pages
Version: 3
Enabled: true
ID: {0c8fbd76-bdeb-4c52-9b24-d587ce7b9dc3}

Name: Secret Agent
Version: 1.32
Enabled: true

Name: Self-Destructing Cookies
Version: 0.4.9
Enabled: true
ID: jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack

Name: SSleuth
Version: 0.4.5
Enabled: true
ID: ssleuth@github

Name: Toggle JavaScript
Version: 0.8
Enabled: true
ID: jid1-KYgT07tufVQH4w@jetpack

Name: TrafficLight
Enabled: true

Name: WOT
Version: 20151208
Enabled: true
ID: {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}

Name: Calomel SSL Validation
Version: 0.79
Enabled: false

Name: Lightbeam
Enabled: false
ID: jid1-F9UJ2thwoAm5gQ@jetpack

Name: Nimbus Screen Capture - editable screenshots.
Version: 8.2.1
Enabled: false

Name: uMatrix
Enabled: false


Adapter Description: AMD Radeon HD 6290 Graphics
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 384
Asynchronous Pan/Zoom: none
ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
Device ID: 0x9807
Direct2D Enabled: Blocked for your graphics card because of unresolved driver issues.
DirectWrite Enabled: false (6.2.9200.17568)
Driver Date: 12-6-2013
Driver Version:
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 14b71043
Supports Hardware H264 Decoding: Yes
Vendor ID: 0x1002
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Important Modified Preferences

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 0
browser.cache.disk.enable: false
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.enabled: false
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 4
browser.cache.memory.capacity: -1 2 true
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20151015111139
browser.startup.homepage_override.buildID: 20151015111139
browser.startup.homepage_override.mstone: ignore
browser.urlbar.autocomplete.enabled: false
browser.urlbar.suggest.bookmark: false
browser.urlbar.suggest.history: false
browser.urlbar.suggest.openpage: false
dom.apps.reset-permissions: true
dom.ipc.plugins.flash.subprocess.crashreporter.enabled: false
dom.ipc.plugins.reportCrashURL: false
dom.min_background_timeout_value: 100000
dom.mozApps.used: true
extensions.lastAppVersion: 45.0.2
font.default.x-western: sans-serif
font.internaluseonly.changed: true Arial
general.autoScroll: false
gfx.blacklist.direct2d: 4
gfx.blacklist.layers.direct3d9: 4
gfx.crash-guard.d3d11layers.appVersion: 45.0.2
gfx.crash-guard.d3d11layers.deviceID: 0x9807
gfx.crash-guard.d3d11layers.feature-d2d: false
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d9video: 2
gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 41.0.3
gfx.driver-init.deviceID: 0x9807
gfx.driver-init.feature-d2d: false
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
media.gmp-gmpopenh264.lastUpdate: 1454471380
media.gmp-gmpopenh264.version: 1.5.3
media.gmp-manager.buildID: 20160316131255
media.gmp-manager.lastCheck: 1458461303
media.hardware-video-decoding.failed: false
network.allow-experiments: false
network.cookie.cookieBehavior: 1
network.cookie.lifetimePolicy: 2
network.cookie.prefsMigrated: true
network.http.sendRefererHeader: 0
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1439154381
places.history.enabled: false
places.history.expiration.transient_current_max_pages: 96852
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.flash: 1
privacy.cpd.extensions-certpatrol: false
privacy.cpd.offlineApps: true
privacy.cpd.siteSettings: true
privacy.donottrackheader.enabled: true
privacy.donottrackheader.value: 1
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.sanitizeOnShutdown: true
privacy.sanitize.timeSpan: 0
security.disable_button.openCertManager: false
security.disable_button.openDeviceManager: false
security.ssl.treat_unsafe_negotiation_as_broken: true
security.ssl3.dhe_dss_aes_256_sha: true
security.ssl3.dhe_rsa_des_ede3_sha: true
security.ssl3.ecdhe_ecdsa_rc4_128_sha: false
security.ssl3.ecdhe_rsa_des_ede3_sha: true
security.ssl3.ecdhe_rsa_rc4_128_sha: false
security.ssl3.rsa_rc4_128_md5: false
security.ssl3.rsa_rc4_128_sha: false
security.tls.insecure_fallback_hosts.use_static_list: false
security.tls.unrestricted_rc4_fallback: false
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1439154381
webgl.disabled: true

user.js Preferences

Your profile folder contains a user.js file, which includes preferences that were not created by Cyberfox.

Important Locked Preferences


Incremental GC: true


Activated: false
Prevent Accessibility: 0

Library Versions

Expected minimum version: 4.12
Version in use: 4.12

Expected minimum version: 3.21.1 Basic ECC
Version in use: 3.21.1 Basic ECC

Expected minimum version: 3.21.1 Basic ECC
Version in use: 3.21.1 Basic ECC

Expected minimum version: 3.21.1 Basic ECC
Version in use: 3.21.1 Basic ECC

Expected minimum version: 3.21.1
Version in use: 3.21.1

Experimental Features
My System SpecsSystem Spec
20 Mar 2016   #19

Linux (Mint is primary) / XP, Win7 Home / Win7 Pro, Ultimate / Win8.1 / Win10 archived VM

I'm glad Callender and I were able to help! Be sure to mark the thread as SOLVED if it is indeed fixed (to help others searching the forum).

My System SpecsSystem Spec
23 Mar 2016   #20

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

@ randomwin7user

Did you delete your last post?

Anyway you seem to have stated that those preferences do not exist. They should.


Backup bookmarks, extensions and additionally make a backup copy of your Firefox Profile and file but keep them stored away from your AppData directory.

Fully remove Firefox (add/ remove programs will not fully remove it) and reboot. Install a fresh copy and restore your bookmarks and extensions then test.

Another test you can do:

To rule out any problem with codecs or missing windows updates download a copy of Cyberfox Portable. It uses it's own separate profile and doesn't share it with Firfox unlike some other firefox variants.

See if you can play twitter videos with that.

Cyberfox 64bit Intel Optimized version (no java plugin)

Cyberfox 32bit Intel Optimized version:

Take your pick and download the Portable Zipped Archive. Extract the files and run the browser. Test twitter video. Also check the preferences mentioned earlier.

RE: Firefox.

It can screw up sometimes if you just keep applying available updates instead of clean installing it from time to time especially after the release of a version that has major upgrades.
My System SpecsSystem Spec

 Firefox won't play twitter videos

Thread Tools

Similar help and support threads
Thread Forum
IE 11 Will Not Play Some Twitter Videos
My IE 11 will not play some videos in Twitter, but they will play in both Chrome and FireFox. This is the same on two different desktops, and I've updated any extensions/add-ons (like flash) that I've been able to find. Any thoughts on how to fix IE, which is my main browser (and which I'd...
Browsers & Mail
Why can't I view videos ( Vine ) on Twitter ?
Browser is IE 11 . All I get is a black screen with the message in Japanese " Not able to play the media. " Can anybody help ?
Browsers & Mail
Can't get Youtube Videos to play on firefox
My wife is having problems getting Youtube videos to play properly on her Desktop PC, she uses Firefox 30.0 browser. The video player screen just shows a black screen with a wheel thing just going round and round, you could leave this for hours and it would still be the same. The strange thing...
Browsers & Mail
unable to play any videos in firefox
i dont know why but all of a sudden i cant play any videos in firefox, if i try at you tube it say's that a problem has occured please try later, i think this problem started when i had a flashplayer update and if i use IE it works fine i have tried uninstalling flashplayer and firefox and...
Browsers & Mail
Can't seems to play videos from YouTube in Firefox.
Hello guys, sorry for the trouble again but this time, I am having trouble with Firefox again. So recently, my Firefox can't seems to play or load any videos from YouTube BUT I am able to play and load videos on other sites like, - Live! Your Game, etc. (Haven't really try the rest...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:57.
Twitter Facebook Google+