Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Browser not working but internet is connected

19 Jun 2012   #11

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1


I had similar problems on two of the computers on my home network. First of all, about 10 days ago my wife told me her Internet Explorer was not loading - "The little round thingy is going round and round", were her exact words. So it was, and did so for some time until eventually the 'Diagnose Connection Problems' screen appeared. I tried all of the above and much more. In the end I shelved the laptop - an Acer Aspire 5536 running Win 7 Pro - to look into the problem later and in the meanwhile let her use one of my 'University' laptops: An F-S Amilo Li 2735 which works perfectly.

I would have left it at that until I had time to look more thoroughly at the problem - perhaps this coming Sunday - had it not been for the fact that exactly the same thing happened to my main desktop PC yesterday. The PC is an Acer Aspire M3802, also running Win 7 Pro (but 64 bit, not 32). All the installed browsers stopped working: that is IE 8, 32 & 64 bit and Firefox. Also, WLM would not load, despite an excellent Internet connection.

Because I use this machine to update my websites every day it was essential I solve the problem so I set to checking all the forums I am a member of, running AV software and so on. In the end, I solved the problem completely by accident.

I do not like using the System Restore option, but sometimes there is little choice and that is what I did. When finished I had an on screen message telling me it had not worked because a certain file could not be accessed and I was advised to temporarily disable my AV software and run System Restore again. I disabled my Kaspersky 2012 Security and tried again - same result.

I was by then getting desperate, so I popped in my o/s disk and tried the repair option; no luck there either and as a final attempt to fix things things I tried System Restore again but launched from my o/s disk menu this time. It failed again BUT this time the error message was more specific; instead of just telling me it could not access a file being used by my AV software it named the file. Of course, I cannot remember the exact file but I do recall it was in my SuperAntiSpyware Pro folder.

I rebooted, un-installed SAS Pro and Bingo!! Problem solved.

The other important factor, I submit, is that both machines stopped accessing the Internet because they were both running SAS Pro AND the problem occurred shortly after Java was updated to JRE 7 u4 and JFX 2.1.0. was installed at the same time. I have informed SAS and await a reply. I am also keeping a keen eye on the other machines here at home, as and when they get the Java and Windows updates.

I hope this will be of help.

My System SpecsSystem Spec
17 Jan 2013   #12

Win 7 Ultimate SP1 64 bit

I am having the same problem but none of the above has worked yet for me. This seems crazy
  • Firefox, IE 64 bit and IE 32 bit do not work
  • Yet I can get my email from my cable company
  • I can also run Utorrent and other programs that use the internet
  • Cable tech support got me to ping Google successfully using CMD
  • Browser does work in safe mode
  • I cannot access my Synology NAS (server) in Win 7 but I can in Safe Mode
  • Cable companies Fsecure will not run a virus scan but it will update
  • It seems like many system restore pints are gone. There is only one from today and one from yesterday
I am at my wits end and don't know what to do next. I have made a lot of changes since my last Ghost backup and would hate to go back so far by using it. Any help would be greatly appreciated
My System SpecsSystem Spec
14 Jun 2017   #13

7 Professional x64, 7 Starter

Quote   Quote: Originally Posted by scum1 View Post
I had a very similar problem where only my 64 bit IE worked. My Firefox and IE 32 would not connect. I tried many different things I read here and was about to give up until I tried this and it worked for me.

got to Cmd line

Type netsh winsock reset

Now all my browsers work including Firefox and IE

Perfect, this solved my issues, thanks!
My System SpecsSystem Spec


 Browser not working but internet is connected

Thread Tools

Similar help and support threads
Thread Forum
Internet connected but browser and email not working
Dear Forum: I hope I'm posting this in the right forum :). I've been having this problem for a couple of weeks now (Internet connected but browser and email not working) with apparently increasing frequency :(. After some 'Startpaging' (i.e. Googling) I found this, which has...
Browsers & Mail
Says connected to internet, but cant open browser
Hi all, for the last few days i have been having the problem of not being able to connect to the internet. only my desktop is having a problem so that eliminates the router. whether through wireless or wired, it says that it is connected in the bottom right and under network. but when i open...
Network & Sharing
Connected to internet but browser won't retrieve websites
Running Acer Aspire one, Win 7 starter, IE. While downloading Bittorrent I acquired several nasty programs. The two most insidious are and YouTube accelerator. I have tried normal uninstall but rather then removing these programs they now do not show up on the list of programs, but still...
System Security
Internet connected but not working
Hi, I have my internet connected long storty short, I reset my router last night, it reset to default settings I got the new password, I'm connected on my Windows Vista computer laptop my desktop computer, all working fine, but on my Windows 7 laptop its connected I can go to google, and windows...
Network & Sharing
Connected to Internet - Browser does not work
Hey guys, so I have this problem: My Desktop is connected to my router vie WiFi and it says I have connection to the Internet. However, i cannot access any website, be it by typing in the name or the IP adress. At the same time, I can ping all websites. I can find them via tracert, which also...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App