Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet Explorer 11 Install Fails 'cos Neutral package install failed

06 May 2019   #11
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, & Kali
 
 

Hi Rincewindwiz,
Need to see some logs, please run
SURT64
when it completes, please run
CBS Folder to Desktop.bat
You can remove the .cab folders from CBS folder on the Desktop, zip it & upload.




My System SpecsSystem Spec
.
07 May 2019   #12
wither 2

Windows 7 Pro SP1 64 bit
 
 

I don't know if they've resolved this but have you run the check for updates since you uninstalled it?
My System SpecsSystem Spec
13 May 2019   #13
Rincewindwiz

64 bit Win 7 Ultimate
 
 

Quote   Quote: Originally Posted by Snick View Post
Hi Rincewindwiz,
Need to see some logs, please run
SURT64
when it completes, please run
Attachment 408170
You can remove the .cab folders from CBS folder on the Desktop, zip it & upload.

Attached

Also please note strange SFC results below
SFC /Scannow reports errors and says its fixed them
An imediate rerun report Windows Resource Protection found corrupt files but was unable to fix them
THe log (CBS6) shows them to be to do with KB4489878 (see above) Typical errors are
2019-05-12 22:48:01, Error CBS Failed to internally open package. [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:48:09, Info CBS Session: 30738700_1668946300 initialized by client Software Explorer.
2019-05-12 22:48:09, Info CBS Session: 30738700_1671966473 initialized by client Software Explorer.
2019-05-12 22:48:15, Info CBS WinVerifyTrust failed [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:48:15, Error CBS Failed to verify if catalog file \\?\C:\Windows\Servicing\Packages\Package_676_for_KB4489878~31bf3856ad364e35~amd64~~6.1.1.9.cat is valid. [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]

So one more go at SFC \scannow and we are back to 'Found corrupt fies and successfully repaired them' except that the log file has a lot of failures
Mark store corruption flag because of package: Package_676_for_KB4489878~31bf3856ad364e35~amd64~~6.1.1.9. [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:47:00, Info CBS Failed to initialize package: Package_676_for_KB4489878~31bf3856ad364e35~amd64~~6.1.1.9, from path: \\?\C:\Windows\Servicing\Packages\Package_676_for_KB4489878~31bf3856ad364e35~amd64~~6.1.1.9.mum, existing package: 1 [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:47:00, Info CBS Failed to resolve package [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:47:00, Info CBS Failed to populate children. [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:47:00, Info CBS Failed to initialize package: Microsoft-Windows-IIS-WebServer-Package~31bf3856ad364e35~amd64~~6.1.7601.17514, from path: \\?\C:\Windows\Servicing\Packages\Microsoft-Windows-IIS-WebServer-Package~31bf3856ad364e35~amd64~~6.1.7601.17514.mum, existing package: 1 [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:47:00, Info CBS Failed to resolve package [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:47:00, Info CBS Failed to populate children. [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:47:00, Info CBS Failed to initialize internal package [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:47:00, Info CBS Failed to create package. [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:47:00, Error CBS Failed to internally open package. [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:47:06, Info CBS Session: 30738700_1048300801 initialized by client Software Explorer.
2019-05-12 22:47:07, Info CBS Session: 30738700_1051590989 initialized by client Software Explorer.
2019-05-12 22:47:13, Info CBS WinVerifyTrust failed [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:47:13, Error CBS Failed to verify if catalog file \\?\C:\Windows\Servicing\Packages\Package_676_for_KB4489878~31bf3856ad364e35~amd64~~6.1.1.9.cat is valid. [HRESULT = 0x800b0100 - TRUST_E_NOSIGNATURE]
2019-05-12 22:47:13, Info CBS Mark
All to do with KB4489878


Attached Files
File Type: rar CBS.rar (118.4 KB, 2 views)
My System SpecsSystem Spec
.

13 May 2019   #14
Rincewindwiz

64 bit Win 7 Ultimate
 
 

Check for updates Run. 7 To do including KB4493472 (the successor, I think, to KB4489878
All installed successfully


Reboot. Attempt reinstall of IE11 Fails as usual
03:15.984: INFO: Setup exit code: 0x00009C59 (40025) - The neutral cab failed to install.
03:15.984: WARNING: Checking version for C:\Program Files (x86)\Internet Explorer\iexplore.exe. The file does not exist.
03:16.015: INFO: Scheduling upload to IE SQM server: http://sqm.microsoft.com/sqm/ie/sqmserver.dll
03:21.116: ERROR: SQM Upload failed while uploading "C:\Users\Rincewind\AppData\Local\Microsoft\Windows\Temporary Internet Files\SQM\iesqmdata_setup0.sqm" with error: 2147500036



SQM Upload failed for setup0 - setup9.sqm
My System SpecsSystem Spec
13 May 2019   #15
wither 2

Windows 7 Pro SP1 64 bit
 
 

My System SpecsSystem Spec
13 May 2019   #16
Rincewindwiz

64 bit Win 7 Ultimate
 
 

Thanks for the thought but nope. The standalone install of neutral.cab failed with the same error code.
My System SpecsSystem Spec
14 May 2019   #17
wither 2

Windows 7 Pro SP1 64 bit
 
 

Go to Control Panel and select Windows Update. Set it to never check for updates. Reboot.

Download the appropriate file from here-

https://support.microsoft.com/en-us/...line-installer

Right click on it and select Run as administrator.

Does that help?
My System SpecsSystem Spec
14 May 2019   #18
Rincewindwiz

64 bit Win 7 Ultimate
 
 

Windows update switched off normally. I check once per month
All prerequisites are installed. (Ive been through them one by one and each time aI ry to install one I get KBwhateveritis is already installed
Sadly I think it a deeper issue than that. I cant even to an upgrade install.
My System SpecsSystem Spec
14 May 2019   #19
wither 2

Windows 7 Pro SP1 64 bit
 
 

Did you do what I suggested? Not sure you would be getting any messages about updates when Windows Update is disabled.

I wonder if it would work if you tried the installation in Safe Mode (no networking).
My System SpecsSystem Spec
15 May 2019   #20
Rincewindwiz

64 bit Win 7 Ultimate
 
 

THe first thing the stand alone installer does is look for updates. Actually, I think its looking for the Windows UPdate prerequisites.

If I try insalling with no internet connection the installer simply refuses to do anything useful!. It reports "Explorer needs an update before installing! Go online, install the update and then run setup again" There is a 'Get Update' link which takes me to the Prerequisites for IE 11 page https://support.microsoft.com/en-us/...et-explorer-11)
If it is connected to the internet, the delay before continuing is very short

The IE11-main .log reports that it is trying to install KB2834140 (Version check for the other KB updates comes back true)
When I download and try to install this update I am told KB2834140 s ready installed on this computer and 2834140 is visible in the list of windows updates installed
So just for the hell of it I uninstalled the update, restarted the computer reinstalled the update and tried to install IE11


Once more it paused trying to 'Install Required UPdates'
This time it is sulking about KB2729094 (which last time it said was OK) and "Installed Updates" reports KB2729094 is installed
The relevant section of IE11-Main.log is
00:23.369: INFO: Service pack name: Service Pack 1
00:23.369: INFO: Version Check for (KB2834140) of C:\Windows\System32\d3d11.dll: 6.2.9200.16570 >= 6.2.9200.16570 (True)
00:23.384: INFO: Version Check for (KB2670838) of C:\Windows\System32\api-ms-win-downlevel-user32-l1-1-0.dll: 6.2.9200.16492 >= 6.2.9200.16426 (True)
00:23.384: INFO: Version Check for (KB2639308) of C:\Windows\System32\Ntoskrnl.exe: 6.1.7601.24408 >= 6.1.7601.21863 (True)
00:23.400: INFO: Version Check for (KB2533623) of C:\Windows\System32\api-ms-win-security-base-l1-1-0.dll: 6.1.7601.24408 >= 6.1.7601.21728 (True)
00:23.400: INFO: Version Check for (KB2731771) of C:\Windows\System32\conhost.exe: 6.1.7601.24408 >= 6.1.7601.22045 (True)
00:23.400: INFO: Checking for correct version of C:\Windows\Fonts\segoeui.ttf.
00:23.400: INFO: Version Check for (KB2786081) of C:\Windows\System32\taskhost.exe: 6.1.7601.18010 >= 6.1.7601.18010 (True)
00:23.415: INFO: Version Check for (KB2888049) of C:\Windows\System32\drivers\tcpip.sys: 6.1.7601.24233 >= 6.1.7601.22444 (True)
00:23.415: INFO: Version Check for (KB2882822) of C:\Windows\System32\tdh.dll: 6.1.7601.18939 >= 6.1.7601.18247 (True)
00:29.858: INFO: Download for KB2729094 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=258385 -> KB2729094_amd64.MSU.
00:29.858: INFO: Waiting for 1 prerequisite downloads.
00:51.308: INFO: Prerequisite download processes have completed. Starting Installation of 1 prerequisites.
00:51.308: ERROR: Error downloading prerequisite file (KB2729094): 0x800c0005 (2148270085)

NOTE There is no mention of a version check so presumably this is not reported if the version check fails? Sloppy.

An attempt to install results in This update is already installed on your computer

So uninstall and reinstall I suppose. And I guess keep going until I have done all of them. What fun!!
THe updates reported as checked by the installer are
KB2834140 reinstalled
KB2670838
KB2639308
KB2533623
KB2731771
KB2786081
KB2888049
KB2882822

Sadly KB2729094 reports an error when trying to uninstall.
So attempt the IE install again to see what the log says about KB2729094

This time the log says
00:29.858: INFO: Download for KB2729094 initiated. Downloading http://go.microsoft.com/fwlink/?LinkID=258385 -> KB2729094_amd64.MSU.
00:29.858: INFO: Waiting for 1 prerequisite downloads.
00:51.308: INFO: Prerequisite download processes have completed. Starting Installation of 1 prerequisites.
00:51.308: ERROR: Error downloading prerequisite file (KB2729094): 0x800c0005 (2148270085)
00:51.402: INFO: PauseOrResumeAUThread: Successfully resumed Automatic Updates.
So it looks like the install of the KB failed (Reasonable since it is already installed)


https://rakhesh.com/windows/ie-11-up...isite-updates/
suggests you can kid it my downloading, the file (the link isin the log) and moving it to the IExxxx.tmp directory
The IE.temp directory is created as soon as the installer starts but putting the file in at that stage does not seem to work. (Message is still failed to download - but then I suspect this is a confusing message)

Confirmed by watching the install directory carefully where it is clear that download is successful and the file (KB2729094_amd64.MSU) is present. An attempt to install it at this stage results in KB already installed.

For the record I am unable to uninstall KB2729094 in safe more
I am unable to install IE11 in safe mode (wants the KB update which then fails presumably because it is already installed)
My System SpecsSystem Spec
Reply

 Internet Explorer 11 Install Fails 'cos Neutral package install failed




Thread Tools




Similar help and support threads
Thread Forum
Neutral package installation failed (exit code = 0x00003715 (14101))
I am thoroughly fed up with this. Some 3 weeks ago, ie11 stopped working - it would not load I have tried reinstalling, deleting and reinstalling several times. Everytime I get the message saying the install did not complete The IE11.main file says Neutral package installation failed (exit...
Installation & Setup
Windows Update failed to install Internet Explorer 10 - Code 9C59
I'm running Windows 7 x86_64 architecture, and I am trying to install Internet Explorer 10 via the Windows Update service (currently I have Internet Explorer 8 installed). This update is continually failing with a 9C59 error (screenshot attached). I have tried to update to Internet Explorer 10...
Windows Updates & Activation
Internet gets slow after windows updates failed to install
So, today I downloaded and installed some windows updates which I think important. but, because of my internet connection was using USB modem, it seems that some of the updates failed to download and I stopped it. and then I installed the rest which successfully downloaded and logged back in....
Windows Updates & Activation
How to install Language Package
I have an English version of windows home premium, and want to intall a dutch language package, but when I go to "control panel" and "clock, language and region" I can't find the place to install the language packages. It is supposed to be below "keyboard and other input methods" but it is empty...
Installation & Setup
Two issues: Upgrade install of W7x86 fails and W7x64 fails to clean install
Clean installing W7 x86 is no problem. But 1) upgrading Vista x86 to W7 x86 fails and automatically rolls back to Vista, and 2) attempt to clean install W7 x64 results in BSOD when rebooting to finalize the process. Any suggestion would be appreciated.
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:31.
Twitter Facebook