Cannot delete .eml files

Page 2 of 5 FirstFirst 1234 ... LastLast

  1. Posts : 27
    Windows 7 Home Premium SP1 64 bit
    Thread Starter

    OK, a few more odiities.
    If I copy / paste the file - I can delete the new one!
    Until I close that folder. When I go back, it will noy delete.
    If I copy the file to another folder by dragging it - I cannot delete the new one.
    If I copy the duplicate back, it will replace the old one.
    I cannot MOVE an .eml file - the option isn't even presented.
    And I cannot RENAME it, no such option presented.
    There is something in the attributes that will not even offer up a delete.

    More wierd - if I save a copy of a test email, as long as Windows Live Mail is open - I can delete it! Oddly, it remains deletable when I close Live Mail.
    It BECOMES undeletable when I close Windows Explorer and reopen it!
    Holy Smokes, Batman - what is going on!
    I also found that if I copy - it won't let me move - out of My Documents to Downloads, it will let me delete that one.
    If I copy or move that one back to My Documents - it is no longer deletable.
    It's something in Windows Explorer - my documents.

    I probably have some option set somewhere.

    I don't have the problem with any other type of file!

    Thanks - as I said, not a killer problem - kind of fascinating.

      My Computer

  2. Posts : 27
    Windows 7 Home Premium SP1 64 bit
    Thread Starter

    I seem to have misposted my last one.
    I'll try again. I think it timed out.
    I discovered that these files are only non deletable if they are in my "LIbraries" - anywhere in my libraries.
    If I copy them elsewhere on the hard drive, to C, or downloads - they are immediately deletable.
    If I copy / paste one to the same directory or folder, it is deletable UNTIL I close Windows Explorer and then return.

    I am NOT making this up!
      My Computer

  3. Posts : 17,545
    Windows 10 Pro x64 EN-GB

    CarlS said:
    I am NOT making this up!

    One of the weirdest issues I've heard!
      My Computer

  4. Posts : 1,020
    Windows 7 Ultimate 64 bit

    Kari said:
    CarlS said:
    I am NOT making this up!

    One of the weirdest issues I've heard!
    I'll second that!

    CarlS - I'm curious about a few things (and broadening our search)

    Security Tab
    * What's in the security tab when your mail client is open?
    * When you go back after you close the mail client, has it changed?
    * Are there any special permissions?

    * Did you try the attrib command? (I'm just curiosu if it was able to change them when they were read only).

    * Are any other files except for your mail files affected?

    * Do you have more than 3 Terabytes of data that is indexed?

    * I'm not aware of any mail settings that make your mail read-only when the app isn't running; but I'll look into it for you.
      My Computer

  5. Posts : 27
    Windows 7 Home Premium SP1 64 bit
    Thread Starter

    Last try.

    Tim, and Kari, you are indefatigable. Thanks.
    After reading this one, if you have no insights - I just might leave it alone.
    I just have to remove properties in order to delete a standalone email in My Documents.
    Could be worse!

    sfc /scannow - says I must be administrator running a console session.
    Frankly, I don't know how to do that.
    I ran system maintenance from the control panel as an administrator - found nothing.

    NO other file type seems to be affected.
    doc txt pdf xsl htm rtf dat jpg gif wmv any quicken file, you name it.

    I do not have 3 terabytes of data indexed. The C drive is only 450 Gig.
    I have not touched indexing, so I assume it is turned on.

    I tried running this string:
    ATTRIB -r -s -H /S /D C:\Users\CarlDesk\My Documents\_aHoldEmails\*.eml
    Response is "Parameter format not correct".
    The run command has c:\Users\CarlDesk> as the default location prompt.

    I save an email to this folder: My Documents\HoldEmails WITH Windows Explorer open there.
    I can delete it, no problem.
    I close Windows Explorer
    I can no longer delete it!
    I delete its attributes through the properties thing.
    I can delete it.
    If I delete properties, and leave it there - and then close / open Explorer - it becomes not deletable again.
    I can delete the folder, with it in it - not a problem!
    I even emptied the trash to be sure.
    I can also MOVE the folder! Which moves the email.
    I cannot MOVE it by itself, only copy.
    If I save it there with Windows Explorer closed, it is NOT deletable when I open it to look.
    I MOVED the folder from My Documents to Public Documents - it is not deletable.
    The folder is deletable, as before.
    I COPY the folder to My Pictures - the file is NOT deletable. The Folder is.
    I MOVE the folder to the C drive - any place - it is normal, deletable.

    This one is Wierdest.
    I open an email. Click on SAVE to file. Find the folder I want: Hold Emails.
    THEN - do not save it, but go to Windows Explorer and open it to look at that folder.
    THEN save it there - it DOES NOT appear in the Windows Explorer!
    If I click away and then back, it appears! And it is NOT deletable.

    If I first OPEN Windows Explorer on that folder, then save an eml to it, I can see it immediately, and delete it. If I have 2 instances of Windows Explorer open, and just close one, the new email remains deletable in the other.

    Close Windows Explorer, close live email.
    Open Windows Explorer to the folder.
    Open live email.
    Open an email - save it to that folder.
    ONLY the new one is deletable.

    The sequencing does not seem to matter. Only the new one is ever deletable.
    I thought I had a sequence where the old ones were rendered deletable, but I can't repeat it.

    I am persuaded that it has something to do with Windows Live Mail.
    When I first brought everything up on Windows 7, I ran Synctoy to establish the backup to my laptop.
    No problem the first run.
    On subsequent runs, it always wanted to overwrite EVERY .eml file.
    I think I had to have opened Live Mail at least once in the interim for this to occur.
    It was as if it reset ALL of the dates modified on all of the .eml files - I don't see how that is possible.
    If I backed up, and did not open Live Mail - they were not overwritten the next time.

    Somehow - that got fixed, and this problem immediately appeared. About a month ago.
    It now makes no difference whether or not Live Mail is running.
    Closing or opening the Windows Explorer seems to trigger the change in the file.

    Thanks again. There must be more urgent problems out there!!!
      My Computer

  6. Posts : 17,545
    Windows 10 Pro x64 EN-GB

    I tried everything you described above. Works fine for me, can not understand the reason for your issue. Try system file scan (sfc /scannow) one more time in elevated command prompt (right click Command Prompt, choose Run as administrator) and typing the command. Sorry about forgetting to mention about elevation.

    Other than that, I have absolutely no clue.

      My Computer

  7. Posts : 1,020
    Windows 7 Ultimate 64 bit

    Hi Carl,

    Also run the attrib command in an elevated prompt
    To get to the elevated prompt.
    1. Click on the START Globe
    2. Type CMD in the search programs and files box
    3. Right click on CMD when it appears and choose 'Run as Administrator'
    4. If it worked correctly, the Command Prompt will open with Administrator in it's Title area.

    I have rewritten the ATTRIB string for your scenario; just paste this in to he elevatged CMD window and press enter.
    ATTRIB -r -s -H /S /D "%userprofile%\Documents\_aHoldEmails\*.eml"

    After you try this, you may as well leave the CMD window open and run 'sfc /scannow'

    Good Luck!
    Attached Thumbnails Attached Thumbnails Cannot delete .eml files-cmd-admin.png  
      My Computer

  8. Posts : 4
    Windows 7 Ultimate

    CarlS said:
    I have discovered that if I open properties on the file, and select "details" and select remove properties and personal information, and then select the "remove the following properties button", and then hit OK, and OK, then I can delete it!
    I have the exact same problem as Carl, but DO NOT have Windows Live Mail installed.

    I use Carl's solution above if I need to delete an .eml file.

    Weird issue this is.
      My Computer

  9. Posts : 27
    Windows 7 Home Premium SP1 64 bit
    Thread Starter

    Indeed. Trust oneself one does not.

    I am NOT making this up.
    I did the scan - nothing found.
    I am learning a lot of things, but no solution.
    The world will not end - but it is a very curious problem.

    Say, Crabtree - I see we are both "junior" members.
    Nobody has referred to me that way in 50 or more years!!
      My Computer

  10. Posts : 1,020
    Windows 7 Ultimate 64 bit

    Yep, this is weird indeed.

    I have one more idea, one that I touched on before but now have an idea to check.
    Open indexing and ensure that the *.eml file location is not being indexed.
    Open your virus software, ensure that the *.eml location is not being scanned.
    See if the problem continues, if this fixes it, try to work out which program causes it. Man this is annoying me... lol.
      My Computer

Page 2 of 5 FirstFirst 1234 ... LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:55.
Find Us