Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Internet explorer 32-bit does not work, but 64bit does

09 Nov 2011   #51

windows 7 home premium 64bit

Thanks for helping me,

Perfectvibes - unfortunately it wont offer me a restore point that goes back further than the day that this problem started.... kinda weird

A Guy - yes thank you, i did use the command prompt correctly and my spelling is also correct but it keeps telling me that the command is not recognized... also weird

im not sure what else to do???
I also RESET my browser but it did nothing

My System SpecsSystem Spec
09 Nov 2011   #52
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

Can you post a screenshot of the exact error message? I'm off until tomorrow night, but someone else will hopefully be along. You might try the System File Checker as well:

SFC /SCANNOW Command - System File Checker

A Guy
My System SpecsSystem Spec
09 Nov 2011   #53

windows 7 home premium 64bit

A Guy,
Sorry im not sure how to do a screen shot but the exact message that it gives me is this....
C:\windows\system32>netsh winsock reset
The following helper DLL cannot be loaded: WSHELPER.DLL.
The following command was not found: winsock reset

ALSO, I've actually already tried the system file checker but it said that everything was good....

Thank you for your time and help
My System SpecsSystem Spec

09 Nov 2011   #54
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

Open an advanced command prompt and type

netsh add helper wshelper.dll

Enter. Then try the netsh winsock reset again.

A Guy
My System SpecsSystem Spec
10 Nov 2011   #55

windows 7 home premium 64bit

A Guy,

I typed in EXACTLY what you said a few times but it never worked.

It said this: The following helper DLL cannot be loaded: WSHELPER.DLL.

and after that, I tried to press reply on this webpage to tell you but my IE 64 bit stopped working and my FireFox stopped working....

Then rite after that, my Laptop crashed and the screen went black with only the HP logo in the center... and if i pressed any key it just made a beep noise so i had to manually turn it off and turn it back on, now my IE 64 bit and FireFox is working again but still not my IE 32 bit....

Maybe i have a virus??? my Kaspersky security expired a little while ago so i was using Commodo security but honestly i have NOT downloaded ANYTHING on this Laptop except for updates and i probably use it about ONCE a MONTH and its only a year old Laptop with Intel I3 CORE.... i cant believe its giving me so many problems

THANKS for helping me
My System SpecsSystem Spec
10 Nov 2011   #56
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

An infection is a distinct possibility, as this problem can often be the result of malware infections. Have you run any scans? If you don't have them already, suggest a few scanners. D/l these free programs and scan:

Malwarebytes : Malwarebytes Anti-Malware PRO removes malware including viruses, spyware, worms and trojans, plus it protects your computer | Remove Malware | Remove Spyware - AntiMalware, AntiSpyware, AntiAdware!

Microsoft Standalone System Sweeper Beta | Microsoft Connect

Also, navigate to C:\windows\SysWOW64 and see if you have the wshelper.dll there. I have Home Premium, and my version is 6.1.7600.16385 . I have zipped it and attached it here. If you do not have the dll at all, download the file, and place it in C:\windows\SysWOW64

It may be necessary to run the netsh add helper wshelper.dll command again (I know, scary :)). If your scans come up clean, and the steps above do not help, I'd think a Repair Install would be your next step:

Repair Install

If you are infected, it can be very difficult to remove certain infections, and a clean install would end up being the ultimate choice. Let's see what you come up with.

Attachment 183169

A Guy
My System SpecsSystem Spec
11 Nov 2011   #57

windows 7 home premium 64bit

A Guy,

First let me say that you are one of the coolest people in the world for putting this much time and effort into helping me and i REALLY appreciate that....

Now, for the BAD news, my Laptop took a HUGE turn for the worst.
I installed AVAST to scan for a virus and it did, and the results found a virus that it called 'rootkit" or something like that (I stupidly did not write it down) then it deleted the virus but told me to do a reboot sweep just to be safe (which would have AVAST run a scan before windows loaded during a reboot) but when it restarted my Laptop, the computer got stuck on the "HP" logo screen with these words in the bottom left, (press esc for startup menu) HOWEVER if i pressed ANY key all it would do is make a BEEP noise and nothing would happen, (FROZEN) so i manually turned it off and back on.....
When i did this, it went to a screen that said, "startup repair" and started running a process that said "attempting repairs" which i cannot stop, and when it finished the process, it said that i need to reboot the computer to finish the fixing process, BUT when it reboots it gets stuck on the HP logo all over again and i have to manually turn off and back on which makes it do the "startup repair" again and reboots and gets stuck again in the logo screen in an INFINITE cycle....

ALSO if i press esc before any of this stuff happens i can go to the startup menu and choose different options like BIOS setup or system recovery for example and there i can choose either a microsoft system restore, or a system recovery, or a minimized image recovery... i tried the microsoft system restore but it keeps failing because of an "unexpected error" and it wont give me any details....

Im thinking of doing a system recovery (even though im sure it will fail too) but if it works it will take it back to a manufacture state and im scared that it might erase my WINDOWS 7? because my Laptop came with it installed so i dont have a disc to re-install it....

Any advice would be great, im feeling pretty depressed at this point for taking such good care of my laptop and now its falling apart for no reason....
My System SpecsSystem Spec
11 Nov 2011   #58

windows 7 home premium 64bit

A Guy,

Thank you for all your help,
i did a Manufacture Restore and it seems to have fixed all my issues....

Thank you so much for helping me, your the best!!!

take care!
My System SpecsSystem Spec
11 Nov 2011   #59
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

I do suspect you were infected. It's unlikely (but not unheard of) for windows to get corrupted that badly on it's own. The factory restore was almost assuredly your best option. You might look into an imaging software so you can make regular system images which would allow you to restore to a point before your problems started without losing all your data and files. Windows 7 also has a built in version that some use.

Backup Complete Computer - Create an Image Backup

I use Acronis True Image, but many here use Macrium Reflect free. I'm glad you got it sorted. Make sure you have a good Antivirus software installed. A Guy
My System SpecsSystem Spec
25 Nov 2011   #60

Microsoft Windows 7 Professional 64-bit
I found a fix for this problem on my computer!!!!!

I noted several problems.
1 -- I could not open internet explorer 32 bit while I could open 64 bit ie.
2 mozilla firefox would flash the page, then crash with a crash message
3 mozilla thunderbird email would crash

I was able to restore thunderbird by going back to an earlier version
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20111103 Thunderbird/3.1.16

But the ie 32 still wouldn't open. and mozilla firefox still crashed

I tried the items posted here such as resetting, scanning for viruse etc. nothing worked.

I uninstalled mozilla firefox and reinstalled same problem. On the mozilla webpage
it suggested starting firefox in safe mode, and unchecking a hardware accelerator button. When I did that, Firefox would start in standard mode. I updated my graphic card drivers (NVIDIA GeForce GTX 460) in the windows device manager and asked it to let windows find the update. When I did that, I went back and rechecked the button in firefox to use graphic accelerator if available and it still worked.

I then did nothing else, but clicked on ie 32 bit, and it worked again. I had recently updated to ie verstion 9 9.0.8112.16421 update version 9.0.3

this is the text version on the instructions I found on the mozilla page:
Start Firefox in Safe Mode

When you start in Firefox's Safe Mode, all extensions are temporarily disabled, hardware acceleration is turned off and the default theme is used. This will help determine whether one of these is causing your problem.

At the top of the Firefox window, click the Firefox button, go over to the Help menu and select Restart with Add-ons Disabled.... Firefox will start up with the Firefox Safe Mode dialog.
For Windows XP, click the Help menu and select Restart with Add-ons Disabled....
Note: You can also start Firefox in Safe Mode by holding down the shift key while starting Firefox.
When the Firefox Safe Mode window appears, press the button Continue in Safe Mode.

After Firefox starts in Safe Mode, test for your problem.
The problem still occurs in Safe Mode

If your problem persists in Safe Mode, it is not being caused by an extension, theme or hardware acceleration. Other possible causes could be plugins or changes made to Firefox preference settings, which are not disabled in Safe Mode.

For additional troubleshooting suggestions, see Basic Troubleshooting, Troubleshooting plugins, and Resetting preferences.

The problem does not occur in Safe Mode

If your problem did not occur in Safe Mode, it is most likely because of an extension, theme or hardware acceleration. Continue following the steps in this article to determine the cause of your problem.
Turn off hardware acceleration

With some graphics card and graphics driver setups, Firefox may crash or have trouble showing text or objects on pages when using hardware acceleration. You can try turning off hardware acceleration to see if it fixes the problem.

At the top of the Firefox window, click on the Firefox button (Tools menu in Windows XP) and then click Options.
Select the Advanced panel and the General tab.
Uncheck Use hardware acceleration when available.
At the top of the Firefox window, click on the Firefox button (File menu in Windows XP) and then click Exit.
Start Firefox the way you normally do.

If the problem is no longer happening, then hardware acceleration was likely the cause. You can try updating your graphics drivers to see if that fixes it or simply run without hardware acceleration. Otherwise, your problem is likely related to extensions or themes. Continue with the steps in this article to see if they help.
Switch to the default theme
My System SpecsSystem Spec

 Internet explorer 32-bit does not work, but 64bit does

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 - 64Bit struggling to update to Internet Explorer 11
Please can someone offer advice. As the titles say above, I'm having trouble downloading and successfully installing Internet Explorer 11 for My Dad's laptop; Windows 7, 64-Bit Home Premium Edition. What occurs, receive a prompt from Microsoft informing you need to update the browser and...
Browsers & Mail
Internet Explorer 10 is forced in 64bit mode
We have a computer where IE10 is forced to run in 64bit mode Even when following options are off needed to run 64bit IE10: - Protected Mode - Enhanced Protected Mode - UAC Is there another option that might explain why it's forced to run 64bit?
Browsers & Mail
Internet Explorer - links to websites on internet do not work
Windows 7 x64 Home Premium SP1 (most recent update level) 1. clicking IE10, IE10 comes up 2. first website started, Google 3. next TAB, Google comes up (configured) Problems 1. When clicking at a desktop icon (refering to a website on the internet), the next fresh screen of IE10 comes...
Browsers & Mail
Internet Explorer 8 is not opening links to new tab in Windows 7 64bit
I have win 7 x64 with IE 8. Whenever i click on link, a new tab incompletely open but a pop up displayed on screen. that link may be a pdf, a downloadable file (movie, .exe ), It does happen in IE 9 also, i tried IE 9 by upgrading IE8. A pop up shows " Internet Explorer has stopped working ...
Browsers & Mail
Internet Explorer does not work
I am using Windows 7 x64 and I am having problem with Internet Explorer (32 bit). When I open internet explorer the taskbar and windows explorer do not work for some time and after some time automatically come into working. And if I close internet explorer then also come into working. Kindly help...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:10.
Twitter Facebook Google+