Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Bsod "kernel_data_inpage_error"

23 Aug 2010   #11

Windows 7 Ultimate 32 bit

This is another error code 7A KERNEL_DATA_INPAGE_ERROR - Usual causes: Memory, Paging file corruption, File system, Hard drive, Cabling, Virus infection, Improperly seated cards, BIOS, Bad motherboard, Missing Service Pack

The dump points to memory corruption and blames msrpc.sys which is windows remote call procedure driver. It most likely not the cause. You have tested your RAM and it passed. But something is causing memory corruption. Look at the usual causes above and go through that list checking your hardware, cable connections, power connections, and the seating of your cards and RAM.

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 7A, {fffff6fc40008cc0, ffffffffc0000185, 6565b860, fffff88001198eb0}

Unable to load image \SystemRoot\System32\Drivers\msrpc.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for msrpc.sys
*** ERROR: Module load completed but symbols could not be loaded for msrpc.sys
Probably caused by : msrpc.sys ( msrpc+3feb0 )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

The requested page of kernel data could not be read in.  Typically caused by
a bad block in the paging file or disk controller error. Also see
If the error status is 0xC000000E, 0xC000009C, 0xC000009D or 0xC0000185,
it means the disk subsystem has experienced a failure.
If the error status is 0xC000009A, then it means the request failed because
a filesystem failed to make forward progress.
Arg1: fffff6fc40008cc0, lock type that was held (value 1,2,3, or PTE address)
Arg2: ffffffffc0000185, error status (normally i/o status code)
Arg3: 000000006565b860, current process (virtual address for lock type 3, or PTE)
Arg4: fffff88001198eb0, virtual address that could not be in-paged (or PTE contents if arg1 is a PTE address)

Debugging Details:

ERROR_CODE: (NTSTATUS) 0xc0000185 - The I/O device reported an I/O error.

DISK_HARDWARE_ERROR: There was error with disk hardware

BUGCHECK_STR:  0x7a_c0000185



PROCESS_NAME:  svchost.exe


TRAP_FRAME:  fffff88006ec34b0 -- (.trap 0xfffff88006ec34b0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffff88001166520 rbx=0000000000000000 rcx=fffff8a0036b0e38
rdx=fffff8a001fdac00 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88001198eb0 rsp=fffff88006ec3648 rbp=fffff8a0036b0de0
 r8=0000000000000002  r9=0000000000000000 r10=fffffa80017c7508
r11=fffff88001166500 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
fffff880`01198eb0 ff              ???
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002b45168 to fffff80002ad0740

fffff880`06ec3198 fffff800`02b45168 : 00000000`0000007a fffff6fc`40008cc0 ffffffff`c0000185 00000000`6565b860 : nt!KeBugCheckEx
fffff880`06ec31a0 fffff800`02ac252b : fffffa80`04dc93a0 fffff880`06ec3310 fffff800`02c5d440 fffff880`01193900 : nt! ?? ::FNODOBFM::`string'+0x34c0e
fffff880`06ec3280 fffff800`02aeb5c4 : 00000000`00000000 00000000`00000008 ffffffff`ffffffff fffff880`06ec3400 : nt!MiIssueHardFault+0x28b
fffff880`06ec3350 fffff800`02ace82e : 00000000`00000008 fffff8a0`01fdac00 fffff8a0`01fdac00 00000000`00000002 : nt!MmAccessFault+0x11c4
fffff880`06ec34b0 fffff880`01198eb0 : fffff880`0119b6d7 00000000`00000010 00000000`00010202 fffff880`06ec3678 : nt!KiPageFault+0x16e
fffff880`06ec3648 fffff880`0119b6d7 : 00000000`00000010 00000000`00010202 fffff880`06ec3678 00000000`00000018 : msrpc+0x3feb0
fffff880`06ec3650 00000000`00000010 : 00000000`00010202 fffff880`06ec3678 00000000`00000018 fffff8a0`02046670 : msrpc+0x426d7
fffff880`06ec3658 00000000`00010202 : fffff880`06ec3678 00000000`00000018 fffff8a0`02046670 fffff880`0118920c : 0x10
fffff880`06ec3660 fffff880`06ec3678 : 00000000`00000018 fffff8a0`02046670 fffff880`0118920c 00000000`00000001 : 0x10202
fffff880`06ec3668 00000000`00000018 : fffff8a0`02046670 fffff880`0118920c 00000000`00000001 fffff8a0`0283e6e0 : 0xfffff880`06ec3678
fffff880`06ec3670 fffff8a0`02046670 : fffff880`0118920c 00000000`00000001 fffff8a0`0283e6e0 fffff8a0`036b0de0 : 0x18
fffff880`06ec3678 fffff880`0118920c : 00000000`00000001 fffff8a0`0283e6e0 fffff8a0`036b0de0 00000000`00000000 : 0xfffff8a0`02046670
fffff880`06ec3680 00000000`00000001 : fffff8a0`0283e6e0 fffff8a0`036b0de0 00000000`00000000 00000000`00000001 : msrpc+0x3020c
fffff880`06ec3688 fffff8a0`0283e6e0 : fffff8a0`036b0de0 00000000`00000000 00000000`00000001 fffff880`06ec36d8 : 0x1
fffff880`06ec3690 fffff8a0`036b0de0 : 00000000`00000000 00000000`00000001 fffff880`06ec36d8 fffff8a0`037360b0 : 0xfffff8a0`0283e6e0
fffff880`06ec3698 00000000`00000000 : 00000000`00000001 fffff880`06ec36d8 fffff8a0`037360b0 fffff8a0`02046670 : 0xfffff8a0`036b0de0


fffff880`01198eb0 ff              ???


SYMBOL_NAME:  msrpc+3feb0

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  msrpc.sys


FAILURE_BUCKET_ID:  X64_0x7a_c0000185_msrpc+3feb0

BUCKET_ID:  X64_0x7a_c0000185_msrpc+3feb0

Followup: MachineOwner
I find two slightly out of date drivers on your system; update these two drivers or consider upgrading your network adapter and wireless adapter. I can't say these drivers are causing your problem; but they are out of date and I have seen network adapters and wireless adapters cause BSOD's.
BCM42RLY.sys Tue Jul 07 20:34:55 2009 - Broadcom iLine10(tm) PCI Network Adapter Proxy Protocol Driver belongs to the software BCM42RLY or Broadcom iLine10(tm) PCI Network Adapter by Broadcom Corporation (

bcmwl664.sys Tue Jul 07 20:45:04 2009 - Broadcom 802.11 Network Adapter wireless driver.
Post back and let us know.

My System SpecsSystem Spec
01 Sep 2010   #12

Windows 7 Home Premium x64

After updating the drivers as recommended a week ago, I have had a stable computer--until now. I've received two bsod's closely together and have no idea why.

Attached is the bsod minidumps etc.
My System SpecsSystem Spec
30 Dec 2010   #13

windows 7, mac os X

From what i can tell, Im having the same error and its either a ram problem, only while copying large amounts of data does it happen to me, and it seems to be related to RAM, and/or the page file.. Another post i read seems to lean towards the page file.. is your system drive old by any chance?? in anyway iffy? guaranteed if u had a brand new drive and re-installed compatible pairs or single chip of ram (to eliminate incompatibilities) the problem would stop..

Do you have any SATA addon cards???
My System SpecsSystem Spec

01 Jan 2011   #14

Windows 7 Home Premium x64

I've tested and even swapped out my RAM.. so that's not an issue. This is a laptop so I have no addon cards of any kind.

Often when my computer has a bsod it corrupts files that were being written to (which is to be expected). The odd thing is this; when I then reboot my computer and attempt to access, delete or copy those files, it causes another bsod. (knowing which files is just through normal usage)

This seems odd to me because merely accessing a corrupt file shouldn't do this (afaik).

I'm just speculating but I suspect either a defective PCB on the hdd or on the SATA access on the motherboard itself.

I don't have a replacement HDD I can try unfortunately.
My System SpecsSystem Spec
01 Jan 2011   #15

Windows 7 Ultimate 32 bit

Razer, run Check Disk -
Run CHKDSK /R /F from an elevated (Run as adminstrator) Command Prompt. Please do this for each hard drive on your system.
When it tells you it can't do it right now - and asks you if you'd like to do it at the next reboot - answer Y (for Yes) and press Enter. Then reboot and let the test run. It may take a while for it to run, but keep an occasional eye on it to see if it generates any errors. See "CHKDSK LogFile" below in order to check the results of the test.

Elevated Command Prompt:
Go to Start and type in "cmd.exe" (without the quotes)
At the top of the Search Box, right click on Cmd.exe and select "Run as administrator"

Go to Start and type in "eventvwr.msc" (without the quotes) and press Enter
Expand the Windows logs heading, then select the Application log file entry.
Double click on the Source column header.
Scroll down the list until you find the Chkdsk entry (wininit for Windows 7).
Copy/paste the results into your next post.

Next, run Memtest again from a cold boot after you computer has been off for an hour or two. Again, run it for a minimum of seven passes.
My System SpecsSystem Spec
01 Jan 2011   #16

Windows 7 Home Premium x64

I should have said I run chkdsk C: /R (which implies /F) when this happens (as you've described).

Attached is 12 of the most recent chkdsk (wininit) log files and then the oldest one I have dating back to September. In this timeframe the number of bad sectors has went from 40 KB to 388 KB. Is it possible that sectors can suddenly become 'bad' after a bsod or is the bsod a result of these bad sectors?

I've ran memtest overnight before and even borrowed RAM from another laptop (which doesn't have this problem before or after swapping) so I'd rule it out.

Thanks again.
My System SpecsSystem Spec
01 Jan 2011   #17

Windows 7 Ultimate 32 bit

The increase in bad sectors may will be, and probably is, a sign your hard drive is failing. A failing hard drive can definitely create freezes, BSOD's, corrupted files and all sorts of problems. If it were my system - and I had this happen to me in October of 2009 - I would back all of my files up ASAP on an external hard drive, purchase a new hard drive and install Windows on it. You can then copy your files back from the external hard drive. Of course, you will have to reinstall your software. Once bad sectors appear containing Win 7 system files or parts of them, your system won't boot. This I know from personal experience.
My System SpecsSystem Spec
02 Jan 2011   #18

windows 7, mac os X

I was getting this error yesterday, but i ended up frying the board's BIOS so im waiting to buy a new motherboard tomorrow.. first board i ever fried doing a flash bios update.. LAME!
My System SpecsSystem Spec
02 Jan 2011   #19

windows 7, mac os X

And yes i think its from a failing hard drive aswell, or a combination of incompatible ram, intermittent to bad hard drive performance. Id reccommend u get a newer drive, test it for performance, test the ram, check your ram configuration and make sure its ideal as suggested in your motherboards manual. reinstall win7 on the new drive (while keeping your old drive intact) and copy whatever files u need off the old boot drive while u continue to use the new install, hoping that you dont see the BSOD ever again. if you dont get a bsod then you know youve fixed it and it was indeed the old drive. which can still be used for data, just not system boot & page file.

good luck!
My System SpecsSystem Spec
02 Jan 2011   #20

windows 7, mac os X

RMA the Hard drive. Get A new Drive.
My System SpecsSystem Spec

 Bsod "kernel_data_inpage_error"

Thread Tools

Similar help and support threads
Thread Forum
BSOD every few hours: mostly "STOP: 0x00000F4", "c00021a" & "c0000135"
Hi everyone! Yesterday my HP laptop (Windows 7) started getting BSOD with various types of errors (mostly "STOP: 0x00000F4", "STOP: 0x0000007A", "c00021a" and one "missing %hs, c0000135"). Most of the time it restarts without any issues and works fine right after the BSOD and then an hour or two...
BSOD Help and Support
Need to add "TASKBARS" (MSese for "Launchpads", "Docks" NOT "Toolbars"
My office just upgraded, and I can no longer use Windows XP. On this system, I was able to add a separate taskbar to facilitate quick access to commonly-browsed folder locations on our vast network, and another one expedited the launching of useful programs and lists. Each task on each taskbar...
General Discussion
BSOD "Bad Pool Header" and "Page In Nonpage Area" Runs in Safe Mode
Hi, I am having a problem with my newer computer, I just got this rig a few months ago and never had a problem until last Thursday. It Blue Screened on me while I was installing ARC GIS 10.1. From then on it randomly crashes. (I have previously installed ARC GIS 10 and never had a problem.) I...
BSOD Help and Support
Hello, i've been having this problem for a week now, tried to fix it but no luck what so ever. So i got tired and i am looking for your assistance on this matter. Every time I play Aion online, in about 10-30mins i get a blue screen saying "REFERENCE BY POINTER" or "IRQL NOT LESS OR EQUAL", tried...
BSOD Help and Support
BSOD with "usbhub.sys" and "driver power state failure"
I have been getting the BSOD since a few weeks and found out by trial and error that a USB-hub is causing the problem. Whenever I disconnect the hub before I shut off the computer I do not get the blue screen. Yesterday I also got a BSOD that mentioned driver power state failure. After I had...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App