Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD

11 Oct 2010   #1

Windows 7 64 bit

Hello. I recently put a computer together and have run into some BSOD problems. I tried reinstalling a fresh copy of windows. But that has not worked.

The computer is running window 7 64 bit OEM
Biostar A880g+ MB
AMD athlon IIx3 445

If I need to include any other information or files, please let me know. Thanks ahead of time.

My System SpecsSystem Spec
11 Oct 2010   #2

Win 7 Ultimate 64-bit. SP1.

Quote   Quote: Originally Posted by dllee101 View Post
Hello. I recently put a computer together and have run into some BSOD problems. I tried reinstalling a fresh copy of windows. But that has not worked.

The computer is running window 7 64 bit OEM
Biostar A880g+ MB
AMD athlon IIx3 445

If I need to include any other information or files, please let me know. Thanks ahead of time.
Hi dllee and welcome

These crashes were both caused by memory corruption. Either a driver corrupted the memory or the memory itself is suspect.

Please run a memory test

Download a copy of Memtest86 and burn the ISO to a CD using Iso Recorder or another ISO burning program. Boot from the CD, and leave it running for at least 5 or 6 passes.

Just remember, any time Memtest reports errors, it can be either bad RAM or a bad motherboard slot. Test the sticks individually, and if you find a good one, test it in all slots.

If the memory checks out with no errors we can then run driver verifier to determine which driver is suspect.

Beyond that, please run Verifier with these settings:
Using Driver Verifier is an iffy proposition. Most times it'll crash and it'll tell you what the driver is. But sometimes it'll crash and won't tell you the driver. Other times it'll crash before you can log in to Windows. If you can't get to Safe Mode, then you'll have to resort to offline editing of the registry to disable Driver Verifier.

So, I'd suggest that you first backup your stuff and then make sure you've got access to another computer so you can contact us if problems arise. Then make a System Restore point (so you can restore the system using the Vista/Win7 Startup Repair feature).

Then, here's the procedure:
- Go to Start and type in "verifier" (without the quotes) and press Enter
- Select "Create custom settings (for code developers)" and click "Next"
- Select "Select individual settings from a full list" and click "Next"
- Select everything EXCEPT FOR "Low Resource Simulation" and click "Next"
NOTE: You can use Low Resource Simulation if you'd like. From my limited experimentation it makes the BSOD's come faster.
- Select "Select driver names from a list" and click "Next"
Then select all drivers NOT provided by Microsoft and click "Next"
- Select "Finish" on the next page.

Reboot the system and wait for it to crash to the Blue Screen. Continue to use your system normally, and if you know what causes the crash, do that repeatedly. The objective here is to get the system to crash because Driver Verifier is stressing the drivers out. If it doesn't crash for you, then let it run for at least 36 hours of continuous operation (an estimate on my part).

Reboot into Windows (after the crash) and turn off Driver Verifier by going back in and selecting "Delete existing settings" on the first page, then locate and zip up the memory dump file and upload it with your next post.

If you can't get into Windows because it crashes too soon, try it in Safe Mode.
If you can't get into Safe Mode, try using System Restore from your installation DVD to set the system back to the previous restore point that you created.

If that doesn't work, post back and we'll have to see about fixing the registry entry off-line:
Delete these registry keys (works in XP, Vista, Win7):
        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\VerifyDrivers
        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\VerifyDriverLevel
Using Driver Verifier to identify issues with Windows drivers for advanced users

Let us know if you need assistance with this


Microsoft (R) Windows Debugger Version 6.11.0001.404 X86
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\K\Desktop\Windows_NT6_BSOD_jcgriff2\083110-18829-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\symbols;*;srv*e:\symbols
Executable search path is: 
Windows 7 Kernel Version 7600 MP (3 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7600.16617.amd64fre.win7_gdr.100618-1621
Machine Name:
Kernel base = 0xfffff800`0285a000 PsLoadedModuleList = 0xfffff800`02a97e50
Debug session time: Tue Aug 31 11:06:58.312 2010 (GMT-4)
System Uptime: 0 days 0:00:10.982
Loading Kernel Symbols
Loading User Symbols
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 4E, {99, 117460, 5, 0}

Probably caused by : memory_corruption ( nt!MiBadShareCount+4c )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Typically caused by drivers passing bad memory descriptor lists (ie: calling
MmUnlockPages twice with the same list, etc).  If a kernel debugger is
available get the stack trace.
Arg1: 0000000000000099, A PTE or PFN is corrupt
Arg2: 0000000000117460, page frame number
Arg3: 0000000000000005, current page state
Arg4: 0000000000000000, 0

Debugging Details:






TRAP_FRAME:  fffff88002c06490 -- (.trap 0xfffff88002c06490)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffff98001bd2c00 rbx=0000000000000000 rcx=0000000000000000
rdx=0000000000000067 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80002bd0981 rsp=fffff88002c06620 rbp=0000000000000000
 r8=0000000000000012  r9=0000000000000000 r10=00000000fffffff9
r11=00000000019d2c00 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz ac po cy
fffff800`02bd0981 0fb600          movzx   eax,byte ptr [rax] ds:fffff980`01bd2c00=??
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff8000295a38c to fffff800028ca740

fffff880`02c05978 fffff800`0295a38c : 00000000`0000004e 00000000`00000099 00000000`00117460 00000000`00000005 : nt!KeBugCheckEx
fffff880`02c05980 fffff800`0292c558 : ffffffff`ffffffff fffffa80`036e7040 fffffa80`0345d230 00000000`00000000 : nt!MiBadShareCount+0x4c
fffff880`02c059c0 fffff800`02895492 : fffff6fc`400160e8 00000000`00000007 00000000`00000006 00000000`00000000 : nt! ?? ::FNODOBFM::`string'+0x184c5
fffff880`02c05a10 fffff800`028da2b2 : 00000000`00000000 fffff880`02c05c50 fffff6fc`400160e8 fffffa80`036e7040 : nt!MiDeleteKernelStack+0x36
fffff880`02c05a60 fffff880`01238b69 : fffff880`0123a534 fffff880`02c05b78 fffff6fc`400160e8 fffff880`00000000 : nt!KeExpandKernelStackAndCalloutEx+0x532
fffff880`02c05b40 fffff880`01238036 : fffffa80`04e69150 00000000`00000000 fffffa80`0468b8c0 00000000`00000001 : Ntfs!NtfsMultipleAsync+0xa9
fffff880`02c05bb0 fffff880`0123b526 : fffff880`02c05f50 fffffa80`04e34810 fffffa80`0468b8c0 00000000`00000000 : Ntfs!NtfsNonCachedIo+0x216
fffff880`02c05d80 fffff880`0123df78 : fffff880`02c05f50 fffffa80`04e34810 fffff880`02c06001 fffffa80`04bb7301 : Ntfs!NtfsCommonRead+0x7a6
fffff880`02c05f20 fffff880`00c0323f : fffffa80`04e34bb0 fffffa80`04e34810 fffffa80`04bb73c0 00000000`00000000 : Ntfs!NtfsFsdRead+0x1b8
fffff880`02c06120 fffff880`00c016df : fffffa80`04637a30 fffffa80`04e34810 fffffa80`04637a00 fffffa80`04e34810 : fltmgr!FltpLegacyProcessingAfterPreCallbacksCompleted+0x24f
fffff880`02c061b0 fffff800`028bc1f2 : fffffa80`04e34830 fffffa80`0467dbc0 00000000`00000043 fffff980`01bd2c00 : fltmgr!FltpDispatch+0xcf
fffff880`02c06210 fffff800`028bc4f5 : 0f300001`0d946900 0f300001`0d946900 fffff880`02c062d0 fffff800`02bc00b0 : nt!IoPageRead+0x252
fffff880`02c062a0 fffff800`028e55c4 : 00000000`00000000 00000000`00000000 ffffffff`ffffffff fffff8a0`00246860 : nt!MiIssueHardFault+0x255
fffff880`02c06330 fffff800`028c882e : 00000000`00000000 00000000`0000000e 00000000`00000000 00000000`00000000 : nt!MmAccessFault+0x11c4
fffff880`02c06490 fffff800`02bd0981 : 00000000`019c0000 00000000`019d2c00 fffff880`02c066e8 fffff880`02c066e0 : nt!KiPageFault+0x16e
fffff880`02c06620 fffff880`012e9522 : fffffa80`0002d400 fffffa80`036b84b0 fffff8a0`00a61ed8 fffffa80`0000000e : nt!CcMapData+0x111
fffff880`02c066e0 fffff880`012df4dc : fffffa80`04d68010 fffffa80`04ac6180 fffff8a0`00a5b018 00000000`00000801 : Ntfs!NtfsReadMftRecord+0xb2
fffff880`02c06790 fffff880`012ae4aa : fffff8a0`00a5b014 fffff8a0`00a5b000 fffffa80`04e34010 00000000`00000000 : Ntfs!NtfsLookupInFileRecord+0x6c
fffff880`02c06820 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : Ntfs!NtfsUpdateFcbInfoFromDisk+0xaa


fffff800`0295a38c cc              int     3


SYMBOL_NAME:  nt!MiBadShareCount+4c

FOLLOWUP_NAME:  MachineOwner



IMAGE_NAME:  memory_corruption

FAILURE_BUCKET_ID:  X64_0x4E_99_nt!MiBadShareCount+4c

BUCKET_ID:  X64_0x4E_99_nt!MiBadShareCount+4c

Followup: MachineOwner
My System SpecsSystem Spec
15 Oct 2010   #3

Windows 7 64 bit

Hello again,

I ran the memtest overnight and after 10 passes no errors were found.

I have run the verifier and attached are the files.

My System SpecsSystem Spec

15 Oct 2010   #4

Windows 7 Ultimate 32 bit

I looked at four of your dumps. Your two Driver Verifier enabled dumps blamed atikmdag.sys. This driver is up to date. You do have one out of date driver:
Rt64win7.sys Thu Feb 26 04:04:13 2009 -Latest PCIe GBE (GigaBit Ethernet) drivers here: Realtek.

Update this driver, reboot and see if this fixes your problem. If it does not, run Memtest as recommended above.

My System SpecsSystem Spec


Thread Tools

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App