Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSODs from 2 to 12 hours in runtime.

15 Oct 2010   #1

Windows 7 Ultimate x64
BSODs from 2 to 12 hours in runtime.

Hi all,

Had an issue of BSODs for the last week and a half since getting new hardware.

Basically overhauled the system, everything new down to harddrive, only old component is a year old Gigabyte GTX275 PCIEVideo Card, which is around a year old.

BSODs have been occurring any time from running windows update (after restart, before 7 has booted) to web browsing, playing video files, games or other progs.

I've done a fresh install of 7, ran every memtest and drivetest I can find with no luck, and the BSOD errors being thrown at me all seem to have something different in them, the latest referring to USBPORT.sys and win32k.dll (will attach them to this post).

I've updated every driver I can find to the latest win7 x64 version, to no avail. Fresh (2 days old) win7 install, have ran burn in tests on the old install to try and force the BSOD, no luck, froze 12 hours later while watching a dvd.

I know there are only 2 minidumps with this, and the stuff that was asked for in the BSOD posting guide, but I'll update as further BSODs occur. Hopefully someone can help :)


My System SpecsSystem Spec
15 Oct 2010   #2

Windows 7 Ultimate x64 SP1

Hi Remi
Your dumps have error code:
  • 0x5 = This generally indicates that the thread was attached to a process in a situation where that is not allowed.
  • 0xD1 = This indicates that a kernel-mode driver attempted to access pageable memory at a process IRQL that was too high.
A hardware device, its driver, or related software might have caused that error.
Let's begin with uninstall Kaspersky and replace it with MSE. (because MSE is known running better in windows kernel)

Have you run memtest at least 7 passes? (with different slot). RAM - Test with Memtest86+
Because I see memory access fault in the stack :
fffff800`028bb80a 85c0            test    eax,eax
fffff800`028bb80c 0f8d0e010000    jge     nt!KiPageFault+0x260 (fffff800`028bb920)
fffff800`028bb812 4c8d4d80        lea     r9,[rbp-80h]
fffff800`028bb816 448a85f0000000  mov     r8b,byte ptr [rbp+0F0h]
fffff800`028bb81d 4180e001        and     r8b,1
fffff800`028bb821 488b5550        mov     rdx,qword ptr [rbp+50h]
fffff800`028bb825 0fb64daa        movzx   ecx,byte ptr [rbp-56h]
fffff800`028bb829 e8d2bb0100      call    nt!MmAccessFault (fffff800`028d7400)
The possibility =
- You have bad RAM
- Bad slot motherboard
- 3rd driver causing the fault

Enable driver verifier and use the windows as usual.
If there are any driver violation , your windows will crash and attach the new dumps here.
Driver Verifier - Enable and Disable

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {fffffa802612c300, 2, 1, fffff88004614338}

Probably caused by : USBPORT.SYS ( USBPORT!USBPORT_Core_iMapTransfer+54 )

Followup: MachineOwner

3: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: fffffa802612c300, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, value 0 = read operation, 1 = write operation
Arg4: fffff88004614338, address which referenced memory

Debugging Details:

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff80002ac50e0


fffff880`04614338 c7016d617030    mov     dword ptr [rcx],3070616Dh





TRAP_FRAME:  fffff880009b0c60 -- (.trap 0xfffff880009b0c60)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=00000000eb29c518 rbx=0000000000000000 rcx=fffffa802612c300
rdx=00000000eb29c519 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88004614338 rsp=fffff880009b0df0 rbp=0000000000000000
 r8=fffffa80050a01a0  r9=fffffa8004f72d20 r10=fffffa80050a01a0
r11=fffffa80050a01a0 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na po nc
fffff880`04614338 c7016d617030    mov     dword ptr [rcx],3070616Dh ds:fffffa80`2612c300=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff8000288e469 to fffff8000288ef00

fffff880`009b0b18 fffff800`0288e469 : 00000000`0000000a fffffa80`2612c300 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`009b0b20 fffff800`0288d0e0 : 00000000`00000000 fffffa80`050a0050 fffffa80`04f73e9b 00000000`00000000 : nt!KiBugCheckDispatch+0x69
fffff880`009b0c60 fffff880`04614338 : fffff880`009b0e48 fffffa80`050a01a0 fffffa80`050a0050 fffff880`0461154a : nt!KiPageFault+0x260
fffff880`009b0df0 fffff880`04611e86 : fffffa80`050a0050 fffffa80`050a0050 fffffa80`03f8a510 fffffa80`050a01a0 : USBPORT!USBPORT_Core_iMapTransfer+0x54
fffff880`009b0e70 fffff880`04602f89 : fffffa80`050a0050 00000000`00000000 fffffa80`050a0d02 fffffa80`050a0d20 : USBPORT!USBPORT_Core_UsbMapDpc_Worker+0x296
fffff880`009b0ed0 fffff800`0289a5dc : fffff880`035d3180 fffffa80`050a0d20 fffffa80`050a0d38 00000000`00000000 : USBPORT!USBPORT_Xdpc_Worker+0x1d9
fffff880`009b0f00 fffff800`02895065 : 000004d8`00000000 fffffa80`046e6b60 00000000`00000000 fffff880`04602db0 : nt!KiRetireDpcList+0x1bc
fffff880`009b0fb0 fffff800`02894e7c : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxRetireDpcList+0x5
fffff880`12cd0a50 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiDispatchInterruptContinue


fffff880`04614338 c7016d617030    mov     dword ptr [rcx],3070616Dh



FOLLOWUP_NAME:  MachineOwner





BUCKET_ID:  X64_0xD1_USBPORT!USBPORT_Core_iMapTransfer+54

Followup: MachineOwner
My System SpecsSystem Spec
16 Oct 2010   #3

Windows 7 Ultimate x64

Hi, wish, and thanks for your reply!

Dropping off Kaspersky now, and I've enabled the driver verifier as per your linked guide - I'll run memtest86 overnight again tonight, and see if anything comes up, I believe I ran it for around 5 passes last time, but if it helps troubleshoot, I'll gladly leave it on longer. I'll run it until it crashes again with current config (minus kaspersky) and keep you updated. When it inevitably crashes again, I'll post the minidumps and move on to the memtest for at least 7 passes.

Thankyou again for your troubleshooting this far!
My System SpecsSystem Spec

16 Oct 2010   #4

Windows 7 Ultimate x64 SP1

You're welcome and please do so :)
My System SpecsSystem Spec
16 Oct 2010   #5

Windows 7 Ultimate x64

Well, just switched the RAM over to the other slots to see if it's a dead slot. 4 errors over 4 passes on MemTest86+ for running through the afternoon. Kinda strange that MemTest86 didn't pick it up yesterday, but 4 for 4 seems like a RAM or motherboard call to me, just as you called it. Fingers crossed for RAM, because it's a little cheaper to replace.

Thanks again for your help, once I've finished ram/motherboard testing and replaced the faulty part, I'll post up to let you know how it all went. First couple of pieces of hardware to be Dead on Arrival/Faulty for me in about 10 years, scared the heck out of me when it just BSOD'd like that.

Thanks for setting my mind at rest and pointing me on the right path - you're a lifesaver :)
My System SpecsSystem Spec
20 Oct 2010   #6

Windows 7 Ultimate x64

Ok - 2 new (generic) sticks of RAM while the others are away on warranty, 0 errors on a memtest pass, and the system's been up 48 hours straight running a few intensive memory programs, and no problems whatsoever.

Thanks again for your help, this one's well and truly solved!
My System SpecsSystem Spec
20 Oct 2010   #7

Windows 7 Ultimate x64 SP1

Thanks for the good news.
I am glad to hear that
My System SpecsSystem Spec

 BSODs from 2 to 12 hours in runtime.

Thread Tools

Similar help and support threads
Thread Forum
Random BSODs every 24-36 hours on new computer
I just got a custom built computer, and I'm getting random BSODs every day or so. They seem have different codes. I tried looking at the dumps in windbg but was not able to understand what the problem is. I also ran an overnight memtest which was fine. Attached are the dump files. Thanks in...
BSOD Help and Support
BSODs during long periods of activity, 4-5 hours.
I just started having bsods on a brand new harddrive (and 8 gb ram) that replaced a bad one. Recently, the bsods happen randomly after about 15-30 minutes of activity and have changed to just black screens, then restarting the boot process.
BSOD Help and Support
laptop BSODs, several hours apart, unknown cause
This is technically my cousins laptop, but the whole family uses it. I was using it tonight with multiple IE windows open when it suddenly BSOD on me. I didn't see what the error number was or anything like that. I've found out that its done this twice earlier today. As far as know no new drivers,...
BSOD Help and Support
3 BSODs in 24-48 hours, error(s) 0x0000000a, 0x0000004a
In the past 24-48 hours I received about 3 BSOD crashes. I've uploaded the files. Using BlueScreenView I seen the error(s) were caused by the driver(s) ntoskrnl.exe and hal.dll (Crash address: ntoskrnl.exe+7efc0) Someone told me that it could be caused by bitdefender TS 2013? Is that true? ...
BSOD Help and Support
Nine BSoDs in Two Hours
Hello, I've been experiencing a lot of BSoDs recently. They computer flashes the bluescreen and then reboots. This is not the first time it has happened. Usually I let the computer reboot and it does not BSoD again but this time it's different. They only occur when I am using the wireless at my...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:34.
Twitter Facebook Google+