Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unmountable_boot_Volume/MBR Corrupt/Device...not Functioning

26 Oct 2010   #1

Windows 7 32bit
Unmountable_boot_Volume/MBR Corrupt/Device...not Functioning

This is my first post in this forum. Please bear with me.

About 2 years ago I bought one of the infamous Barracuda 7200.11 hard drives. Several months later it stopped working. Seagate claimed a firmware issue and fixed the drive. I was able to keep all my data.


1. The drive shows up in the bios (by itself Boot priority is 1st hard drive and when
It is added as a second drive it is second in hard drive priority.) It shows up
both ways.

2. Seagate firmware will update.

3. When booting into windows the computer gets stuck on opening screen. After a while a brief BSOD appears..but disappears too fast to read.

4. After restart I am asked to start in safe mode or normal.

I choose safe mode. Again to opening screen. After a while the BSOD
appears: unmountable_boot_volume ....
"Stop 0x000000ED (0x8E065030, 0x C000014F,0x00000000, 0x00000000)

5. I then insert the Win. 7 Disc and run Check Disk. After sometime I get:
Root cause found: MBR is Corrupt

Repair action: Disk metadata repair
Result: Failed, Error code = 0x45d

6. Next from Windows RE I enter "command prompt" and then
BootRec.exe. I run BootRec.exe/FixMbr. After a few moments I get:
A device attached to the system is not functioning.

7. When the drive is attached to my computer as a second drive it shows up, but
is not accessible. I get: F:\ is not accessible
The request could not be performed because of
I/O device error.

In the end I just want the drive to work long enough for me to get the data from it. I have business documents and photos that I need.

I will be grateful for any help. Thanks guys.

My System SpecsSystem Spec
26 Oct 2010   #2

Windows 7 Ultimate (2 machines one x86 one x64)

I just went through a similar issue with a WD Raptor that was my disk used for virtual machines but I had some stuff stored on it as well. I was able to get it to mount just long enough in windows to get a directory listing on it then it would disappear and win7 would give me an error like you got in #7. In my case I was able to get it working with a Linux recovery disk to put that data on a secondary hard drive.

Here is the one I use: (I also keep around several other free boot dvds that I use as well, like Ultimate Boot CD - Overview)
Computer First Aid Using Knoppix
My System SpecsSystem Spec
26 Oct 2010   #3

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

To try to fix mbr automatically, you should try Startup Repair , three separate times with restarts .

After fixing boot, if still that volume does not work, you may use Recuva for it's recovery of data .
My System SpecsSystem Spec

26 Oct 2010   #4

Windows 7 32bit

Thank you guys I will look into both options. And look forward to all other options posted. If I get the problem solved, I wil definitely let everyone know. Thanks again.
My System SpecsSystem Spec

 Unmountable_boot_Volume/MBR Corrupt/Device...not Functioning

Thread Tools

Similar help and support threads
Thread Forum
Huawei USB E367 Internet device not functioning properly
Hallo, I have a Toshiba Laptop with Windows 7, 32-bit with 2G Ram. I use a Huawei USB E367 for my internet connection. It has been working well for the past 4 years, on any computer that I use. The USB has been giving me trouble for the past few weeks now, but ONLY on my laptop, on all...
Hardware & Devices
Mbr corrupt and i/o device not found.
Hai! Guys iam having a problem with my assus n55sf. I try to clean my asus every weekend (clean, scan disk & defrg) and shut down. When i try to on it show me windows 7 repair (recom). I dont know whats wrong. I start repair my asus and the result (mbr corrupt) i try fix mbr it show me (i/o...
General Discussion
Device driver attempting to corrupt Kernel caught
The Minidumps I have indicate; DRIVER_VERIFIER_DETECTED_VIOLATION UNEXPECTED_KERNEL_MODE_TRAP MEMORY_MANAGEMENT PAGE_FAULT_IN_NONPAGED_AREA My OS is Windows 7 64bit, and has been newly reinstalled to try and fix the issue. Unfortunately it hasn't fixed the issue. My hardware dates back to...
BSOD Help and Support
BDRW- driver corrupt, can't reinstall, cd says not correct device
I've recently restored my os from an image, and today I've found that my "LG WH10LS30 10X Blu-ray Burner with LightScribe" drive is not showing up under Computer. What I've checked, tried, and found so far: - Tools > Folder Options > View > "Hide empty drives" is UNchecked. - Device...
bsod also device driver trying to corrupt system
I have been having bsods a couple over the last couple of days, so I ran the driver verifier to see if any drivers where causing the problem. Ther is but I don't know which one. So I have attached my dump file here to this thread to see if any one can help me get this ironed out...thanx in...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App