Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win 7 X64 spooler issues.

28 Oct 2010   #1
Galkins

windows xp pro
 
 
Win 7 X64 spooler issues.

Have a machine running Win 7 home premium 64 bit, it had an HP MFC printer connected to it but then suddenly stopped working.

Some hours of looking about found the problem was the spooler service stopped starting,
checked c:\windows\system32\ and found spoolsv.exe was renamed spoolsv.exe.log, removed the wrong version of spoolsv.exe and put back in the correct version and spooler started up fine.

Problem is that every time the machine reboots the problem repeats itself. On checking the event log, aside from the message that the spooler failed to start the only other error I get is:
The Remote Procedure Call (RPC) Sync failed to start due to the following error:
This version of RPC Sync is not compatible with the version of windows you're running...


Any ideas on if the two are related and how to resolve the spooler problem?


My System SpecsSystem Spec
.
28 Oct 2010   #2
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

The best and easy solution would be a quick system restore.
System Restore
My System SpecsSystem Spec
28 Oct 2010   #3
Galkins

windows xp pro
 
 

I'd rather do a restore as a last resort, I'd prefer to know if this problem will re-occur and how or why it happened.
My System SpecsSystem Spec
.

28 Oct 2010   #4
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

You may be able to fix it with an SFC scan.
SFC /SCANNOW Command - System File Checker
It is a form of corruption. It may have happened during a shutdown, power surge, etc. I do not know the exact cause, but we can take measure to correct the problem.
My System SpecsSystem Spec
28 Oct 2010   #5
Galkins

windows xp pro
 
 

SFC scan says it found corrupt files but was unable to fix. Posted to the cbi.log but beyond me as to what in the log to look for exactly.
My System SpecsSystem Spec
28 Oct 2010   #6
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

I will get instructions on finding the log. But run the SFC several times, it has difficulty fixing all files at once.
My System SpecsSystem Spec
28 Oct 2010   #7
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

My System SpecsSystem Spec
28 Oct 2010   #8
Galkins

windows xp pro
 
 

Ok running out of fingers to count the number of times I've run SFC

Looking at the log it seems to be tcpmon.ini that is causing the problem, here's an excerpt

2010-10-28 02:09:38, Info CSI 00000122 [SR] Beginning Verify and Repair transaction
2010-10-28 02:09:41, Info CSI 00000123 Hashes for file member \SystemRoot\WinSxS\amd64_microsoft-windows-p..rtmonitor-tcpmonini_31bf3856ad364e35_6.1.7600.16385_none_2e6dc451c0fa9db5\tcpmon.ini do not match actual file [l:20{10}]"tcpmon.ini" :
Found: {l:32 b:as3OOcx5px0XiJa7f7s9BVvlW/FFlKR4NMU/T+UP/Kg=} Expected: {l:32 b:ENtKeUct91LKlHclgfWTvnCdCOHHwDe+SYrPzZTTezU=}
2010-10-28 02:09:41, Info CSI 00000124 [SR] Cannot repair member file [l:20{10}]"tcpmon.ini" of Microsoft-Windows-Printing-StandardPortMonitor-TCPMonINI, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
2010-10-28 02:09:44, Info CSI 00000125 Hashes for file member \SystemRoot\WinSxS\amd64_microsoft-windows-p..rtmonitor-tcpmonini_31bf3856ad364e35_6.1.7600.16385_none_2e6dc451c0fa9db5\tcpmon.ini do not match actual file [l:20{10}]"tcpmon.ini" :
Found: {l:32 b:as3OOcx5px0XiJa7f7s9BVvlW/FFlKR4NMU/T+UP/Kg=} Expected: {l:32 b:ENtKeUct91LKlHclgfWTvnCdCOHHwDe+SYrPzZTTezU=}
2010-10-28 02:09:44, Info CSI 00000126 [SR] Cannot repair member file [l:20{10}]"tcpmon.ini" of Microsoft-Windows-Printing-StandardPortMonitor-TCPMonINI, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
2010-10-28 02:09:44, Info CSI 00000127 [SR] This component was referenced by [l:202{101}]"Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~6.1.7600.16385.WindowsFoundationDelivery"
2010-10-28 02:09:44, Info CSI 00000128 Hashes for file member \??\C:\Windows\System32\tcpmon.ini do not match actual file [l:20{10}]"tcpmon.ini" :
Found: {l:32 b:as3OOcx5px0XiJa7f7s9BVvlW/FFlKR4NMU/T+UP/Kg=} Expected: {l:32 b:ENtKeUct91LKlHclgfWTvnCdCOHHwDe+SYrPzZTTezU=}
2010-10-28 02:09:44, Info CSI 00000129 Hashes for file member \SystemRoot\WinSxS\amd64_microsoft-windows-p..rtmonitor-tcpmonini_31bf3856ad364e35_6.1.7600.16385_none_2e6dc451c0fa9db5\tcpmon.ini do not match actual file [l:20{10}]"tcpmon.ini" :
Found: {l:32 b:as3OOcx5px0XiJa7f7s9BVvlW/FFlKR4NMU/T+UP/Kg=} Expected: {l:32 b:ENtKeUct91LKlHclgfWTvnCdCOHHwDe+SYrPzZTTezU=}
2010-10-28 02:09:44, Info CSI 0000012a [SR] Could not reproject corrupted file [ml:520{260},l:46{23}]"\??\C:\Windows\System32"\[l:20{10}]"tcpmon.ini"; source file in store is also corrupted
My System SpecsSystem Spec
28 Oct 2010   #9
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Ill look it over, but for now ME Bad, I should have told you about 3 times, is enough.
My System SpecsSystem Spec
28 Oct 2010   #10
richc46

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install
 
 

Ok this is what I know for a fact
SFC should fix that file.
If it does not a repair install is needed.
It may or may not correct your problem, but my guess is that it will
So its the above or system restore
or wait for other answers.

Whatever you decide, I wish you the best and will offer any help that you may need.
My System SpecsSystem Spec
Reply

 Win 7 X64 spooler issues.




Thread Tools




Similar help and support threads
Thread Forum
Print spooler keeps running
My print spooler keeps running and eats 10% of my i7. There is nothing in the print queue and I have not used the printer since weeks. I shut off the service but that is not a permanent solution. What could be the cause.
General Discussion
Print Spooler Error
Hello, I'm having problems with my mother's Laptop with the spooler, for some reason this keeps popping up everytime I want to "Add a printer", but I have watched a few video clips and I was thinking then.. In the services, the word "Print Spooler" don't exist on her laptop, BUT there is another...
Hardware & Devices
print spooler does not always start
i`ve just purchased a hp deskjet 3055a wirelesss printer. its set up to a home network with 3 pc`s using it 1 is xp home, 2 is win 7 hp 32bit and my main machine is win 7 hp 64bit. the last machine is giving me a problem it does not always turn on the print spooler service if i try turning it on...
Hardware & Devices
Print Spooler keeps stopping
I have seen numerous posts on this site and other sites about the Print Spooler repeatedly stopping but I have yet to see a good fix. At least for our PC. We have a Dell Vostro 220, Windows 7 Pro, Intel Core 2 E7500 @ 2.93GHz, 32-Bit OS with a Dell 1110 (USB) and a Dell 2330dn (Ethernet) hooked...
Drivers
Print Spooler
I have installed a hp laserjet p1006, with windows 7 x64 drivers. Printer shows installed, says working, but when attempting to print, all it shows is that document is spooling, then nothing happens. Checked windows system 32 printer file, nothing there. Does anyone have any suggestions. I have...
Hardware & Devices
PRINTER SPOOLER ISSUE! Please help me!
Well after spending about 20 hours of my life on researching this problem online and trying all kinds of "fixes" I am turing to this board for help. I have a Gateway FX 6802 - 64 bit computer running Windows 7. Brand new - purchased 2 months ago. I also have an Epson 1280 printer which I have...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:02.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App