Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win 7 Recovery

14 Nov 2010   #1
VClerk

Windows 7
 
 
Win 7 Recovery

I am running Windows 7, I've have the computer for just over a year and a couple of months ago, after an update was installed on my system, I could not get internet connection, and Office didn't work. The update said that it was a windows critical update. I can get it in the Safe mode with internet, so I did a system restore. Worked great until the system updated again.
So I've been playing this game for a while. Not sure what update caused the system to quit....but anyway, now when I try to do a system restore (and it does not matter what restore point I choose) I get:

%systemroot%registration
Destination: ComPlus Staging

I tried a registry cleaner from Pctools, I tried changing the Volume Shadow...it was disabled, so I changed it to automatic and stated it, but now it says that it is set to automatic but it is stopped.
Help. I don't know what else to do.


My System SpecsSystem Spec
.
15 Nov 2010   #2
Abhishek Ghosh

Windows 7 Ultimate 64 bit, Mac OS X 10.6
 
 

I would like to suggest that you check if the following two
services are disabled in the Windows server.

Microsoft Software Shadow Copy Provider
COM+ System Application

If they are disabled, please try to enable and start the service. Then try to backup again.

Please also check if the COM+ Class Registration Database is located in %systemroot%\registration directory. You can also check the Distributed COM Programs on this server comparing other server without problem. You can use Q323287. You can also check the Distributed COM
Programs on this server comparing other server without problem. You can use
Q323287.

Dierctory content of %systemroot%\registration is:
23.05.2006 21:35 <DIR> CRMLog
24.05.2006 16:42 23.248 R00000000000e.clb
24.05.2006 16:42 23.576 R00000000000f.clb
22.11.2006 10:14 1.048.576 {02D4B3F1-FD88-11D1....crmlog


HOW TO: Set Permissions for Distributed COM Programs in Windows : HOW TO: Set Permissions for Distributed COM Programs in Windows 2000

1. restore folder %systemroot%\Repair\Backup\BootableSystemState\ComRegistrationDatabase from a Shadowcopy.
The folder was empty, but I could restore a file called ComRegDb.bak which has the server installation date.
2. create a folder %systemroot%\Repair\Backup\BootableSystemState\Registry
3. create empty file %systemroot%\Repair\Backup\BootableSystemState\Registry\test.txt
My System SpecsSystem Spec
19 Nov 2010   #3
VClerk

Windows 7
 
 

I looked at the Microsoft Software Shadow Copy Provider, it was running, and automatic.
The COM+ System Application is in the manual mode, but it would not let me start it. So I am unable to backup still.


And I definately did not understand the following, I don't know how to get where I need to be. I used the Q323287 link, but either I'm dumb, but I didn't see the default security tab. I have no idea. So I couldn't do the below.

Please also check if the COM+ Class Registration Database is located in %systemroot%\registration directory. You can also check the Distributed COM Programs on this server comparing other server without problem. You can use Q323287. You can also check the Distributed COM
Programs on this server comparing other server without problem. You can use
Q323287.

Dierctory content of %systemroot%\registration is:
23.05.2006 21:35 <DIR> CRMLog
24.05.2006 16:42 23.248 R00000000000e.clb
24.05.2006 16:42 23.576 R00000000000f.clb
22.11.2006 10:14 1.048.576 {02D4B3F1-FD88-11D1....crmlog
My System SpecsSystem Spec
.

18 Jul 2011   #4
SebastianC

Windows 7 64 Professional
 
 

Hi VClerk,
I am getting exactly the same problem as the one you have described.
Did you mange to find a solution for it?
Thanks in advance.
My System SpecsSystem Spec
14 Oct 2011   #5
PattiChati

Windows 7 Home Premium SP 1, 32-bit
 
 

I have windows 7 and my system restore doesn't work either because of the message %systemroot%\registration.
I can keep the volume shadow on automatic, but it won't stay running. Any ideas?

I also cannot delete all of xoftspeSE and wondered if this had anything to do with the above
My System SpecsSystem Spec
Reply

 Win 7 Recovery




Thread Tools




Similar help and support threads
Thread Forum
Empty C:\Recovery folder when trying to create Recovery Disc
Hi all I'm new here, so I hope this is the right sub-forum for this question. I'm trying to create a Recovery disc for my laptop (Asus Zenbook), and as it doesn't have a CDROM, I'm following the instructions here 95 - Make a bootable Windows Recovery USB Flash drive from a Windows 7 system -...
Backup and Restore
Recovery not working and couldn't able tomake recovery partition activ
Product Name and Operating system: DV6 21124el (windows 7 ultimate 32bit) Hi, I have this laptop for the last 3 years and never used the recovery option as I didn't need to, the recovery partition is there never been formated, now my windows is too slow and wanted to restore it to factory...
Software
0xc000000f Recovery Error - System Recovery Discs not being processed
Hello, My computer has many corrupt files. I have done both sfc /scannow and chkdsk /r multiple times, but the corrupt files still remain. Unfortunately, my HP's recovery manager is also corrupt so I decided to do a full factory restore. Because I couldn't do a full factory restore from the...
Backup and Restore
Recover Deleted Windows 7 Recovery Files from Recovery Drive
Dear All, My colleague mistakenly deleted all the file from the Windows 7 recovery drive, drive is still there and nothing have been copied in that drive after deleting the recovery files. Machine is HP Probook 4530s. Is there any way to restore the windows 7 recovery reset the system to its...
General Discussion
Problem starting up after using samsing recovery basic recovery
After using samsung recovery, my computer won' t start properly. In normal mode it crashes immediately after loadin my background and desktop items. It shows a blue screen ( see image) and then will restart itself, giving me the option to start windows normally or in safe mode. I have tried safe...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App