Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD 0x00000050

04 Dec 2010   #1
majicninja

Windows 7 Ultimate x64
 
 
BSOD 0x00000050

I received this error a few minutes ago. Upon googling it microsoft stated there was a hotfix for this error. Upon downloading and going to install the fix it stated it was already installed.

My RAM, Video Card and Hard drives are not faulty. My processor is not faulty. My bios was updated May of this year. All my drivers are up to date.

I can not view the .dmp file in the dev tools because it states i have the wrong symbols. This i do not understand.

I am uploading the dmp file to see if any of you can help me with this error and get it fixed.


My System SpecsSystem Spec
.
04 Dec 2010   #2
Tepid

Win 7 Ultimate 32bit
 
 

You might also want to check the following,.,...
I am not saying this is it, but it will not hurt to check and make sure....


The computer may automatically restart, or you may receive a "serious error" message or a Stop error message in Windows Server 2003, in Windows XP, or in Windows 2000
My System SpecsSystem Spec
04 Dec 2010   #3
majicninja

Windows 7 Ultimate x64
 
 

Unfortunately that doesnt pertain to my version of windows. Windows 7 Ultimate x64 build 7600 is my version of windows.
My System SpecsSystem Spec
.

04 Dec 2010   #4
Tepid

Win 7 Ultimate 32bit
 
 

Read it anyway and see if this is an issue,.,,,, just cause it does not say Win 7,, does not mean it may not affect Win 7.

Probably should have mentioned that earlier,,, but,, as stated,, it will not hurt to check and make sure first. Could save you some time if that is what it is.
My System SpecsSystem Spec
04 Dec 2010   #5
majicninja

Windows 7 Ultimate x64
 
 

Ok my system isnt restarting automatically. Its blue screening out. It just did it again and said something about cdd.dll in it. Other than that I can not diagnose the problem because the symbols i have are not correct for some reason. This is a FRESH install of windows 7 ultimate x64. I have Windows 7 ultimate x32 on another PC and its not blue screening at all. I run AVG Full Antivirus Spyware and Rootkit.

Ran memtestx86 on both sticks of OCZ Gold edition RAM. Both pass test. So I know its not RAM Video or hard drive or my DVDRW.
My System SpecsSystem Spec
05 Dec 2010   #6
wish

Windows 7 Ultimate x64 SP1
 
 

Hi,
It seems your Asus driver is obsolete and must be updated ASAP.

Then uninstall RivaTuner because it has some issue with windows 7.

Update these drivers:
Code:
ASACPI.sys   Sun Mar 27 18:30:36 2005Asus ATK0110 ACPI Utility
Rt64win7.sys Thu Feb 26 01:04:13 2009 → Realtek NIC driver
Code:
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 50, {fffff900c345dcf0, 0, fffff960002acced, 0}


Could not read faulting driver name
Probably caused by : win32k.sys ( win32k!SFMLOGICALSURFACE::OwnsSurfaceCleanup+2d )

Followup: MachineOwner
---------

0: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

PAGE_FAULT_IN_NONPAGED_AREA (50)
Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arguments:
Arg1: fffff900c345dcf0, memory referenced.
Arg2: 0000000000000000, value 0 = read operation, 1 = write operation.
Arg3: fffff960002acced, If non-zero, the instruction address which referenced the bad memory
    address.
Arg4: 0000000000000000, (reserved)

Debugging Details:
------------------


Could not read faulting driver name

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80002ab10e0
 fffff900c345dcf0 

FAULTING_IP: 
win32k!SFMLOGICALSURFACE::OwnsSurfaceCleanup+2d
fffff960`002acced 488b4f20        mov     rcx,qword ptr [rdi+20h]

MM_INTERNAL_CODE:  0

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x50

PROCESS_NAME:  dwm.exe

CURRENT_IRQL:  0

TRAP_FRAME:  fffff880087dc920 -- (.trap 0xfffff880087dc920)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000011 rbx=0000000000000000 rcx=fffff900c761c570
rdx=00000000551238f7 rsi=0000000000000000 rdi=0000000000000000
rip=fffff960002acced rsp=fffff880087dcab0 rbp=0000000000000001
 r8=0000000000000000  r9=0000000000000000 r10=fffff900c2e2fb90
r11=0000000000000001 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
win32k!SFMLOGICALSURFACE::OwnsSurfaceCleanup+0x2d:
fffff960`002acced 488b4f20        mov     rcx,qword ptr [rdi+20h] ds:c570:00000000`00000020=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff800028f9f14 to fffff80002879740

STACK_TEXT:  
fffff880`087dc7b8 fffff800`028f9f14 : 00000000`00000050 fffff900`c345dcf0 00000000`00000000 fffff880`087dc920 : nt!KeBugCheckEx
fffff880`087dc7c0 fffff800`0287782e : 00000000`00000000 fffff900`c761c570 00000000`00000600 00000000`00000000 : nt! ?? ::FNODOBFM::`string'+0x42837
fffff880`087dc920 fffff960`002acced : 00000000`00000002 00000000`551238f7 00000000`551238f7 00000000`00000001 : nt!KiPageFault+0x16e
fffff880`087dcab0 fffff960`002ac1fe : fffff900`c761c570 00000000`00000000 000038f7`624d4653 00000000`0000001d : win32k!SFMLOGICALSURFACE::OwnsSurfaceCleanup+0x2d
fffff880`087dcae0 fffff960`002ad103 : 00000000`00000000 00000000`551238f7 fffff900`c761c570 00000000`01f48f40 : win32k!SFMLOGICALSURFACE::DeInitialize+0x4e
fffff880`087dcb20 fffff960`00209bf7 : 00000000`00000000 fffff900`c00bf010 fffff900`c761c570 00000000`00000020 : win32k!bhLSurfDestroyLogicalSurfaceObject+0x4b
fffff880`087dcb60 fffff960`0022aed0 : 00000800`00000001 00000000`00000001 fffff880`087dcca0 00000000`00000000 : win32k!GreSfmCloseCompositorRef+0x10f
fffff880`087dcba0 fffff800`02878993 : fffffa80`05db0b60 00000000`020ff600 000007fe`f9c7d610 00000000`00000000 : win32k!NtGdiHLSurfSetInformation+0x1a8
fffff880`087dcc20 000007fe`fea04efa : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`020ff058 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x7fe`fea04efa


STACK_COMMAND:  kb

FOLLOWUP_IP: 
win32k!SFMLOGICALSURFACE::OwnsSurfaceCleanup+2d
fffff960`002acced 488b4f20        mov     rcx,qword ptr [rdi+20h]

SYMBOL_STACK_INDEX:  3

SYMBOL_NAME:  win32k!SFMLOGICALSURFACE::OwnsSurfaceCleanup+2d

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: win32k

IMAGE_NAME:  win32k.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4c7dc13c

FAILURE_BUCKET_ID:  X64_0x50_win32k!SFMLOGICALSURFACE::OwnsSurfaceCleanup+2d

BUCKET_ID:  X64_0x50_win32k!SFMLOGICALSURFACE::OwnsSurfaceCleanup+2d

Followup: MachineOwner
---------
My System SpecsSystem Spec
05 Dec 2010   #7
majicninja

Windows 7 Ultimate x64
 
 

Updated the ACPI Utility and the Realtek Ethernet drivers. I do not have Riva Tuner installed on this pc. I use EVGA Precision. Easier to understand and I only use it to turn my fan up on my graphics card. No overclocking capabilities on this motherboard. So no sense in overclocking the video card. Thank you for helping me with the debugging. If i have any more problems with this I will be glad to post again.
My System SpecsSystem Spec
05 Dec 2010   #8
wish

Windows 7 Ultimate x64 SP1
 
 

You're welcome, hope that solve your problem
My System SpecsSystem Spec
Reply

 BSOD 0x00000050




Thread Tools




Similar help and support threads
Thread Forum
BSOD 0x00000050
Hello Recently I had problems with BSOD 0x0000003b. After updating Windows it disappeared. I overclocked my CPU to 4.5GHz and replaced my Radeon HD6970 to GTX 780 TI. Today while browsing internet new BSOD 0x00000050 popped out. My PC: Motherboard: Asus P8P67 rev 3.0 CPU: i5-2500K GPU:...
BSOD Help and Support
BSOD 0x00000050
Hi, Please, i need help to resolve this bsod. thankz
BSOD Help and Support
BSOD 0x00000050 Please help...
I literally have had this issue for months now. I have a Phenom II X4 955, 8GB Ripjaw ram, and an ASUS M5A78L-MLX Plus and every time I try to get drivers for the onboard video, I get 0x00000050. This also happens when trying to download something, or install something. I know it isn't the hard...
BSOD Help and Support
BSOD 0x00000050
Hi guys, I was getting this BSOD during League of Legends, after that I was running a full scan of Microsoft Security Essentials then got the same problem. Replaced RAM after I had some RAM failures, its the same RAM as I had before only new ones. I dont know if u need anymore information...
BSOD Help and Support
BSOD 0x00000050
Hi guys need some help. My computer was working fine on windows 7 32 bit. I tried to install an update for the Nvidia SMU driver and got a BSOD 0x00000050 nvsmu. I then thought seen as how my system would run better on x64 i will install this. Have to unidentified drivers in device...
BSOD Help and Support
BSOD 0x00000050
Hi my PC keeps on BSODing when doing random tasks on the computer it can be totaly random in time frames somtimes the computer works fine for a few hours and others its just a matter of minuetes before it crashes ive ran memory tests disk checks and all sorts and they have all came back with no...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:47.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App