Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD (Again)

11 Dec 2010   #21

Windows 7 Ultimate 32 bit

This crash occurred after only 25 seconds of uptime. This means it is most likely either a hard issue or a driver issue. Can you boot in the Safe mode without a BSOD? If you can, that points to a likely driver issue. If you get a BSOD in the Safe mode, it is likely a hardware issue. I see this BSOD occurred during a cold boot. A failing power supply can cause this.

Your dump blames wininit.exe for the crash. This file is a Windows system startup file. There are some viruses that disguise themselves as wininit.exe. I suggest you download and install Malwarebytes. Update it and then run a scan to make sure you don't have a nasty lurking about on your system.

I find two outdated drivers loaded on your system. The rest of your drivers look good. Update these two drivers and see if they make a difference.
LHidFilt.Sys Wed Jun 17 12:49:39 2009 - Logitech SetPoint HID Filter Driver. Downloads.

LMouFilt.Sys Wed Jun 17 12:49:43 2009 - Logitech SetPoint HID Filter Driver. Downloads.
Let me know if you can cold boot in the Safe mode without a BSOD. That will tell us what we should try next. If you can boot in the Safe mode, enable Driver Verifier. Driver Verifier will cause a BSOD if it encounters a problem driver. Upload any and all Driver Verifier enabled dumps. Follow the instructions in this tutorial precisely: Driver Verifier - Enable and Disable. If you get a BSOD in the Safe mode, run Memtest again from a cold boot after your computer has been off for a while. RAM - Test with Memtest86+

My System SpecsSystem Spec
11 Dec 2010   #22


Hi Carl. I only seem to get BSOD (most of the time) when I boot from a real cold start, i.e. after several hours of PC downtime so the safe mode test you suggest probably won't be too useful. I did however have a problem with driver verifier. I ran it and got a BSOD on restart resulting from RTKVHD64.sys which gave a stop error code 0.0000005.

I've uploaded the dumps here too. Note that the last 2 dumps from today (12/10/2010) are the ones relevant to the driver verifier (I missed the safe mode option once so got another BSOD before I turned off driver verifier).

I did not have any malware and have updated the logitech drivers also.
My System SpecsSystem Spec
11 Dec 2010   #23


So I had left my PC alone for a couple of hours and when I tried to reboot this time I had 'disk read error' press ctrl+alt+del to restart. I did and it restarted fine. Thought I'd mention it though. I've also reduced my RAM timings and voltage to 9-9-9-25 and 1.65V on the recommendation of someone I was talking to about RAM settings.
My System SpecsSystem Spec

11 Dec 2010   #24

Windows 7 Ultimate 32 bit

I see that you successfully updated the Logitech drivers. Very good. Your RTKVHD64.sys driver is up to date. The 0.0000005 error code means memory corruption. One of the two Driver Verifier enabled dumps contained no data; it is corrupt. Make sure Driver Verifier is turned off for now.

Run Memtest again from a cold boot after your computer has been off for at least two hours. RAM - Test with Memtest86+. I want to be as certain as we can be (Memtest is not perfect) that RAM is not causing the problem. Post your results.
Windows 7 Kernel Version 7600 MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16617.amd64fre.win7_gdr.100618-1621
Machine Name:
Kernel base = 0xfffff800`03059000 PsLoadedModuleList = 0xfffff800`03296e50
Debug session time: Sat Dec 11 14:10:18.711 2010 (GMT-5)
System Uptime: 0 days 0:00:25.428
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D5, {fffff98002e08d60, 0, fffff8800691cef6, 0}

Unable to load image \SystemRoot\system32\drivers\RTKVHD64.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for RTKVHD64.sys
*** ERROR: Module load completed but symbols could not be loaded for RTKVHD64.sys

Could not read faulting driver name
Probably caused by : RTKVHD64.sys ( RTKVHD64+d9ef6 )

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Memory was referenced after it was freed.
This cannot be protected by try-except.
When possible, the guilty driver's name (Unicode string) is printed on
the bugcheck screen and saved in KiBugCheckDriver.
Arg1: fffff98002e08d60, memory referenced
Arg2: 0000000000000000, value 0 = read operation, 1 = write operation
Arg3: fffff8800691cef6, if non-zero, the address which referenced memory.
Arg4: 0000000000000000, (reserved)

Debugging Details:

Could not read faulting driver name

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff800033010e0

fffff880`0691cef6 8b4630          mov     eax,dword ptr [rsi+30h]





PROCESS_NAME:  svchost.exe


TRAP_FRAME:  fffff88003cc82b0 -- (.trap 0xfffff88003cc82b0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=fffff88003cc84d8
rdx=fffff88003cc8440 rsi=0000000000000000 rdi=0000000000000000
rip=fffff8800691cef6 rsp=fffff88003cc8440 rbp=0000000000000002
 r8=0000000000000000  r9=fffff8800691cef6 r10=0000000000000000
r11=fffff80003243e80 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na po nc
fffff880`0691cef6 8b4630          mov     eax,dword ptr [rsi+30h] ds:3e80:00000000`00000030=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80003149f14 to fffff800030c9740

fffff880`03cc8148 fffff800`03149f14 : 00000000`00000050 fffff980`02e08d60 00000000`00000000 fffff880`03cc82b0 : nt!KeBugCheckEx
fffff880`03cc8150 fffff800`030c782e : 00000000`00000000 fffff8a0`0140910c fffffa80`07038000 fffff800`030fc33f : nt! ?? ::FNODOBFM::`string'+0x42837
fffff880`03cc82b0 fffff880`0691cef6 : fffff880`03cc84d8 00000000`00000000 fffff8a0`0140910c fffffa80`06d0ef40 : nt!KiPageFault+0x16e
fffff880`03cc8440 fffff880`03cc84d8 : 00000000`00000000 fffff8a0`0140910c fffffa80`06d0ef40 00000000`00000000 : RTKVHD64+0xd9ef6
fffff880`03cc8448 00000000`00000000 : fffff8a0`0140910c fffffa80`06d0ef40 00000000`00000000 fffff800`00000000 : 0xfffff880`03cc84d8


fffff880`0691cef6 8b4630          mov     eax,dword ptr [rsi+30h]



FOLLOWUP_NAME:  MachineOwner





BUCKET_ID:  X64_0xD5_VRF_RTKVHD64+d9ef6

Followup: MachineOwner
My System SpecsSystem Spec
11 Dec 2010   #25


Hi Carl. I'll do a memtest86+ run on each stick again, I guess I'll have the results by tomorrow afternoon maybe? I'll post as soon as I get them. Today and yesterday the system has only crashed from initial startup i.e. the first time it is turned on or if it left off for few hours before power up. Weird huh?
My System SpecsSystem Spec
11 Dec 2010   #26

Windows 7 Ultimate 32 bit

Yes it is weird and it really sounds like a power supply problem.
My System SpecsSystem Spec
11 Dec 2010   #27


Odd thing is, that wasn't how it happened before! It would BSOD in the middle of running Firefox or watching a movie!

*Sorry, ignore this. I actually had a bad RAM stick when I first had errors (it's being RMA's at the moment).
My System SpecsSystem Spec
12 Dec 2010   #28


As per usual, BSOD on first start up this morning. I'm running Memtest86+ now so I'll post the results when available. My error this time was BAD POOL HEADER Stop code 0x00000019. It also went into startup repair next boot and couldn't fix anything, thought it was a driver problem though. Do you want the dump file for this one too?

I read this post (see link below) about someone with a similar issue and they seemed to come to the conclusion it might be a hard disk issue? I only mention it because it's the same type of problem and I had that 'disk read error' yesterday. Any thoughts? I also did read another post where it was software related and clean install fixed all however...

It's all fun & games isn't it.
My System SpecsSystem Spec
12 Dec 2010   #29

Windows 7 Ultimate 32 bit

Run Check Disk
Run CHKDSK /R /F from an elevated (Run as adminstrator) Command Prompt. Please do this for each hard drive on your system.
When it tells you it can't do it right now - and asks you if you'd like to do it at the next reboot - answer Y (for Yes) and press Enter. Then reboot and let the test run. It may take a while for it to run, but keep an occasional eye on it to see if it generates any errors. See "CHKDSK LogFile" below in order to check the results of the test.

Elevated Command Prompt:
Go to Start and type in "cmd.exe" (without the quotes)
At the top of the Search Box, right click on Cmd.exe and select "Run as administrator"

Go to Start and type in "eventvwr.msc" (without the quotes) and press Enter
Expand the Windows logs heading, then select the Application log file entry.
Double click on the Source column header.
Scroll down the list until you find the Chkdsk entry (wininit for Windows 7).

Copy/paste the results into your next post.

I also suggest that your run an SFC (System File Checker) scan. SFC /SCANNOW Command - System File Checker.

My System SpecsSystem Spec
12 Dec 2010   #30


I tried to run a chkdsk on my secondary drive yesterday from in Windows (it's only got my work and pictures on it - no system files) and it got to the end of the scan and simply started again. I selected both the options to scan for and fix any errors. Is this usual? I also couldn't view the results of this in the event viewer. Should I have let in run through again?

I'm still on the memtest at the moment, stick 1 looks ok. I'll try stick 2 in a second then go onto the disk checking. I can also get copies of the Samsung and WD hard drive checkers for my respective drives. Should I use those too?
My System SpecsSystem Spec

 BSOD (Again)

Thread Tools

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:20.
Twitter Facebook Google+