Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Probabably cause by: cdrom.sys (BSOD Win7 64-bit)

05 Jan 2011   #1

Windows 7
Probabably cause by: cdrom.sys (BSOD Win7 64-bit)

Hello, I'm familiar with looking at dumps a bit but I just wanted to check with the good folks here before I blame some kind of CD-ROM driver. I am running Daeomon tools.

Strange thing is in device manager I see two entries for a CD rom driver. One says SCSI. I'm not sure what that may represent cause I dont have any SCSI devices unless I'm mistaken. (jpg attached)

Here's a paste. I attached the mini dump as well. Thanks for any info.

Use !analyze -v to get detailed debugging information.
BugCheck 1E, {0, 0, 0, 0}
Probably caused by : cdrom.sys ( cdrom!DeviceMainTimerTickHandler+b4 )
Followup: MachineOwner
0: kd> !analyze -v
* *
* Bugcheck Analysis *
* *
This is a very common bugcheck. Usually the exception address pinpoints
the driver/function that caused the problem. Always note this address
as well as the link date of the driver/image that contains this address.
Arg1: 0000000000000000, The exception code that was not handled
Arg2: 0000000000000000, The address that the exception occurred at
Arg3: 0000000000000000, Parameter 0 of the exception
Arg4: 0000000000000000, Parameter 1 of the exception
Debugging Details:

EXCEPTION_CODE: (Win32) 0 (0) - The operation completed successfully.
00000000`00000000 ?? ???
EXCEPTION_PARAMETER1: 0000000000000000
EXCEPTION_PARAMETER2: 0000000000000000
EXCEPTION_RECORD: fffff80004529288 -- (.exr 0xfffff80004529288)
ExceptionAddress: fffff88000c6bcd8 (cdrom!DeviceMainTimerTickHandler+0x00000000000000b4)
ExceptionCode: c0000005 (Access violation)
ExceptionFlags: 00000000
NumberParameters: 2
Parameter[0]: 0000000000000000
Parameter[1]: ffffffffffffffff
Attempt to read from address ffffffffffffffff
TRAP_FRAME: fffff80004529330 -- (.trap 0xfffff80004529330)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffffa800642d6b0 rbx=0000000000000000 rcx=fffffa8007d289c0
rdx=fffffa800642d550 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88000c6bcd8 rsp=fffff800045294c0 rbp=fffffa8007d6cf08
r8=fffffa800642d550 r9=fffffa8007d139f0 r10=fffffa8006df2d10
r11=fffffa8007d69b80 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0 nv up ei pl nz na pe nc
fffff880`00c6bcd8 ff15ba330000 call qword ptr [cdrom!_imp_IofCallDriver (fffff880`00c6f098)] ds:fffff880`00c6f098=0000000000027928
Resetting default scope
LAST_CONTROL_TRANSFER: from fffff800030c046e to fffff800030c8710
fffff800`04528378 fffff800`030c046e : 00000000`00000000 fffffa80`0764d001 fffff800`04528af0 fffff800`030f5668 : nt!KeBugCheck
fffff800`04528380 fffff800`030ee40d : fffff800`032d6b7c fffff800`03210e84 fffff800`03058000 fffff800`04529288 : nt!KiKernelCalloutExceptionHandler+0xe
fffff800`045283b0 fffff800`030f5a90 : fffff800`03217b14 fffff800`04528428 fffff800`04529288 fffff800`03058000 : nt!RtlpExecuteHandlerForException+0xd
fffff800`045283e0 fffff800`031029ef : fffff800`04529288 fffff800`04528af0 fffff800`00000000 fffffa80`07d6cf18 : nt!RtlDispatchException+0x410
fffff800`04528ac0 fffff800`030c7d82 : fffff800`04529288 0000057f`f82931e8 fffff800`04529330 fffffa80`07d6cf28 : nt!KiDispatchException+0x16f
fffff800`04529150 fffff800`030c668a : fffff800`04529390 fffff880`0185b3a3 00000000`00000000 00000000`00000000 : nt!KiExceptionDispatch+0xc2
fffff800`04529330 fffff880`00c6bcd8 : fffffa80`07d6ce10 fffffa80`05a50b60 fffff800`03242e80 fffff800`04529c58 : nt!KiGeneralProtectionFault+0x10a
fffff800`045294c0 fffff880`00f4ff19 : 00000000`00000000 fffff880`040cb698 fffff880`040d8d68 fffff880`040d8d68 : cdrom!DeviceMainTimerTickHandler+0xb4
fffff800`04529500 fffff880`00f4ff50 : fffff800`04529630 fffff800`04529648 00000000`00000004 00000000`00000000 : Wdf01000!FxTimer::TimerHandler+0xb5
fffff800`04529540 fffff800`030d429e : 00000000`00000000 fffff800`04529618 00000002`40114200 00000000`00000000 : Wdf01000!FxTimer::_FxTimerDpcThunk+0x18
fffff800`04529570 fffff800`030d3dd6 : fffffa80`05a50c68 fffffa80`05a50c68 00000000`00000000 00000000`00000000 : nt!KiProcessTimerDpcTable+0x66
fffff800`045295e0 fffff800`030d44be : 0000003a`bed9cd76 fffff800`04529c58 00000000`0018add1 fffff800`03246ca8 : nt!KiProcessExpiredTimerList+0xc6
fffff800`04529c30 fffff800`030d3cb7 : 00000012`666104cb 00000012`0018add1 00000012`6661043d 00000000`000000d1 : nt!KiTimerExpiration+0x1be
fffff800`04529cd0 fffff800`030d0eea : fffff800`03242e80 fffff800`03250c40 00000000`00000000 fffffa80`06f560f0 : nt!KiRetireDpcList+0x277
fffff800`04529d80 00000000`00000000 : fffff800`0452a000 fffff800`04524000 fffff800`04529d40 00000000`00000000 : nt!KiIdleLoop+0x5a

fffff880`00c6bcd8 ff15ba330000 call qword ptr [cdrom!_imp_IofCallDriver (fffff880`00c6f098)]
SYMBOL_NAME: cdrom!DeviceMainTimerTickHandler+b4
IMAGE_NAME: cdrom.sys
FAILURE_BUCKET_ID: X64_0x1E_0_cdrom!DeviceMainTimerTickHandler+b4
BUCKET_ID: X64_0x1E_0_cdrom!DeviceMainTimerTickHandler+b4
Followup: MachineOwner

My System SpecsSystem Spec
05 Jan 2011   #2

Windows 7

I also have Itunes installed and it started happening after I installed that along with the Adobe CS5 suite. I got this screenshot of a driver by Gearbox which wiki says they license their API to Apple used in iTunes for burning.
My System SpecsSystem Spec

 Probabably cause by: cdrom.sys (BSOD Win7 64-bit)

Thread Tools

Similar help and support threads
Thread Forum
CDRom no longer recognized.
Heya. My CDrom has suddenly stopped working, windows no longer recognizes it. I have tried replacing the cables, plugging it into a different port and replaced the CDrom all together with one that I know works. It will power up during the initial boot. Awhile ago it was announced that...
Hardware & Devices
My DVD/CDROM not working after update
Hello, After the latest update my dvd drive, which is an hl-dt-st-dvdram gt32n is not showing in windows explorer. I cannot burn anything. Windows explorer hangs repeatedly and I can't do a clean shutdown at all. I went to device manager and it told me that Windows did not start a related device...
Hardware & Devices
Can read CDROM, but not CD-R
I have W7 32bit with a DVD-RW drive that used to read/burn CD-R's fine, but now it won't do either. It will burn DVD's and read DVD's/CDROM's. Do you have any suggestions? Thx!
Hardware & Devices
BSDO after CDROM installed
Greetings! Been around for some time, but just registered. A couple days ago I tried to update a PCI Exrpress driver with Drivermax, I had condidence in that software, because it helped me move from Vista 32b to Win7 64b. Some hardware was not recognized and the software helped me with it. ...
BSOD Help and Support
DVD/CDROM not working
Hi all, About a two weeks ago my dvd drive stoped working (it could have been longer but I havent used the drive), this only a few weeks after upgrading to Windows 7. When looking in device manager my DVD drive is not recognised and I'm stuck what to do next. The DVD drive has power to it...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:18.
Twitter Facebook Google+