Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New memory works great in memtest/linux, crashes windows 7

30 Jan 2011   #1
7X64User

 
New memory works great in memtest/linux, crashes windows 7

Hello,
I have Windows 7 Professional 64bit. I got a new stick of 4GB DDR3 1333 memory. Whether I use it by itself or with another stick, the computer blue screens with random errors instantly when trying to boot Windows 7. A 2GB stick of the same speed from the same manufacturer works great in Windows 7. So you would think that the memory stick is bad. But I let it run a memtest86 test for over 8 hours, it made 6 passes and had no problems. Also passed a Windows Memory Diagnostic from the startup menu. I was able to boot into Ubuntu 64bit with no problems. It recognized the full 6GB and was passing a linux memtester test with no issues. So the memory seems to be good. Is there some setting that could cause Windows 7 64bit to crash with 4GB or more?

I should add that I can't boot into safe mode either. Random blue screens when the 4 colored dots are moving on the boot screen.


My System SpecsSystem Spec
.
30 Jan 2011   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by 7X64User View Post
Hello,
I have Windows 7 Professional 64bit. I got a new stick of 4GB DDR3 1333 memory. Whether I use it by itself or with another stick, the computer blue screens with random errors instantly when trying to boot Windows 7. A 2GB stick of the same speed from the same manufacturer works great in Windows 7. So you would think that the memory stick is bad. But I let it run a memtest86 test for over 8 hours, it made 6 passes and had no problems. Also passed a Windows Memory Diagnostic from the startup menu. I was able to boot into Ubuntu 64bit with no problems. It recognized the full 6GB and was passing a linux memtester test with no issues. So the memory seems to be good. Is there some setting that could cause Windows 7 64bit to crash with 4GB or more?
We need the dmp file to be sure, but can you run a system file check to verify you OS?

At the end there is a report that we need the results of

SFC /SCANNOW Command - System File Checker
My System SpecsSystem Spec
30 Jan 2011   #3
7X64User

 

Thank you for your reply. I just ran this using the working 2GB stick:

Beginning system scan. This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.

I will try rebooting and collecting some dump files now.
My System SpecsSystem Spec
.

Reply

 New memory works great in memtest/linux, crashes windows 7




Thread Tools




Similar help and support threads
Thread Forum
Built a new Windows 7 computer at work, works great
So, I thought that I would share a layout of a machine that I built at work as a workstation that was super easy to build and works great. Intel Core i7-3770 Asus P8Z77-V LK ATX mobo with EUFI BIOS 16GB G.Skill Ripjaw X Series (2 x 8GB) DDR3 1600 RAM Kit Samsung 22X DVD Burner SH-222BB 600W...
Hardware & Devices
W7 installer doesn't detect SATA after Linux, Linux works smoothly
OK, My config is HP G6 1075 SA with W7 Home Premium 64 bit pre-installed. It was working well until last week when I decided to install Debian Linux. I am no N00B to Linux and have installed it probably 100s of times. Debian installed and booted well but Windows BSODed with an error 0x0000225...
Installation & Setup
Netlimiter 1.3 Works Great windows 7 (64 bit)
The one program I was concerned about not working under Win7 x64 was Netlimiter. I've always hated the versions above 1.3 so on a whim I decided to ignore the "This software has known compatibility issues" warning and install it, after reading that 1.3 doesn't use device drivers like the newer...
Software
Windows 7 works great on the MacBook Pro
Source
News
Great, hardware HD acceleration works out of the box.
I have onbored Intel GMA X4500HD which intel claims has hardware acceleration for HD movie playback. I could never get this to work properly with vista even with the power dvd HD codec installed? I also tried all the dodgy codec packs available (which in my experience courses more harm than...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:06.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App