Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Almost all programs and processes crashing at launch!

12 Feb 2011   #11
x3m

Windows 7 Ultimate Retail (x64)
 
 

Quote   Quote: Originally Posted by ickymay View Post
If your system stays stable long enough type reliability history from the search and click all exclamation and red X marks for some clues in the description ?

from properties tools on your O/S drive schedule a disk check (tick both boxes) then boot back to safe mode after the diskcheck has run and from an elevated command prompt run sfc /scannow

let us know how it goes
Thanks again for the help!

Anyway, I checked the Reliability Hist and as I had described before all the errors are described only as "APPCRASH" with almost all being a "ntdll.dll" fail, but some show a "StackHash_####" [followed by a 4 digit number/letter combination - different in each one] fail [Name of the failed module].
I did try doing a repair install, but that didn't change much. The only thing that I did notice, is that during the 1st boot after the repair install, a message saying that the .NET Framework was corrupted and it was fixing it, but like any other program, it would crash before it resolved anything. I also tried downloading the framework and installing it manually, but it doesn't work in Safe Mode and in normal it also crashes. But this got me thinking that maybe this whole thing is a issue with the .NET....
Although it already has run diskcheck once, I'll try what you suggested and post back here... Thanks


My System SpecsSystem Spec
.
12 Feb 2011   #12
x3m

Windows 7 Ultimate Retail (x64)
 
 

Quote   Quote: Originally Posted by ickymay View Post
from properties tools on your O/S drive schedule a disk check (tick both boxes) then boot back to safe mode after the diskcheck has run and from an elevated command prompt run sfc /scannow

let us know how it goes
No luck...both came clean.
Seems harder and harder to find a solution for this...
but thanks for the help!
My System SpecsSystem Spec
13 Feb 2011   #13
ickymay

win7 ultimate / virtual box
 
 

np , at this stage I would systematically remove all installed programs one by one with system restore points and maybe take some educated guesses at whatever could be causing the problems ?

start by unninstalling Skype then Avast , replace with MSE or avira free ?

Do not run two AV at the same time as this could be the cause so remove Threatfire

If after working your way backwards on installs doesn't fix the problem then maybe try a repair install from within windows ?

keep us informed of progress
My System SpecsSystem Spec
.

14 Feb 2011   #14
x3m

Windows 7 Ultimate Retail (x64)
 
 

Quote   Quote: Originally Posted by ickymay View Post
np , at this stage I would systematically remove all installed programs one by one with system restore points and maybe take some educated guesses at whatever could be causing the problems ?

start by unninstalling Skype then Avast , replace with MSE or avira free ?

Do not run two AV at the same time as this could be the cause so remove Threatfire

If after working your way backwards on installs doesn't fix the problem then maybe try a repair install from within windows ?

keep us informed of progress
Thank you very much for the help Ickymay. But I have already done a clean install of Windows - I just was loosing to much time trying to fix the issue (and didn't feel like I was getting closer), so I decided it was better just to do it and get ir over with (was about time anyway).
For now it seems to have done the job since everything seems to be running fine. Unfortunetly it didn't resolve other issues I had before, but at least now I can open apps with no problem. Ill probably be back soon to try to resolve the issues still pending.

And on a side note: I don't think it was the AVs because I've been running both for years, and ThreatFire is made to run beside a normal AV. My main theory is a Virus (mainly think this because all the system restore points where gone...) or a bad program update, which must of have done something in a 32-bit registry, library, or whatever...

Thank you very much for the help again!
My System SpecsSystem Spec
15 Feb 2011   #15
ickymay

win7 ultimate / virtual box
 
 

a pleasure and glad you have it running happily again
My System SpecsSystem Spec
10 Feb 2012   #16
trico2000

Windows 7 pro 64 bit
 
 
resolve problem

Hi guys,

I had the same problem. After I instal the driver for wacom cintiq, I was not able to run some app. like photoshop, after effects, vlc player, toon boom etc. I read this whole forum, but without any conclusion.
I though that the only way how to fix it, is to reinstal my OS. Fortunately I have found this link>
Windows 7 explorer.exe keeps crashing - ntdll.dll fault - Microsoft Answers
I folowed it (except that I didnt turn it back to normal mode) and after I disabled the startup app. except microsoft services I was able to run the crashing programs. Than
I looked to the list of startup app in SERVICES panel, and I found that there is a check box for tablet service pen, so I uncheck it. After reboot its seems that everything is ok. Now Im going to uninstal everything that is connected to tablet and clean the registry for every case. Good luck.
My System SpecsSystem Spec
Reply

 Almost all programs and processes crashing at launch!




Thread Tools




Similar help and support threads
Thread Forum
Warcraft 3 crashing on launch windows 7
Just to note i have already tried blizzard support and they have failed to find a solution so here goes nothing. I click the launch icon for warcraft 3 frozen throne the launch icon with arthas appears the screen goes black then it crashes. Program: c:\program files (x86)\warcraft...
Gaming
all applications crashing on launch need help
something really stupid recently started happening with my computer in which trying to play video of any kind would cause explorer.exe to crash alongside windows media player, skype to crash on system boot, and crash on launch when i try to reopen it up to 15 times, same goes for windows media...
Software
All programs crashing randomly, won't launch afterwards
like title says, most if not all my program are suffering some kind of chain reaction crash bug. One will crash and then every other one that's also open will crash too and none of them work afterwards until I reboot. I have a fairly new ASUS F75VD laptop running 7 Home Premium x64 SP1.. I...
General Discussion
Programs Only Open In Safemode, Less Processes Loaded On Startup
After having scoured the internet for help, not really gotten anywhere, and feeling reinstalling windows might be my only option, I'm going to leave this here before I fall asleep and see if anyone can shed some light on this. I guess I should start from the start? Earlier I'd finished watching...
General Discussion
Programs show under processes, but not in Applications tab
Hi Most of my programs are not starting up correctly any more. They do appear in the list of processes after I try to start them from the start menu, but they do not show in the applications tab in Windows Task Manager. Also, no program window appears as well as no tray icon is shown. Resource...
BSOD Help and Support
Script to Check Processes then Launch
I would like a script that does the following: If ProcessA.exe NOT Running? Open ProgramA (Access link file) End If If ProcessB.exe NOT Running? Open ProgramB (Access link file) End If
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App