Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: windows 7 usb problem

22 Feb 2011   #1
Zyfer

windows 7 ultimate x86
 
 
windows 7 usb problem

Hello i have searched google all over to find out what my problem was but i really cant find anything matching it so here is the story

My windows 7 64bit hangs on starting windows and the only way i can really start my pc in 64 bit is this

Start the pc wait for it to freeze then unplug all usb when its frozen then restart the pc and wait for about 7-8 minutes and then the pc starts up

If i install the 86bit/32bit then it starts up just fine no problems and i can run vista64 bit without any problems

My keyboard is a logitech G11
My mouse is a logitech mx518
My headset is a Kave headset(it also has a usb)

All this happens even after a clean install and when i get into windows 7 i update everything would it work if i also updated windows 7 itself?

i really need some help on how to fix this thanks


My System SpecsSystem Spec
.
22 Feb 2011   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Zyfer View Post
Hello i have searched google all over to find out what my problem was but i really cant find anything matching it so here is the story

My windows 7 64bit hangs on starting windows and the only way i can really start my pc in 64 bit is this

Start the pc wait for it to freeze then unplug all usb when its frozen then restart the pc and wait for about 7-8 minutes and then the pc starts up

If i install the 86bit/32bit then it starts up just fine no problems and i can run vista64 bit without any problems

My keyboard is a logitech G11
My mouse is a logitech mx518
My headset is a Kave headset(it also has a usb)

All this happens even after a clean install and when i get into windows 7 i update everything would it work if i also updated windows 7 itself?

i really need some help on how to fix this thanks
So you can run vista 64, and win 7 32, but not win 7 64. Is all the hardware compatible with win 7 64 bit?

Do you have the correct drivers installed for the USB devices?

Please go to start>search>type device manager.
Are there any "unknown devices" with yellow triangles on them?
Is you driver there , listed, and working?

If your driver is missing, or there is a yellow triangle on it, you will need to update it.


What PSU? Any more (unpowered) USB devices installed?

Ken
My System SpecsSystem Spec
22 Feb 2011   #3
Zyfer

windows 7 ultimate x86
 
 

Now that actually makes alot of sense i will have to check that out when i come home and to be honest i have never ever ever updated my USB devices/ports and ive had the computer for 3 years now so it might be the problem

All my hardware is 64bit compatible and i guess 64bit win7 is also 64bit vista

I actually dont know what PSU i have but i have it because of my great need for heavy GFX i currently have a radeon HD5770 but i will check it out when i come home what the name is but i dont think the PSU will cause any problems
My System SpecsSystem Spec
.

22 Feb 2011   #4
Zyfer

windows 7 ultimate x86
 
 

i do not see the name on my PSU but i found out its 650watt and ive now checked if i needed to update any drivers but there was nothing no triangle or anything so the problem must lie somewhere else since its the usb ports that are causing the problems and i have 10 usb ports where 3 of them are being used
My System SpecsSystem Spec
22 Feb 2011   #5
Zyfer

windows 7 ultimate x86
 
 

well here is where i am now

Im on my 64bit system now its all installed but big problems are still here and yet they are still unexplainable

I can start windows if i press F8 and choose Boot logging.

Windows freezes on startup still if its normal startup

Windows freezes in safeboot the last thing i see that is loaded is CLASSPNP then it all just stops
Windows started once when i removed one of my ram and only ran 2gb instead of 4 but when i put the second one in again it froze again and the ram is not broken because it reads 4gb of ram

Windows can start on normal boot when all USB devices are removed from the ports
"note to self. Do not disable USB in Bios ever ever again"

so is there anyone who can help me? and do remember this is all after clean install and now all drivers are installed.
My System SpecsSystem Spec
22 Feb 2011   #6
Sardonicus

Windows 7 Home Premium 64 bit
 
 

What is your chipset or motherboard?
My System SpecsSystem Spec
22 Feb 2011   #7
Zyfer

windows 7 ultimate x86
 
 

MSI G33m MS-7357 Ver 1.0
My System SpecsSystem Spec
23 Feb 2011   #8
Zyfer

windows 7 ultimate x86
 
 

bumpdiclap
My System SpecsSystem Spec
Reply

 windows 7 usb problem




Thread Tools




Similar help and support threads
Thread Forum
Printer problem needs guru. Looks like Windows not Brother problem.
Windows 7 Professional Haven't had the need to use my printer in a couple of weeks, so I don't know when the problem started. It is a Brother HL-2270DW that has been problem free. There are tests that can be tried using the printer itself and it says it has a good connection and should be...
General Discussion
UI Problem/ minimized windows Display problem
Hi windows 7 community, I have a problem with windows 7 since the first day i've installed the OS (couple of years), and i haven't been able to solve it yet. The problem is that when i have a main application window, and different documents(windows) open in that main application window, when i...
General Discussion
Laptop Windows 7 Problem/Software/Hardware? Keyboard problem
Okay, right now I'm currently trying to find out whats wrong with a keyboard that is on a laptop, after the computer starts there are some script errors, I don't know exactly what they are but I ran combo fix without safe mode and restarted the scripts went away...and it started working after...
Hardware & Devices
Moving windows/icons down problem!! Move right/left/up - no problem
New system i7 3930K CPU Sabertooth X79 Mortherboard GeForce GTX690 GPU Intel 520 series SSD 32GB RAM Dell U2711 27" Monitor Win 7 Pro
General Discussion
Windows 7 Not genuine Problem. And 404 error (security?) Problem.
Hi, ive had both of these problems for about two weeks and have tried to fix it myself. No luck at all. Dont no of their connected. Help on how to fix it would be greatly appreciated.
BSOD Help and Support
Windows Media Player Problem - Sound/skipping problem.
Oh look, another windows media player problem, lol. Well, it's something really weird, at first i thought it was just my computer being all slow or the file was messed up, No matter what movie or format i play it makes this weird screeching noise. It also lags pretty bad. I tried the scans, i did...
Music, Pictures & Video


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App