Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: c:\mon.bat not recognized as an internal

25 Feb 2011   #1

Windows 7 32bit sp1
c:\mon.bat not recognized as an internal

I have windows 7 sp1 and when i try to run an ms dos program found in c:\fir directory i get this error :

'c:\mon.bat' is not recognized as an internal or external command, operable program or batch file.

When I had windows 7 without sp1 it worked fine.
Please help.This program receives data from another comp trough lan. Thank You.

My System SpecsSystem Spec
25 Feb 2011   #2

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

If the batch is in C:\fir directory, you need to type mon.bat at the C:\fir prompt, then hit Enter.
My System SpecsSystem Spec
25 Feb 2011   #3

Windows 7 32bit sp1

To enter the program I use a file called gestoc.bat (not cmd) and its entering the program but when I select the option I need from the menu and hit enter it gives me that quick error and exits out very quickly, I've managed to see the error message with a quick printrscreen.Gestoc.bat it is in the same directory.
My System SpecsSystem Spec


 c:\mon.bat not recognized as an internal

Thread Tools

Similar help and support threads
Thread Forum
Internal network adapter not recognized
I've been dealing with this issue off and on for a while so I'm hoping somebody knows how to fix this! I have a Lenovo Ideapad Z575. I recently installed a clean copy of Win7 Home premium 64 bit and was able to update all drivers except for the wireless lan one which I downloaded from the Lenovo...
Hardware & Devices
'ipconfig' is not recognized as an internal or external command, . . .
I am getting a message as above if I attempt to execute ipconfig. I tried another machine but the same message returns. What could be wrong?
Network & Sharing
Internal hard drive not recognized
My system consists of 2 500 GB drives in RAID 1 and a 3rd 1 TB drive for storage and backup. All are SATA drives. System is about 6 months old. The 1 TB drive is about 1.5 years old and was used in my prior system, but had been reformatted and was working just fine in my new system up until now. ...
Hardware & Devices
Internal HDD usb connection not recognized for some reason
Hello there, I have an internal Western Digital HDD that I used to connect to my laptop via a sata to usb adaptor (company name: KONG). Recently it stopped working for no reason - I tried it in 2 PC's. Any idea have to fix it? Thanks in advance. :geek: Edit:
Hardware & Devices
Internal Hard drive Not Recognized
Hi forum I just installed windows 7 and noticed that my internal hard drive is being recognized as an external disk drive. Whats going on and how do i change it? My hard drive is a TOSHIBA MK3252GSX ATA Device, my computer is an hp dv5 thanks
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:53.
Twitter Facebook Google+