Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD after installing RAID 0

24 Mar 2011   #1
Slashmolder

Windows 7 Ultimate x64
 
 
BSOD after installing RAID 0

Ever since I set up a RAID 0 setup my computer crashes whenever I try to do a windows update. Halfway though an update, no matter what I do, the computer decides to BSOD on me.

Basic Computer Information:
Bought the core components in summer of '09
Upgraded GPU, added SSD, and added second HDD summer/fall '11
Windows 7 x64, got from MSDN back when I had a subscription which has now expired.
4GB of DDR2 RAM
3.0 GHz AMD Phenom IIx4
Biostar TA790GXB A2+ mobo
1 128 GB SSD
2x 660 GB HDD

For a while I've had my computer setup like this:
C: (128GB PNY SSD) for my windows install
D: (660GB WD HDD) for storage and my windows user profile
E: (660GB WD HDD of the same model as the other) for Ubuntu

I today decided that since I haven't used my Linux HardDrive in over a month that I'd try to RAID my two identical HDDs to have one large drive with faster speeds. Since I didn't care to figure out how to replace my old drivers with the RAID drivers of biostar's website. So instead I backed up all my information onto an external harddrive and installed Windows 7 fresh again.

My setup was now this:
C: (128 GB SSD) with windows installed on it.
D: (1.2 TB RAID 0) for storage and my user profile

After a smooth installation I booted into windows, installed some drivers and started updating. Everything went fine and my computer restarted. After the restart two updates were left: a Security Update for .net 4 and Service Pack 1. Whenever I attempt to install either of these two updates it downloads all the way and then starts to install. Half way though the install I get a BSOD. Your help is very much appreciated

Edit: after shutting down my computer it tried to install an update. Now it won't even stay in Windows for a minute without crashing. Safe mode is doing the same thing.


My System SpecsSystem Spec
.
25 Mar 2011   #2
usasma
Microsoft MVP

 
 

If you're overclocking, please return the system to normal values while we troubleshoot. If there's a problem with the overclock it'll show as a hardware problem until the system is returned to stock values - so stopping the overclock is the way to troubleshoot these issues (and prevent having to replace hardware unnecessarily)

The errors in MSINFO32 suggest that there may be a problem with your hard drive(s) - this can also be caused by a rootkit. Please run the following free diagnostics:
Quote:
I suggest starting all troubleshooting with the following diagnostic tests. They'll save you a lot of time and heartache if there is a hardware failure, and you'll have the disks on hand in case you need them in the future:
Quote:
H/W Diagnostics:
Please start by running these bootable hardware diagnostics:
Memory Diagnostics (read the details at the link)
HD Diagnostic (read the details at the link)

Also, please run one of these free, independent online malware scans to ensure that your current protection hasn't been compromised: Free Online AntiMalware Scanners (read the details at the link)
Older versions of the ATI Catalyst Control Center may have BSOD issues with some systems. Please uninstall the Catalyst Control Center and see if that helps to stop the BSOD's.

OLDER DRIVERS PRESENT IN THE DUMP FILES
- Please update these drivers from the device manufacturer's website - or uninstall/remove them from your system. Reference links included below.
- DO NOT use Windows Update or the Update Drivers function of Device Manager.
- Please feel free to post back about any drivers that you are having difficulty locating.
- Windows Update exceptions may be noted below for Windows drivers:
Quote:
Code:

amdsbs.sys        Fri Mar 20 14:36:03 2009 (49C3E213)
ahcix64s.sys      Tue Mar 17 02:38:19 2009 (49BF455B)
netr6164.sys      Wed Apr 07 08:07:21 2010 (4BBC7579)
Rt64win7.sys      Thu Feb 26 04:04:13 2009 (49A65B0D)
amdiox64.sys      Thu Feb 18 10:17:53 2010 (4B7D5A21)
AtihdW76.sys      Wed Nov 17 07:02:04 2010 (4CE3C43C)
dump_ahcix64s.sys Tue Mar 17 02:38:19 2009 (49BF455B)
BS_I2cIo.sys      Mon Jun 16 02:45:18 2008 (48560BFE)
usbfilter.sys     Fri Apr 03 07:39:51 2009 (49D5F587)
hidbth.sys        Mon Jul 13 20:06:52 2009 (4A5BCC1C)
WinUsb.sys        Mon Jul 13 20:06:28 2009 (4A5BCC04)
RTKVHD64.sys      Thu Feb 24 05:19:18 2011 (4D6630A6)
atikmdag.sys      Wed Jan 26 17:48:28 2011 (4D40A4BC)

http://www.carrona.org/dvrref.html#amdsbs.sys
http://www.carrona.org/dvrref.html#ahcix64s.sys
http://www.carrona.org/dvrref.html#netr6164.sys
http://www.carrona.org/dvrref.html#Rt64win7.sys
http://www.carrona.org/dvrref.html#amdiox64.sys
http://www.carrona.org/dvrref.html#AtihdW76.sys
http://www.carrona.org/dvrref.html#dump_ahcix64s.sys
http://www.carrona.org/dvrref.html#BS_I2cIo.sys
http://www.carrona.org/dvrref.html#usbfilter.sys
http://www.carrona.org/dvrref.html#hidbth.sys
http://www.carrona.org/dvrref.html#WinUsb.sys
http://www.carrona.org/dvrref.html#RTKVHD64.sys
http://www.carrona.org/dvrref.html#atikmdag.sys
BSOD BUGCHECK SUMMARY
Code:

Built by: 7600.16695.amd64fre.win7_gdr.101026-1503
Debug session time: Thu Mar 24 23:37:10.102 2011 (UTC - 4:00)
System Uptime: 0 days 0:42:16.006
BugCheck F4, {3, fffffa80050442e0, fffffa80050445c0, fffff80002f8e2d0}
Probably caused by : csrss.exe
PROCESS_NAME:  csrss.exe
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0xF4_C0000005
FAILURE_BUCKET_ID:  X64_0xF4_C0000005_IMAGE_csrss.exe
Bugcheck code 000000F4
Arguments 00000000`00000003 fffffa80`050442e0 fffffa80`050445c0 fffff800`02f8e2d0
BiosVersion = 080014 
BiosReleaseDate = 05/25/2009
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16695.amd64fre.win7_gdr.101026-1503
Debug session time: Thu Mar 24 22:53:41.332 2011 (UTC - 4:00)
System Uptime: 0 days 0:03:45.846
BugCheck F4, {3, fffffa800500db30, fffffa800500de10, fffff80002fd02d0}
Probably caused by : csrss.exe
PROCESS_NAME:  csrss.exe
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0xF4_C0000005
FAILURE_BUCKET_ID:  X64_0xF4_C0000005_IMAGE_csrss.exe
Bugcheck code 000000F4
Arguments 00000000`00000003 fffffa80`0500db30 fffffa80`0500de10 fffff800`02fd02d0
BiosVersion = 080014 
BiosReleaseDate = 05/25/2009
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16695.amd64fre.win7_gdr.101026-1503
Debug session time: Thu Mar 24 22:48:48.896 2011 (UTC - 4:00)
System Uptime: 0 days 0:18:57.784
BugCheck F4, {3, fffffa8005aacb30, fffffa8005aace10, fffff80002fd12d0}
Probably caused by : csrss.exe
PROCESS_NAME:  csrss.exe
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0xF4_C0000005
FAILURE_BUCKET_ID:  X64_0xF4_C0000005_IMAGE_csrss.exe
Bugcheck code 000000F4
Arguments 00000000`00000003 fffffa80`05aacb30 fffffa80`05aace10 fffff800`02fd12d0
BiosVersion = 080014 
BiosReleaseDate = 05/25/2009
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16695.amd64fre.win7_gdr.101026-1503
Debug session time: Thu Mar 24 21:37:02.282 2011 (UTC - 4:00)
System Uptime: 0 days 0:05:12.186
BugCheck F4, {3, fffffa8004ff3b30, fffffa8004ff3e10, fffff80002fe12d0}
Probably caused by : csrss.exe
PROCESS_NAME:  csrss.exe
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0xF4_C0000005
FAILURE_BUCKET_ID:  X64_0xF4_C0000005_IMAGE_csrss.exe
Bugcheck code 000000F4
Arguments 00000000`00000003 fffffa80`04ff3b30 fffffa80`04ff3e10 fffff800`02fe12d0
BiosVersion = 080014 
BiosReleaseDate = 05/25/2009
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16695.amd64fre.win7_gdr.101026-1503
Debug session time: Thu Mar 24 21:27:43.726 2011 (UTC - 4:00)
System Uptime: 0 days 0:02:19.630
BugCheck F4, {3, fffffa80050214c0, fffffa80050217a0, fffff80002f7c2d0}
Probably caused by : hardware_disk
PROCESS_NAME:  csrss.exe
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0xF4_IOERR_C000009D
FAILURE_BUCKET_ID:  X64_0xF4_IOERR_C000009D_IMAGE_hardware_disk
Bugcheck code 000000F4
Arguments 00000000`00000003 fffffa80`050214c0 fffffa80`050217a0 fffff800`02f7c2d0
BiosVersion = 080014 
BiosReleaseDate = 05/25/2009
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16695.amd64fre.win7_gdr.101026-1503
Debug session time: Thu Mar 24 21:24:14.120 2011 (UTC - 4:00)
System Uptime: 0 days 0:06:19.024
BugCheck F4, {3, fffffa8004f86b30, fffffa8004f86e10, fffff80002fc62d0}
Probably caused by : csrss.exe
PROCESS_NAME:  csrss.exe
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0xF4_C0000005
FAILURE_BUCKET_ID:  X64_0xF4_C0000005_IMAGE_csrss.exe
Bugcheck code 000000F4
Arguments 00000000`00000003 fffffa80`04f86b30 fffffa80`04f86e10 fffff800`02fc62d0
BiosVersion = 080014 
BiosReleaseDate = 05/25/2009
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16695.amd64fre.win7_gdr.101026-1503
Debug session time: Thu Mar 24 21:16:56.674 2011 (UTC - 4:00)
System Uptime: 0 days 0:03:08.578
BugCheck F4, {3, fffffa800500ab30, fffffa800500ae10, fffff80002fca2d0}
Probably caused by : hardware_disk
PROCESS_NAME:  csrss.exe
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0xF4_IOERR_C000000E
FAILURE_BUCKET_ID:  X64_0xF4_IOERR_C000000E_IMAGE_hardware_disk
Bugcheck code 000000F4
Arguments 00000000`00000003 fffffa80`0500ab30 fffffa80`0500ae10 fffff800`02fca2d0
BiosVersion = 080014 
BiosReleaseDate = 05/25/2009
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16695.amd64fre.win7_gdr.101026-1503
Debug session time: Thu Mar 24 21:12:33.118 2011 (UTC - 4:00)
System Uptime: 0 days 0:14:06.022
BugCheck F4, {3, fffffa80052e4920, fffffa80052e4c00, fffff80002f842d0}
Probably caused by : csrss.exe
PROCESS_NAME:  csrss.exe
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0xF4_C0000005
FAILURE_BUCKET_ID:  X64_0xF4_C0000005_IMAGE_csrss.exe
Bugcheck code 000000F4
Arguments 00000000`00000003 fffffa80`052e4920 fffffa80`052e4c00 fffff800`02f842d0
BiosVersion = 080014 
BiosReleaseDate = 05/25/2009
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16695.amd64fre.win7_gdr.101026-1503
Debug session time: Thu Mar 24 20:56:57.891 2011 (UTC - 4:00)
System Uptime: 0 days 0:37:22.795
*** WARNING: Unable to verify timestamp for fvevol.sys
*** ERROR: Module load completed but symbols could not be loaded for fvevol.sys
Probably caused by : storport.sys ( storport!RaUnitScsiIrp+3ba )
BUGCHECK_STR:  0x7a_c000009d
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
PROCESS_NAME:  System
FAILURE_BUCKET_ID:  X64_0x7a_c000009d_storport!RaUnitScsiIrp+3ba
Bugcheck code 0000007A
Arguments 00000000`00000020 ffffffff`c000009d fffffa80`0511f078 00000000`00000000
BiosVersion = 080014 
BiosReleaseDate = 05/25/2009
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
Built by: 7600.16695.amd64fre.win7_gdr.101026-1503
Debug session time: Thu Mar 24 20:17:51.536 2011 (UTC - 4:00)
System Uptime: 0 days 0:01:07.050
BugCheck F4, {3, fffffa8004ffcb30, fffffa8004ffce10, fffff80002fd92d0}
Probably caused by : hardware_disk
PROCESS_NAME:  csrss.exe
DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
BUGCHECK_STR:  0xF4_IOERR_C000009D
FAILURE_BUCKET_ID:  X64_0xF4_IOERR_C000009D_IMAGE_hardware_disk
Bugcheck code 000000F4
Arguments 00000000`00000003 fffffa80`04ffcb30 fffffa80`04ffce10 fffff800`02fd92d0
BiosVersion = 080014 
BiosReleaseDate = 05/25/2009
ииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииииии``
  
  
My System SpecsSystem Spec
25 Mar 2011   #3
Slashmolder

Windows 7 Ultimate x64
 
 

After a system restore I was again able to use my computer up until I tried to install something again.
I ran the check and there is indeed a few bad blocks on my SSD according to HD Tune. I'm guessing I need to RMA it so I'm installing Windows 7 again on my RAID array and then will go though that process. I was unable to, however, find updates to most of the drivers you listed to being out of date.
My System SpecsSystem Spec
.

26 Mar 2011   #4
usasma
Microsoft MVP

 
 

With the fresh install of Win7 - which drivers are missing/outdated?
My System SpecsSystem Spec
26 Mar 2011   #5
Slashmolder

Windows 7 Ultimate x64
 
 

[QUOTE=usasma;1310146]
Quote:
Code:

amdsbs.sys        Fri Mar 20 14:36:03 2009 (49C3E213)
ahcix64s.sys      Tue Mar 17 02:38:19 2009 (49BF455B)
netr6164.sys      Wed Apr 07 08:07:21 2010 (4BBC7579)
Rt64win7.sys      Thu Feb 26 04:04:13 2009 (49A65B0D)
amdiox64.sys      Thu Feb 18 10:17:53 2010 (4B7D5A21)
AtihdW76.sys      Wed Nov 17 07:02:04 2010 (4CE3C43C)
dump_ahcix64s.sys Tue Mar 17 02:38:19 2009 (49BF455B)
BS_I2cIo.sys      Mon Jun 16 02:45:18 2008 (48560BFE)
usbfilter.sys     Fri Apr 03 07:39:51 2009 (49D5F587)
hidbth.sys        Mon Jul 13 20:06:52 2009 (4A5BCC1C)
WinUsb.sys        Mon Jul 13 20:06:28 2009 (4A5BCC04)
RTKVHD64.sys      Thu Feb 24 05:19:18 2011 (4D6630A6)
atikmdag.sys      Wed Jan 26 17:48:28 2011 (4D40A4BC)
I believe all those drivers that were in the first post you made, unless I am misinterpreting what you said.
My System SpecsSystem Spec
27 Mar 2011   #6
usasma
Microsoft MVP

 
 

Those are the drivers from the dump files that I analyzed before you reformatted.
FWIW - most of the drivers are available here: BIOSTAR :: TA790GXB A2+ :: Driver
Then wait for another BSOD and we'll see what else is missing.
My System SpecsSystem Spec
Reply

 BSOD after installing RAID 0




Thread Tools




Similar help and support threads
Thread Forum
installing new SSD raid or AHCI ??
ok I got my new 250gb ssd, I been reading up on ssd and some say install with raid others say AHCI, and some say AHCI then after windows install switch to raid??? I plan on using this to put windows on, then I have a 1tb hdd that I have portioned into 4 200gb each that I plan to use for installing...
PC Custom Builds and Overclocking
Removing RAID and Installing Windows 7
I attempted to do a reinstall of windows 7 as I've been having some issues with this laptop (Lenovo U410) out of the box. After making a bootable usb with windows 7 it failed to recognize the hard drives (I have a 32 GB SSD and 750 GB HDD). I had no idea why it couldn't and with a failed attempt...
Installation & Setup
Removing Raid O designation and installing a New SSD
I currently have a Dell Studio 7100 AMD 1090T with two 750 gb Baracudas in a Raid 0 configuration. My MOB is sata 2 only. I wish to undo the Raid and make them individual drives. I am adding a sata 3 card along with a new Samsung 830 256 gb ssd drive configured as the start up drive and working...
Hardware & Devices
Installing Windows 7 Getting Rid of RAID
Hi guys I will be upgrading to Win7 soon from XP and i have a few questions before i jump in head first :D So basicly i have a RAID0 setup at the mo on 2 500gb SATA drives and reading on here and other places tht really i gain no extra performance on it and just upping my risk of loosing my...
Installation & Setup
Installing SSD on an existing RAID system?
Hi, I'm currently using Windows 7 Professional and have 4 internal HD's set up in RAID. Current Setup: 2 - 500GB drives in RAID 0 2 - 500GB drives in RAID 1 I use the RAID 1 drives for backup purposes only.
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

й Designer Media Ltd

All times are GMT -5. The time now is 13:56.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App